Zwift Hub Autocalibration [Firmware v4.0]

Contact support. You may need a new trainer.

I’m running 3.9 firmware and having a problem. If the flywheel is spinning quickly (on a descent for instance) and I stop pedalling, it is still reporting watts. Over 7-10 seconds it will drop and then hover around 20w before it finally drops to 0. Not ideal in a zwift race when the pack are all in a supertuck catching breath and you cant because the power is stuck on 20w.

I don’t know if this is just common with the Zwift Hub or just a fault with my turbo. I’ve tried both Bluetooth, bridging over the companion app and also Ant+ on MacOS, Windows and Android versions - same issue across all platforms. I’ve tried a different turbo (Kickr) and that works fine so its obviously the Hub. I hope this is something that can be addressed in a firmware update.

1 Like

I performed the firmware upgrade, and it appeared to work. However, after the update, when I attempted to select the Zwift Hardware menu option, I got a popup asking me to pair my phone to the zwift hub (a Bluetooth pairing request). I clicked ‘okay’ on that popup, but it just kept redisplaying the popup until finally it just showed my zwift hub as disconnected. It gave me the option to ‘forget’, and unfortunately I clicked that thinking that if I closed the companion app and reopened it, that the Zwift Companion app could rediscover the device.

Now when I click the Zwift Hardware menu option, I get a window saying ‘No Zwift Hardware Found’ , and the bluetooth pairing request cycle starts again. Eventually the popups stop displaying leaving me with just the ‘No Zwift Hardware Found’ message and a button to retry. The retry button just repeats the Bluetooth Pairing request popup.

Interestingly enough, the zwift hub led does go from a blinking blue light to a solid blue light while the bluetooth pairing request popup is displayed, but eventually will start blinking blue again .

I reinstalled the Zwift Companion and it is the current version (it was the current version before the problem occurred as well). I do have the location permission for the ZC set correctly as well.

Any help would be appreciated. I am able to ride with the current state of this problem, but would not be able to update firmware if a new version came out later this year given my Zwift hub doesn’t show up anymore as a hardware device.

@shooj Is there any news on when firmware version 4.0 will be rolled out to all? I have my replacement trainer but I’m reluctant to return my old one while the new one is still on v3.9 I would like to be able to get my replacement trainer on to v4.0 and test everything works first but it isn’t available

My companion app was showing a new firmware is available last night. Maybe a new build is making the rounds. Not installing it yet, though.

I just updated to firlware version 4.0 and now the hub is not connecting anymore, it refuses all bleutooth connections and the blue light keeps flashing…
Tried everything suggested here.

Same as Douglas above with one exception - I could only ride by replacing the bluetooth dongle with an ANT+ dongle. I hope this can be fixed so I can use bluetooth.

What is temporarily working for me is connecting to the companion app on iOS and then setting zwift to use the companion app instead of directly connecting to the hub. This can be done by selecting the gear menu on the top right. Not sure if that’ll work for you, depends on your setup and the problems you’re having.

Just want to report the same problem after the update. Zwift will often show 2-5W causing me to not aero tuck…
And to be clear, this was not a problem before the update.

Now I’m starting to doubt my recent PR’s as well :frowning:

Does is hit 0w eventually? Mine will but only after the flywheel drops to a low enough rpm, which can take a while sometimes!

I also updated to v4 a few days ago and experience similar problems as described above. Companion app can’t find the hub at all and prompts for retries in a loop but never finds it. On my regular win10 PC it will connect but immediately gets ‘No signal’. Finally I tried my work win10 laptop and THERE it will connect perfectly. So at least I can use it now but hopefully a fix will be out soon…

After 10-15sec it settles at 0W so the flywheel speed might be a factor. The first 10-15sec also contain some random false cadence spikes.

@shooj Just going to tag the Community Forum Manager as well :slight_smile:

1 Like

The trainer connection just crapped out on me 45 minutes into a race which was super frustrating. All attempts to reconnect to the trainer through both the companion app and directly to the PC wouldn’t work until I unplugged the trainer and plugged it back in.

As a follow-up to my post earlier about the Companion App not showing my Hub anymore after I updated to firmware V4, Zwift customer support reached out to me and are sending me a replacement unit. I have boxed up my current unit to return to them. Not sure why a firmware upgrade is such a big deal, but this is the solution they are providing. I have no clue what firmware version is going to be on the new unit, but will think twice about installing any new versions in the future.

A replacement trainer is the weirdest solution that keeps being mentioned, as a fix for something wrong with the firmware. Is support telling you that newer replacements will not have an issue with the same firmware?

My replacement trainer has firmware version 3.9 and every time I check, it says firmware is up-to-date, so I don’t know what will happen if/when V4 is offered.

They may have withdrawn v4 due to these issues. It sounds like it bricked a lot of trainers. Personally I would not update the firmware until a lot of people report success. Let someone else beta test it.

that’s always the mystery with forums… Are the 2% with issues the only ones you read about, and it’s fine for the other 98%? Same question on the iPhone14/CA thing… Zwift presumably has iPhone14 somewhere and they can’t reproduce the problem being reported.

1 Like

Yep, hard to interpret negative signals without positive signals as well. But at some point people will show up here with Hub questions and it will come out that they are using v4 firmware successfully. Until that time I would run 3.9. The apparent lack of a rollback feature makes it too risky.

With iOS 16 we’ve heard from people using it successfully. Even so, I waited for several months before deciding to update my older iPhone (works fine). I saw many positive reports from people with similar hardware so I concluded it was safe. Also there is a path back to the older iOS.

Support would not comment on their reasoning despite specific questions about the firmware and their ability to fix a existing unit without returning it. I did not ask what firmware version the new is coming with.

I did search the forum for problems being reported (such as this thread) before I decided to upgrade from V3.9 to V4 and it seemed like the release was okay, plus it had been out for weeks at that point. Like Paul said above, its a crapshoot. I normally don’t upgrade firmware, but I wanted autocalibration. I suspect others feel the same. And my trainer was still working, just not seeing it on Zwift Companion anymore. Kind of bizarre.