Zwift hangs for a second


(Haykel Barhoumi) #1

Hi,

I’m experiencing hang/freeze whilst in-game every couple of mins for 1-2 seconds long. When the freeze occurs I don’t appear to lose my position when in group rides. This happens on every workout and I’ve been checking zwiftalizer and the issue doesn’t appear to be graphical, network, ANT+ related. I also noticed the issue is still occurring when in watch mode.

Also tried settings my graphical settings to the lowest setting, but the problem still occurs. Also when the hang occurs the mouse cursor keeps appearing.

I’m running;
Dell XPS15 9750
Windows 10
i7 8750H
16GB RAM
Nvidia 1050ti


(Gerrie Delport) #2

Did you try to change from windowed to full screen mode.


(Haykel Barhoumi) #3

Hi, Always running in fullscreen mode.


(Gerrie Delport) #4

Try windowed mode.

Do you have a dual monitor setup?

Google “screen losing focus in games”

There must be something on your PC that take priority of your screen. I have seen some posts in the gaming community of this happening.


(Haykel Barhoumi) #5

Hi,

I usually hook it to a TV via HDMI, but I’m also experiencing this issue when not using any external displays. The same thing happens in window mode.

P.S. the cursor appears first and then the momentary lag


(Gerrie Delport) #6

Yes that sound the same as what gamers on other forums has reported.

It is a process that run in the background and then take focus for a second but then does not return focus to Zwift.

I would suggest looking at other processed running.


(Haykel Barhoumi) #7

Not experiencing this problem in others games but I can give it a go.

Can you provide any recommendation on how I can identify this rogue process. Task manager hasn’t been helpful so far.

Thanks.


(Gerrie Delport) #8

I will have to search a bit more. I don’t have this problem, but as a gamer i came across posts describing the same issue.


(Vincent W.) #9

Have you tried starting a clean boot before running the game?

https://support.microsoft.com/en-us/help/929135/how-to-perform-a-clean-boot-in-windows