Zwift does not show Wahoo Direct Connect pairing option on iOS 16 [October 2022] [SOLVED]

I reported the exactly issue and solution (entitlements) to the support team in Mid December 2022, and they still haven’t fixed the issue.

1 Like

thanks, sooner or later they will read us. Unbelievable for a company like zwift. I did in QZ 2 months ago!

1 Like

I have the same issue - just received my KICKR Bike v2. Direct connect works fine on MacOS and AppleTV, but not on iPad or iPhone. However, it’s not just an issue for Zwift, it’s an issue with Wahoo RGT as well. I have a few workarounds that can get it working similar to using the app above (I launch Zwift on my AppleTV inside, connect to the KICKR Bike via WiFi, disconnect, then it appears on both RGT and Zwift).

I reported the issue again today to Zwift support, with lots of details of the problem and how long it has been since I first reported it to them and how frustrating is that there still isn’t a solution, they said they are looking into it and hope to have a solution soon…

1 Like

it’s fun because we already provided the solution for them 3 months ago :smiley:

1 Like

Hi folks,

If you’re on iOS 16 and having trouble getting Wahoo Direct Connect to appear as an option on the pairing screen, you may need to refresh Zwift’s Local Network permissions. I recommend that you delete Zwift and re-install from the App Store in order to prompt the permission and select Allow. Please feel free to post in here whether that works for you. If it doesn’t we can follow up in a Support ticket.

do you mean that the new zwift version added a fix for this?

No change. Still not working after your recommended workaround. I still have to use a third party app to recognize the direct connect.

can i ask you which 3rd party app?

Search for my postings. It’s the IOS app „Discovery“.
You have to open it, click insinde the app on wahoo and then direct connect appears inside Zwift. com/de/app/discovery-dns-sd-browser/id305441017


Thank you @Carsten_Skyschigu , I’ll make sure our developers know there’s still an issue.

Hi @Rowdy ,

Still not working for me (reinstalled, permissions, etc), on an iPad Pro with latest ipad os.
Do you still need to get support cases raised or do you have enough materials ?


Thank you @kouik_me ! The investigation has been reopened, so I’ve turned this thread into a Known Issues thread for folks to check back in on. You can always feel free to open a support ticket, but we should have what we need at this point.

1 Like

Has anyone figured out the fix for wifi or direct Connect showing as an option on iPad or iPhone post iOS 16.1? Plenty of threads out there with people trying to figure it out with no resolution. One workaround has worked for me – IF I launch Zwift on my Apple TV (inside) and connect to my KICKR bike (garage) via wifi, then launch Zwift on iPad or iPhone, the network option works. I can do my workout. If I don’t connect to Apple TV first, it never works. Also, it works on my MacBook Pro as well – this only affects iOS. Finally, I have to do the AppleTV trick every time – it’s not like it remembers after doing that trick once.

Any insight would be great – people have the issue with iOS greater than 16.1 or 16.2 (I tried on 16.2 and 16.3 – no luck. Others say 16.0 or less and it still works fine).

A previous post marked this solved, but I have removed the solution for now. There seem to be some workarounds using other WDC-compatible apps or other devices not on iOS 16.1 or higher, but there is currently no workaround within Zwift on an iOS device.

FYI, the workaround does not function for me. I see the kickr in network apps, advertising as it should, but it’s not changing anything on zwift

If anyone as an idea for other workarounds, please share.

This did the trick for the iPad and iPhone.

Interesting that the Apple TV finds the zwift direct connect no issue.

My previous workaround required going to Apple TV then opening the ipad and discovering the direct connect there.

Meant to post this the other day, but it seem like the issue has been resolved in the latest version 1.39.0 of Zwift, every time there has been an update I’ve checked to see if I could connect again and once I had updated to this version it worked! Strange how this came about with the new pairing screen update!
Hopefully it working for everyone else too?

Hey all - to confirm - this issue was fixed in v 1.39.

With Anthony’s confirmation that it has - and the absence of any followup reports - I’m going to mark this one solved.

1 Like

Thanks, this did the trick on my ipad 16.6.1 and Zwift 1.53.2

1 Like