Zwift does not show Wahoo Direct Connect pairing option on iOS 16 [October 2022] [SOLVED]

I updated my IOS to version 16.1 using on an actual IPad Mini. Also Zwift app updated to actual version.
Now it’s not possible to connect my Wahoo KickR via direct connect.
Make a workaround and uninstall and install Zwift again. Then crosschecked with wahoo fitness - there is no problem and the KickR is recognized on the IPad via direct connect. I closed Wahoo fitness and tried again with Zwift.
Only BT connection possible, but no direct connect.

Is it a known bug in Zwift?

There was an issue with the Kickr v6 the wifi was dropping, direct connect did not change anything and BT was the worst. Best option was Ant+. With latest Kickr firmware, it solved everything. But it seems like Apple users still encounter some issues.

That is the main thread:

I don’t have Wifi. Only direct connect. Never had a problem until trying to use Zwift with IOS 16.1 and the actual Zwift app Version 1.30.0

Hope there will be an update soon.

This sounds to me an issue with Apple/Zwift this time and not really Wahoo…


I guess that’s is a problem with the actual version of Zwift.

Direct connect is also not working on windows. Network status and IP is good and no firewall. Wahoo app also recognizes the direct connect dongle without problems. Must be a failure in Zwift.

Problem solved. Router was damaged… Produced very high network pings.

Ooooh!!! Well at least you know and you can go forward! Let’s go shopping for new router! => New Router Day ?? :smiley:

1 Like

Glad it’s not just me, got exactly the same issue once I’d updated to iPad OS 16.1 also doesn’t work on iPhones once updated to iOS 16.1 so it looks like Apple has made a change in the iOS which stops this working in Zwift. Interestingly it still works with the Wahoo app, so hopefully Zwift are aware and will push out a game update soon.

I’m currently using a Kickr V5 with the direct connect adapter, running Zwift on an iPad Air 5 now running iOS 16.1.

1 Like

Had no connection between Zwift and my IPad using the Wahoo direct connect dongle. First thought, that is an problem with by rooter.
But it seems to be a problem with IOS.
On my Phone I have IOS 16.1 and on the IPad IOS 16.1 first, now 16.2 beta and always the same problem, that I do not find the direct connection dongle.


I installed the app "Discovery - DNS-SD Browser

After opening the app on the IPhone, the direct connection dongle is shown on the IPad.
Now I have to open the app prior open Zwift and have no problem. Perhaps this will help you too.


Thanks, I’ll give that a try later and see if it helps, hopefully a work around while Zwift sort the issue out.

I’ve logged a support call with Zwift a moment ago and they have just picked up this thread too, so hopefully they will look into it.

Also I tried connecting Zwift with my old iPad which is running iOS 15.7 and that all works just fine.

1 Like

Just throwing my hat in the ring as someone who recently updated to the new iOS and had it kill my wifi connection on the Kickr V6.

Try the app mentioned above. When I open the app and open the network and press on the wahoo kickr inside discovery dns browser, Zwift find the Kickr.


I’ll give that a shot! Thanks.

The main issue is that Zwift needs to ask the Multicast entitlement to Apple. I already did for QZ.
Check this thread Zwift developer /cagnulein /qdomyos-zwift /issues/1011


Hi there -
I have a similar issue - received my brand new KickR V6 with WiFi support.
It works via WiFi on the Apple TV and on the PC … but impossible to get the Direct Connect available on iPad & iPhone (both running under iOS 16.1.1)…Only BT available.
Not a major issue right now as I can still enjoy Zwift with my new KickR … but it’s a kind of anoying as I was looking to something more “Plug & Play” ! :slight_smile:

Hopefully someone will find a workaround or this being fixed shortly.

Yes as I said before it’s a known issue. I hope the Zwift developer will read my message because I already found the solution for them!


Same issue for me since IOS 16.1 zwift not seeing the direct connect anymore on my Ipad. Turnaround with the DNS app as describe here above is working well. Hopefully will zwift update soon


Several updates and this issue still isn’t resolved come on Zwift sort it out please.


Push, for me it is still not working. I am able to find the kickr with the app mentioned above but Zwift does not recognize the direct connection.

1 Like