Zwift crashing on exit - Windows 10

Same here.

It worked on a different PC in windowed mode, it worked on this one in windowed mode (but the graphics seemed to struggle and full screen sorted that out) but doesn’t work in full screen mode.

I can test the other PC again tomorrow in full screen to see if it also gets the same problem. They are basically the same set up except the current one is a bit older.

just to be clear it hangs after saving, so it gets back to the world choice screen, then clicking exit on that is when it hangs. the very final click needed to exit the app.

I’m always in full screen mode, the game runs like turd in windowed. Anyway I just timed it on my system and after hitting Exit from the main menu (this is after discarding a ride) it took 11.5secs to get back to the desktop. So it’s pretty slow no matter what.

I currently do windowed mode with Borderless Gaming. I’ve been using this setup for months with no issues until my run yesterday (4/6/21) at noon. I could imagine a windows patch messing things up.
The fit files are there, but seems like the upload to Zwift is not working. My router signal is strong, fast and port-forwarded to allow communications with Zwift servers.

If you use Borderless Gaming to avoid the whole ‘minimising when using a second display’ thing, you may wish to consider DisplayFusion which has a function to lock the game. Lets you run it in full screen mode which performs much better.

Anyway this feels like a server/network issue to me, where the game isn’t ever completing some upload so it just sits there and Windows eventually decides it’s not responding.

I use BGR to maximize the game but allow me to have a Discord video chat overlay. Works like a charm on my rig (4k/60fps)

It’s most definitely on the network/server side. I’m going to look at the log file with Zwiftalizer to see if it reports connection issues.

Whenever I try windowed mode it just feels noticeably less smooth to me (irrespective of system) but if you’re happy with it then fair enough. :wink:

yeah this is my experience too, hence why i switched to full screen.

Think it’s because Windows DWM takes over vsync control in windowed and Zwift works best in old-fashioned full screen exclusive.

Got an idea on this. When you close the game, after saving the log file, the launcher comes to life again and performs an update check. Pretty sure this is new, the game log file always used to be the most recent but now there’s a newer (and live) launcher log file. So perhaps it’s a permissions thing on your system where the game is waiting for the launcher which can’t run for some reason.

Edit: I’m on the older 1.0.50 launcher because it performs better in the game (documented this elsewhere). What version are you guys on? If you’ve reinstalled I bet you’re on the latest one. Worth trying a roll back.

Another user with the same issue…

going to try a different PC today and see if it is the same.

So the other PC worked and closed fine.

The set ups are the same except the one that doesn’t work doesn’t have wifi so i USB tether my phone to it to use as a wifi dongle (phone is connected to wifi).

that is the only difference I can think of but there are now drop outs during the rides (the riders don’t disappear companion app stays connected the whole time) speed tests before and after are as good as the other PC that works

very strange.

will try the one that doesn’t work with a proper wifi dongle at some point but can’t see why it should make a difference.

You phone might use cellular data if the wifi signal drops or is weak, maybe that is causing it?

I’ve had a similar issue since the February update. I’m running an I7-6700k workstation with a GTX1660TI GPU on a wired LAN with Fiber internet at 1gb up and down. It’s pretty much optimized and its only reason for life is Zwift. Since that update, when I close Zwift, about 70% of the time it will hang on the closing screen. I’ve tried to wait it out but the computer goes to sleep before it gets unhung. If I doubleclick on the screen, I get the this app is no longer responding window then the app closes when tell it to close it. Never lost any events that way and I’ve not had the problems with Zwiftpower data processing when that happens. Just weird…

1 Like

Hi @Mark_Crane_TOG_G_63y

This seem like a common answer but have you tried to completely uninstall and delete all Zwift files and reinstall every thing. I like to do that form time to time since I rely on Zwift performing optimally.

What launcher are you using? Right-click the Zwift icon in the system tray to find out if you’re not sure.

I haven’t reinstalled for yonks and my system hasn’t done this once as yet.

PS: if it’s a dedicated Zwift PC, you should tweak your power settings so it doesn’t go to sleep. :wink:

its a new install of zwift on that PC so will be the latest version.

The phone won’t switch to mobile data or the companion app would disconnect.

just one of those things i guess just seems weird

Just to update this, i switched the PC back to using my phone as a USB tether and it now exits fine.

Nothing has changed but it didn’t exit before and now it does! very odd!

maybe lumpy internet at the exact time i clicked exit or something previously.

But it is all working fine now so I won’t complain!