Zwift Crashes While Messaging

Hello. I am a ride leader and I lead or sweep over 3 rides a week. Since the recent March 2021 Zwift App update the Zwift app just crashes spectacularly during rides, especially during the act of mid-messaging and it seems to be also when I’m using the ‘back-delete’ key. Before that update Zwift was absolutely stable.

I have tried to contact Zwift support but with little feedback. Disappointing as I lead rides and this affects 300+ riders when I’m leading a community ride.

I have tried to troubleshoot myself. My network is stable, I have tried 3…yes three…different machines (2 new modern Win 10 laptops, and a 2019 iMac 27" Retina); I have replaced Ant+ and USB cables; I have replaced keyboards etc. I have turned Bluetooth OFF on the Zwift machine also. It is really frustrating.

I do message a lot so could it be a message buffer size issue?

I have now reverted to looking at the Zwift logs and dump logs. On area I found was the text ‘com.apple.audio.IOThread.client’ in the dump and read somewhere that it could be a BlueTooth issue. I do have my iPhone on with Wireless Bluetooth Bose ear buds. This is what I will try and eliminate next.

Has anyone experienced any similar issues or have any troubleshooting tips? I am IT literate (Very) so please be as technical as need be to help.

Help!!!

Thanks

Steve

Let’s keep it to this thread: ZwiftApp crashing while writing a message - #2 by SteveH-EVORideLeader

Please put the addition information in the existing one.

Closing this one.

Ride On!