Zwift Companion Release: June 29 (3.16 iOS, Android)

Will upgrading be enforced, like the issue at the weekend appeared to preview?

(answer is yes)

2 Likes

Any chance rollback will be allowed? I know my 'vintage ’ iPad is a complete fossil circa 2013 but it does work.

2 Likes

ZwiftCompanion: upgrade. I don’t find the upgrade. Like tha last we…

@Wes I had about an hour delay between being locked out of companion and being able to get the android update despite frequently trying.

will it work correctly on my iPad ( in landscape mode, ie no power lead at bottom)
I do not want a double size iPhone scree, with a copy of what’s on my main screen.

My android update took ages too, however, this was consistent with all apps in the play store so thinking this was a google not zwift issue.

This is STILL not working for Android 4.4.

Despite uninstalling, re-starting, installing it still comes back to a forced front screen of “The version of Zwift Companion app is out of date. Please update to the latest version” with an Update button.

That’s despite installing directly from Google’s Play Store.

Please fix this properly Zwift.

Pretty sure that’ll be because 4.4 is too old for some of the newer features; not sure they ever advised this for Android but on iOS there was a cut off point. I believe on Android it’s version 5.0 or newer. Problem is it appears you’re now stranded and because of the enforcement can’t use what previously did work.

They need to add an exception for older OS versions, unless they’re saying you just can’t use it any more. @shooj can you advise?

Definitely need v5.0 for the update

1 Like

Nice one. :+1:

So the question (which I guess also applies to iOS) is whether people on older operating systems are now completely locked out of using Companion by the enforced update message that they can’t comply with.

1 Like

Version 3.16 of Zwift Companion marks the end of support for legacy devices running Android 4.x or older.

The latest France and Paris worlds that we’re rolling out to everyone in August will not work if you don’t have v 3.16. Other popular features like Meetups won’t work correctly on outdated versions of ZC.

It’s been a good run for Android 4. Introduced in 2011, even Google stopped supporting it in 2018. Please use ZC on a newer Android device.

3 Likes

Cheers. Not only is it no longer supported, it’s been officially culled because of the upgrade check.

What is the equivalent iOS cut off?

iOS10 and older were no longer supported as of Companion v3.13.

1 Like

This is STILL not working for Android 4.4.

That’s despite installing directly from Google’s Play Store.

Please fix this properly Zwift.

I believe to have read somewhere Android 5 is minimum required?!?

1 Like

It’s correct that the newest versions have Android 5 as minimum requirement.

1 Like

Hi.Im under the impression that version 3.16 of the companion app for android should allow me to save events to the calendar…this was introduced in 3.15). I’m unable to do this as I get the below error message. What am I doing wrong? I’m running android 9 on the s8
Screenshot_20200703-082534_Companion|243x500

@Peter_Davies3
What calendar app do you use on your phone? Is it Google’s default calendar, or something else?

I just registered for tonnight’s 10pm (my time) L’Etape event, and did not see this same error message.

It took about a minute to sync, but it showed up on my calendar as expected.

I’m curious how your default calendar app is set up.