Zwift Companion app on iOS16 won't connect [September 2022]

I’m having the same issue. Everything worked until about a week ago but now Zwift companion won’t connect during a ride or workout. I’m using Zwift on a MacBook Pro and ZC on an iPhone 13 with ios 16.0.2, with latest version of ZC. Everything is in the same WiFi network. No new phone or operating system update to clearly pinpoint what is causing the issue.

Hi, I have been having the same issue as everyone else since upgrading to an iPhone 14 Pro.
I usually use an ATV with my phone but since the upgrade this has not worked. My iPad which is on the most up to date iOS works fine.
I have however just installed Zwift on my iPhone and the iPad ZCA connects to that straight away but it doesn’t work the other way round, so the iPhone is not initiating the connect request. Just for info, both my iPhone and iPad do not have the ZCA under ‘local network’ in settings.
Maybe this will help a little??

iPhone 13 Pro Max with IOS 16.3.1 using the ZC with Macbook IOS Ventura. Also problems that connection is lost after a few minutes and cannot reconnect,. Also the connection with. Apple Watch is constantly dropping, As shame we have to wait so long for an solution

Apple Watch is no longer supported so you’d be best looking for an alternative HRM.

1 Like

I’ve been following this thread for awhile and am curious if anyone has received a reliable fix for the issue?

I feel somewhat fortunate, the only issue I’ve had since upgrading to iOS 16.3.1 is GCA continues to kick me out of the map screen, back to the home screen during an activity. I probably just jinxed myself :worried:

Nothing. And, saying this as a paying level 60 Zwift subscriber who uses Zwift throughout the year, it’s shameful. Without keeping an ipad near my bike I no longer have a way to communicate with anyone on Zwift, to direct my bike to different routes, to adjust my workout intensity on the fly, etc. I understand that glitches happen, but it has been SIX months and the issue affects the LATEST iphones on the market. It’s insane that Zwift does not seem interested in fixing its software for people with the latest tech. Should we all be migrating to a company that cares about its customer base?

Same, Tim. iPhone 14 Pro, upgraded from XR. The upgrade was done at the shop, transferring all my settings. I’m tempted to back up my photos, etc. and then do a clean reset and install, but only if people confirm this would work.

1 Like

Another iPhone 14 Pro user here with the same issue. Upgraded from iPhone 11 Pro which was working fine and now can’t use ZC app.

Really frustrating to see this has been going on for months without even identifying the cause.

I’ve contacted Zwift support and got a refund as I can’t use the full service/features and linking to this thread. I’d suggest everyone in this thread that is affected do the same, for every month you’ve been unable to use the companion app. That might get this a little bit of focus (assuming Zwift management looks at this kind of data!)