Zwift Companion app on iOS16 won't connect [September 2022]

Just got the iphone 14pro and I am have the same issues, I am not able to use the companion app. As pointed out by many other people here in this thread. That have iphone 14.

Update: I was able to eventually fix my issue by erasing my phone and doing an iCloud backup restore. It worked after. Not saying that will work for everyone but it did solve my issue…for now.

Same here…my ZC app has not connected since I got the new 14 over a month ago. VERY FRUSTRATING as I do a lot of group rides and now am unable to correspond as I would like with the groups that I ride with. Not only that but it is much more convenient for me to track all of my data while riding! With this being an issue since 9/22 (5 months) and affecting a lot of people I sure hope it is at the top of the priority list to get fixed! The only thing I haven’t tried is to fire up and old iPhone that I have and just hook it up to wifi to run the app while riding. I am going to try that tonight.

I’ll keep you posted!

RIDE ON!

1 Like

Similar to many. Just upgraded to iPhone 14 pro on IOS 16.3. Companion won’t open map when undertaking a ride. My old iPhone XS max on the same IOS 16.3 works fine. Certainly seems an iPhone 14 pro issue.

2 Likes

Came to share what seems to have fixed my issue and see Michael did the same thing yesterday.

After doing a bunch of testing with a friend and discovering his iPhone 14 Pro worked great with my iPad setup I decided to reset my phone. I had uninstalled both Zwift and ZC and did a new iPhone backup prior to the reset so I would be restoring without either app. After the reset and iCloud restore, ZC is connecting consistently. Extreme frustration sometimes leads to extreme solution.

While I was doing my reset my friend found this which might be worth trying. You can reset the entire privacy subsystem using Settings > General > Reset > Reset Location & Privacy. Neither my phone or his has Companion listed in Privacy & Security under Local Network so not sure I have much confidence in this solution but it seems like the network discovery should have the app listed.

Brilliant! I didn’t understand my router and devices had that capability.
I switched the 5hz name and the iPad and iPhone to that network and the connection has been rock solid ever since.
Thanks for sharing your insight because it has saved my sanity.
Ride Strong!

1 Like

I don’t know if this problem has been solved for some of you but I just had the problem since I changed to an Iphone 14 Pro Max.
I didn’t have the problem before when using the companion app on an Iphone 12 Pro Max using IOS 16 (always keeping the latest IOS version).
I used the backup of the Iphone 12 Pro Max to install the Iphone 14 Pro Max. Since then, when I use Zwift the companion app doesn’t start the map.
I use Zwift on an Apple TV 4K (2021 version).
I tried to use the COmpanion app on my Ipad (also with latest IOS) and it works fine. Only seems to be the Iphone 14 Pro Max for which doesn’t work.
I tried to uninstall the companion app and reinstall it but no success.
From what I understand after having read the thread, it hasn’t be resolved by Zwift yet, but if any of you managed to have it fixed, I’d love to have the steps you took.

No idea if this is useful information for anyone, but my Companion app stopped connecting right as this year’s TdZ began, so roughly the first week of January. I’m using it on an iPhone SE with iOS 6.2. It’s on the same network as my computer and I’ve tried all of the router stuff mentioned here and on other websites. The only time it connected recently was the first and only ride I did between the 1.33 update and 1.33.1 patch. My trainer resistance was garbage for that ride and destroyed my legs, but my Companion app worked! Could this have been a coincidence? Sure, I guess. But the day before the update the app didn’t work, the day of the update it worked flawlessly (about the only thing that worked), and the day after the patch it stopped again.

The app was working for over a year without a single connectivity issue. Just last week it cannot find my treadmill. Other apps finds and connects just fine, just zwift having the issue. Any suggestions? I have T5 Track Connect.

Possibly this is your answer

2 Likes

I’m also having the very same issue.
My hardware:

  • iPhone 14 Pro running iOS 16.3
  • AppleTV (A2169) running tvOS 16.3
    Both devices on the same network/channel etc….
  • Hope Zwift fix it very soon
2 Likes

Don’t hold your breathe. Zwift, by the lack of response over now 5 months have buried working in this

@shooj @Rowdy @MikeL_ZHQ

1 Like

This is driving us crazy! My wife and I both have iPhone 14 ProMax; she was running iOS 16 and has not been able to get the companion to work. She repeatedly deleted the app and reinstalled it. Nothing works. This has been frustrating since it worked just fine on her 13 ProMax. I use the same phone and wasn’t having any issues until I upgraded to iOS 16.3, now I am having the same issue she has been struggling with for months.

Hey Zwift! Come on! “A known issue” is not a bug fix, its an excuse. Fix the code! I think Zwift ought to credit effected users as a financial penalty until this is fixed, maybe then they’d get this addressed.

Add my name to the list of iPhone 14Pro users with iOS16.3 companion not working. Fails to load map and workout screen.

We’d love an update on where this stands @shooj

Thank you.

1 Like

This indicates that it is a problem with the iOS update and not Zwift’s fault?

1 Like

Cris, this has been an issue for more than 5 months. As the client, it is Zwift’s responsibility to be compatible with the host operating system (this is the standard app:device protocol). This is Zwift’s code error to fix, they have acknowledged this is a known issue however they have yet to resolve it.

Ok, so they just declare it’s not compatible with the changes that Apple made to the OS? Apple have a responsibility to make sure they’re not suddenly causing issues with apps that were working previously. It’s like they’ve no QC and didn’t carry out any/enough testing (sound familiar?)

Please show me where zwift have stated it’s Apples fault? And whether or not Apple broke something in the iOS 16 series zwift as a developer had months to test with the betas before

It’s the combination of iOS 16 and iphone 14 (max).

Other (older) iPhones with iOS 16 do work and iphone 14 (max) with older firmware are working, though.

That’s a clear indication, that apple messed up its new firmware on specific hardware.

The ZCA app function in question might be seldomly used by any app and went under the radar while testing.

Mark and Cris, Zwift is responsible for ensuring that it’s app and tools are compatible with device firmware; every other Bluetooth device I own (many) continue to connect seamlessly with the 14 ProMax and iOS16. Apple hasn’t messed up, its the third-party app developer’s responsibility to test and validate compliance with hardware and software. Apple has zero responsibility for ensuring that third-party apps work with their software/hardware ecosystem; it remains the third-party developer’s responsibility. I say this as someone who has to develop code for existing architectures, this is standard practice. What is not standard practice is Zwift’s continued head-in-the-sand refusal to address the issue beyond admitting that there is a known issue that their software is flawed and doesn’t work correctly. You could say that a more customer-focused developer would address these issues and take corrective efforts rather than remain silent.

3 Likes