Zwift Companion app on iOS16 won't connect [September 2022] [SOLVED]

This answer came from an “ambassador” which is a random person who signed up to answer Zwift’s support requests. That person won’t have any knowledge of what’s going on inside the company. I think you usually have the option to avoid using an ambassador to answer your question, though results from Zwift support staff may not provide more visibility into development work.

I am having the issue with ZC on an iPhone 12 running iOS16 and Zwift on my iPad running iOS 16.

I also booted up an old iPhone (8) running iOS14 and it wouldn’t connect either.

So, for me, it isn’t limited to iPhone 14 (since i don’t have one) but seems to be more of an issue with iOS16 (or either the iPhone or the iPad).

i did notice a network setting of the iPhone (in the wifi setup) which is Private Wi-Fi address, and mine is turned on. I am going to see if that is on my iPad and see what happens if i turn that off on both.

If it’s on other phones than iphone 14 with iOS 16 it is most likely another problem with your wifi or network

I hear what you are saying, that there would be some other network issue, except it worked, and then iOS 16 came out and it stopped.

I just looked and my iPhone 14 has it turned on and Companion App has been working fine so doubt that would be it.

what iOS is your 14? and what is running zwift?

iPhone 14 running 16.2
Apple TV running 16.2

Has been solid since I got it. My iPhone XS running 16.1 was spotty at times even in airplane mode.

I’m having issues on my IPhone 13 Pro.

This may be the daily visit till they fix this, if it was a pro rider having an issue I’m sure it would have been fixed yesterday. I did contact support at first I was told I would get emailed with help and they never followed up with that either.

ThenZwift should come out a say it is an Apple bug and that they are working with them to resolve ir rather than silence. But since it’s NOT that issue, but mostly relates to the new”pro”models, it’s something Zwift themselves need to address


It’s fine the weather will be nice by march and I’ll be outside then I’ll just subscribe to a different service next winter. The silence is pretty ridiculous.


This is happening with me randomly on iPhone XR with the current iOS:

My “fix” is the following:

  1. Close down companion app
  2. Turn off mobile connection on iOS
  3. Disable bluetooth and wifi
  4. Start companion app and get the error for “no connection”
  5. Hit the retry button 5-10 times
  6. Now enable bluetooth and wifi connections
  7. Swap back to companion app and hit the retry button

The app should now get a connection to Zwift running on your other device.

I’m not able to choose if my devices go to 2.4ghz or 5ghz WIFI, it just happens automatically.

iOS/iPadOS 16.3 release candidates out… Zwift companion app still F00ked

1 Like

Bought the 14 max pro for ZC? Where is the support???

Wahoo RGT or Rouvy are sounding better with each passing day…

I also find it amusing that Zwift is basically just dumping us all here to commiserate while they just tell us they’re working on after 3 iOS updates and 4 months… :joy:

1 Like

I’m so excited to join this group! My companion app stopped syncing tonight but I got everything to work on my phone using the zwift app. So clearly this is a zwift issue if it works on my phone but won’t allow me to sync to my Apple TV for some reason. I did just sign up for the 2 week trial at Wahoo. No companion app needed there. So Zwift….you got two weeks! LOL!

You don’t need the companion app to use Zwift.


Beyond frustrated. All working perfectly until updated iPhone 12 Pro with iOS 16.2. Now connects one day and then not the next. I’ve been troubleshooting for two weeks. I’ve run through all the suggestions: deleting, re-loading, re-setting, you name it. I don’t know what to do. How could thousands of people across the world be using this app and have this problem???

By the way, I’ve been Zwifting for 7 years with little trouble. I’ve been Zwifting with the Companion app for 3 years with no trouble. Not until this update did everything go to hell.

1 Like

So I’ll add to the pile. Been using ZC with my Apple TV for a while. Last time I used it was yesterday with my iPhone 11 Pro. My wife used it this morning on her iPhone 11. No issues.

Yesterday I got my new iPhone 14 Pro. Copied over all my apps and data. Tried to ride this afternoon, no joy. The ZC is not being “seen” by the Zwift app on my Apple TV. I tried again on my wife’s iPhone 11, connected just fine.

Same Apple TV, same Zwift App on said Apple TV. Same iOS version (16.2). Her iPhone 11 works and my iPhone 14 Pro does not.

I have tried all “tricks” of reboots, uninstall and reinstall on both my phone and Apple TV. Nothing makes a difference. Her phone works and my new one doesn’t.

I would assume this points to a setting/configuration on my new iPhone 14 Pro but I can’t seem to find the magic one yet.