Zwift Click Firmware Update stucks on Set DFU-Modee


Yesterday I received the Zwift Hub One. I updated the Zwift Hub without any problems. After that I connected the Zwift Click to the Companion App and tried to update the firmware. But it stays on Set DFU mode and the connection of Zwift Click is lost after a few minutes. But the blue LED stops flashing and I am obviously connected to the app, otherwise I would not be able to start the update.

Does anyone have a hint as to what mistake I am making?

Thanks a lot and best regards

I had the same problem the first time I tried to update.

I closed the Android Companion App completely (App Info - Force Close) and tried again and it worked right away.

I’m curious if you will also have the watt/speed problems that occur here partly…

I had the same issue with my Zwift play controllers last week. Eventually I had to just switch them off. Fortunately, they still worked fine during following rides. That happened several times, so I stopped trying to upgrade for the week. This weekend they upgraded just fine.

Your risk, you have to make the choice, but I would say just use the click for a while if it connects and works, and try the upgrade later.

Thank you very much for your replies. I de-energized the click and reinstalled the companion app. Same result. So I wait some days and try to make the update.

I also cannot update my new Zwift Click. It also freezes at the “Set DFU mode”. The device reboots, blinks the blue light until it automatically turns off.

I already used it once on Zwift within a workout and free ride and it is functional.

EDIT: 4 days after, it updated without issues! I cannot really say what I did different in the meantime, except changing the position of the clicker on the handlebar :smiley: