Zwift activities not syncing to Garmin Connect [October 2022] [SOLVED]

I have the same issue. Both yesterday and today there was a delay of 3-4 hours before the ride appeared on GC. Coincidentally (?) it happened also right after midnight CEST time.
It’s quite frustrating as I have moved to GC as a primary platform only yesterday, after I got Garmin Epix…
Sync to Strava is instantaneous.

Same Problem here,zwift doesn‘t sync with my Garmin connect.
Ride was on 25.10.2022

Same issue here - no sync to Garmin Connect but synced flawlessly to Strava and MapMyRide - using Zwift on iPad iOS 15.7

Hey @shooj, you seem to have a great handle on things like this so I figured you might be able to help us out - I’m curious as to when this becomes a “known issue” since numerous threads on the same topic are starting to show up - thanks in advance for any info you can provide.

I also reported it to Garmin since I use beta firmware
Look in Fenix 6 thread beta 23.80 forum

The activity came after a reboot of both phone and watch.

I also got a reply from the support on United Heroes:
Hugo (United Heroes)

24 Oct 2022, 10:08 CEST

Hello Andreas,

Thank you for your message.
Unfortunately, Garmin stopped being a relay between third-party apps (for instance between Zwift and our app), a few weeks ago now.
This is a unilateral decision we can’t act on.

As we are indeed not compatible with this service at the moment, we will of course take your feedback into account for future improvements.
In the meantime, I can only advise you to use another app adapted to your practice: [Which app should I choose?](deleted link).

Also, please note it is possible to import your activities using GPX/TCX/FIT files, [this is how](deleted link).

I hope you will enjoy our United Heroes experience despite this inconvenience.

Have a nice day,
The United Heroes team

I am also facing the same issue. Rides are syncing to Strava and Today’s Plan but not Garmin Connect
Need help!

Yep - this has started happening to me too. Only in the last few days

Possibly related

1 Like

Hi, this is happening to me today also. Zwift uploads fine to Strava, but not Garmin Connect. Can anyone help? Need it for motivation, my first ride in too long :slight_smile:

Yep also having the same issue the last few days… I’ve been exporting the original file from Strava and just manually uploading into garmin.

A bit annoying though, not sure what the issue is.

I just took a look at Garmin Connect (iOS) and noted the activity was uploaded through Zwift with all associated data. My manual upload was still there which I just deleted. Not sure if the problem was rectified (thanks to anyone who may have fixed it) or I was just impatient.

Did two Zwift group rides tonight. Both are viewable in Zwift & Strava but not in Garmin Connect. Is there a delay with Garmin Connect right now?

Hello everyone,

Thank you for raising this to our attention. This issue is being addressed right now. There may be some delay, but your activities should eventually appear. I will post an update once everything is back to normal.

Update: Zwift activity uploads to Garmin Connect should now be caught up.


For the past three days my Zwift rides are not syncing to Garmin Connect. Known issue?

1 Like

Completed two rides earlier this evening and they synced almost instantly - Thanks for the follow-up @Rowdy!

I’m having the same issue in past 3 days. On Tuesday I had to manually upload after my ride wasn’t sync after some time and tonight the same issue. Any suggestions?

I’m still having this issue. Zwift is not sending the activity to Garmin Connect :frowning_face:

Still not working.

Same here, activities not uploading to Garmin Connect. This then doesn’t flow through to training readiness etc, a big advantage that Zwift had compared to MyWhoosh, RGT and other competitors

Issue still persists. Rides are not uploaded to Garmin Connect, and can in some cases even not be uploaded manually. In some cases it helps to use the Corrupt Time Fixer of fitfiletools, but not in all. Any other tips? Helping doesn’t seem to be an answer, as the ride of last Tuesday was still not uploaded today (Saturday).

Sorry if I sound harsh, but can this please be fixed? It is so incredibly annoying that things stop working. An update should improve the functionality, not make the experience worse.

1 Like