Zpower


(' BTCNJ-Jim-HUBS(D)) #1

How accurate can Zpower be without input of wheel circumference?
Garmin , TrainerRoad require me to input my wheel size , circumference .


(' BTCNJ-Jim-HUBS(D)) #2

Hi guys , another ? On the leader board of the game by my own name, I do not see the little badge Zpower . I do see it on other peoples names . Should I see it ? If so how do I turn on ?
Keep up the good work ,


(Kyle Polansky) #3

That’s a good question. My guess is that Zwift just assumes a standard 700c wheel and then uses the speed sensor to get the number of wheel revolutions per minute (or second?) to calculate speed. I am guessing that this speed is then matched up with the power curve for the trainer you are using. Ideally you would want to get the speed of the trainer’s resistance wheel.


(Eric C. (Zwift HQ)) #4

Kyle is correct. Currently we are assuming a standard 700c wheel. We’ll add more options as we refine it.


(Jon Hancock (B)) #5

Hi,

Had my first experience of Zwift today and was wondering the same thing. Can anyone comment on what sort of difference to zpower the wheel size makes. I utilise an old mtb with a 26" trainer tyre and in trainerroad have set the correct circumference. With Zwift should I expect to be able to hold a higher or lower value?

Cheers,
Jon.


(Irina Souiki) #6

I am currently “fixing” this by using the relay feature of TrainerRoad. TrainerRoad allows you to broadcast the virtual power value. Obviously you need two Ant+ sticks to do this but it works to collect the correct power value in Zwift.


(Jason Flores Endurance Lab) #7

Im also doing what Irina is doing since I dont have the option for zPOWER in the settings screen even though im on the Travel Trac Fluid which is suppose to be a support trainer.  Any idea why?

 


(Eric C. (Zwift HQ)) #8

Hi J. Flores,

zPower is only enabled for the Jet Black Fluid Z1, the CycleOps Fluid 2, and Kurt Kinetic trainers as outlined here in the release notes for 1.0.5395:

“For those of you using a Basic Setup (speed sensor and classic trainer), you can choose between Virtual Power Modes for supported trainers. Classic Mode may reduce the jumpiness of the wattage display experienced using zPower but it also reduces responsiveness during sprints as it does not account for acceleration. The zPower option is currently only available for Kurt Kinetic trainers, the CycleOps Fluid 2 and the JetBlack Z1.”

This is also reflected in our Trainer Knowledge Base article: https://support.zwift.com/hc/en-us/articles/203152565–Info-Which-trainers-does-Zwift-support-What-do-I-need-to-ride-

The rest of our classic trainers use our virtual power curve which, currently, cannot account for acceleration.


(Jason Flores Endurance Lab) #9

Thank you for the reply… Now to figure out why my power is so high with my travel Trac fluid… 


(Eric C. (Zwift HQ)) #10

If your power is high, make sure you do the following:

  1. Choose the Travel Trac Comp Fluid trainer when pairing speed

  2. Make sure your speed sensor is properly aligned

  3. Make sure your tire is set to 100PSI

  4. And, lastly, make sure your ANT+ dongle is close to the speed sensor

Also, are you using the OLDER Travel Trac Fluid trainer or the NEWER Travel Trac Comp Fluid? Because we only officially support the newer one.


(Jason Flores Endurance Lab) #11

^ +1!

Hmm now to figure out how old my TTCF is.  It seemed to match up well to the power reading i was getting in trainerroad in May but since a couple updates its gone up and no longer match.  Just trying to keep it honest.  100+ watts at 10mph is just not right =)


(Eric C. (Zwift HQ)) #12

Haha, no worries! Power curves are a tricky thing to be sure.


(Scott Benzie) #13

If you have the old trainer tac fluid, what should I select ?  And I guess how do I know which is which ?


(Ryan Goldenberg) #14

 I am using a basic setup with an Elite Fluid Alu trainer and Garmin speed and cadence sensor. As listed in the Zwift topic, I selected the Crono Fluid trainer in my setup. Doing my first ride in Zwift for about an hour this morning, it showed an average power output about 100W higher than what my Garmin computer reported (and what I believe is closer to my ability). What’s interesting is that the distance traveled between Zwift and Garmin was very close - within about 7%. I used a USB extension cord to get my ANT+ receiver ride next to my bike, and I believe I have 700x25c tires. Any thoughts/recommendations on how to increase my power accuracy in the software?


(Nick Zourikian) #15

@ Jaso Flo / Eric C - Same situation here: Did your Travel Trac ever begin displaying more realistic power levels?

I’ve got a relatively “new” TravelTrac Fluid trainer (i.e. circa 2014).

Almost ridiculously higher than normal (max or average) wattage attainable with  Zwift rides!  :slight_smile:

Yes - I verified the helpful checklist offered by Eric C.:

If your power is high, make sure you do the following:

  1. Choose the Travel Trac Comp Fluid trainer when pairing speed

  2. Make sure your speed sensor is properly aligned

  3. Make sure your tire is set to 100PSI

  4. And, lastly, make sure your ANT+ dongle is close to the speed sensor

Also, are you using the OLDER Travel Trac Fluid trainer or the NEWER Travel Trac Comp Fluid? Because we only officially support the newer one.

 

 


(Scott Benzie) #16

I ended up have to use the Elite Qubo, as the fluid unit on the back matched.

I have a Tacx Fluid.