ZCA sometimes takes 15-20 minutes to realize I'm riding

In the past few months, ZCA has occasionally taken 15-20 minutes to switch from the ‘inactive’ home page to the ‘riding’ screen.

ZCA is on the same network as the Zwift app. Force quitting the ZCA app doesn’t help, but power-cycling the phone fixes it. Or, if I wait long enough, it fixes itself.

Fortunately, I no longer rely on ZCA for a Bluetooth bridge.

Switching to airplane (or as I like to call it aeroplane mode) and back or turning Bluetooth off and on is my go to if it takes longer than 30 seconds.

1 Like

What kind of device? iOS/Android? Which version of iOS/Android?
Have you tried disabling mobile data for test, so it can only use Wifi?

1 Like

IOS 13.4.1. I haven’t tried disabling ZCA’s mobile data, but I will give that a shot.

This problem is normally when your phone and Zwift device aren’t on exactly the same network connection. Try turning off Wi-Fi Assist: https://support.apple.com/en-us/HT205296

Today, on L’Etape du Tour Stage 2, I couldn’t ever get ZCA to recognize that I was riding. I turned off cellular data. I toggled airplane mode on and off. I turned wifi on and off. I force quit ZCA. I turned the phone on and off. No luck. ZCA refused to be my riding companion. ZCA is iOS version 3.16.0 (1045).

After I saved the France ride, I restarted Zwift, and ZCA immediately loaded the Watopia map.

Is this a problem with France? The app store has no ZCA update available.

1 Like