ZCA crash

When scrolling back through my activities on the iOS version of ZCA, the app reliably crashes when I get back to early 2017. (@Gerrie_Delport has confirmed that the Android version of ZCA doesn’t have this problem. That is, he successfully scrolled back to the beginning of my activities on Android.)

Hi @Jim_Mattson
I’d like to gather more details, so I can have our QA team investigate.

  1. I’m looking at the server logs from today and see that you used Zwift companion on both an iPhone and an iPad. Did ZC crash on both devices, or just one?
  2. Does it crash at the same date (more or less) consistently in early 2017? Or is it the act of scrolling back in general with the crash occurring at very varied month / years?
  3. When did you start to notice this?
  4. Are there any other consistencies you’ve noticed?
1 Like
  1. ZCA is just crashing on the iPhone. I haven’t tried the iPad.
  2. Twice it crashed around mid-March 2017. The third time, I scrolled much slower, and I got as far back as late December 2016 before it crashed. (I still had about a year to go, since I started in December 2015.)
  3. I’ve never tried to scroll back that far before today. (I was inspired to do so by @Gerrie_Delport’s 4-year Zwift anniversary post.)
  4. Nope.
1 Like

The iPad also crashes, around June 2017.

Roger, thanks for following up on that.

Here’s a crash log from the iPad:


It’s actually a “JetsamEvent.” AFAICT, this is the iOS equivalent of Linux’s oom-killer. In other words, ZCA was apparently terminated because iOS was low on memory, and ZCA was the largest process.

Thank you for the additional insight. Would you mind emailing that log file to support AT zwift DOT com and specify in the body to forward this to Shuji?

Done. For the record, I think this is the interesting bit:

“uuid” : “ccc7e1ae-9a27-36c0-9f38-1a15b119778a”,
“states” : [
“killDelta” : 2678,
“genCount” : 0,
“age” : 2564123194,
“purgeable” : 0,
“fds” : 25,
“coalition” : 2554,
“rpages” : 92800,
“reason” : “per-process-limit”, <================ Here!
“pid” : 19398,
“cpuTime” : 124.494635,
“name” : “Zwift Companion”,
“lifetimeMax” : 92800

I’m not an iOS developer, but this looks like a simple memory leak. I suspect that you aren’t freeing the memory associated with activities that have scrolled off the top.