Worst Experience in a Meetup

Joined a meet up. Had a problem a few minutes in. Had to close out and reboot my computer.
Rejoined Zwift, it said locating riders, and it basically took me nowhere. Definitely not back to my group. I closed zwift and reloaded it, it tried to locate riders and it took me somewhere random and then my avatar went offroad. I actually went through the ocean in a straightline somewhere. I was face to face with the whale at some point and then I just steered right onto one of the underwater roads, but not with my group. I closed zwift and reloaded it again, same, failed to find my group. I did it one last time and it was past the time to rejoin my meetup so had to do something else.

I regularly see riders just riding through the air and cutting off major parts of courses and now I experienced it myself. It’s really annoying when other riders do it and it’s really annoying that joining a meetup is such a mess.

The only times I’ve ever had problems similar to what you describe was when my internet connection has been playing up.

I have a hard-wired connect that is around 250mb tested on the PC.

Btw, here’s a picture of me submarining.

1 Like

And most of the time it’s not me but other randoms flying through the air or cutting corners big time.

That is one of the COOLEST pics!!!

1 Like

I know it sounds mad, but most of my problems went away when I switched from hard-wired to wi-fi.

I run Zwift on a 4K Apple TV box and also have fibre BB.