Works on nVidia Shield TV

Great. Thank a lot.

I used your files and I used my own and I can’t seem to get it to work on either a 2015 or 2018 shield. I can get it to say “verifying download” then “opening game” but then it closes itself. I have tried several times.

I am able to install and get Zwift running on my Nvidia Shield TV; however the problem I am having is pairing my smart trainer via Bluetooth. It is a Turbo Muin with Misoru B+ sensor. The thing is that both my phone and Amazon tablet will detect the Misoru. My Nvidia Shield will no even detect it. Any suggestions?

What trainers have been successfully paired with the Shield?

What about the 4iiii Viiiiva heart rate monitor to act as an ant+ to Bluetooth bridge? Any success stories?

1 Like

Thanks for uploading those files! I was about to ask for some files which worked to test.

I am on a 2017 Shield. It says ‘Zip missing. Attempting download” and I followed your instructions to the letter. Even killed it and reloaded it. Odd. Can’t think what it could possibly be missing.

In app permissions it asks for camera, location and storage. I turned all on. No dice still.

I kept on getting this until I relased I also needed the OBB files. Make sure you’ve definitely created the directory under /home/Android/obb named “com.zwift.zwiftgame” and paste the obb file in there.

If you’re using something like ES File Explorer, it’s not immediately obvious, but when typing after the “com” it’ll actually put in a space character between that and the dot. Remove that (and any additional spaces) so that it is just “com.zwift.zwiftgame” -then paste the OBB file in there.

Thanks! I got one step closer. I looked closely at the name. A “(1)” had been amended to the file name by the downloaded. Now it verifies and goes to load game, but the turquoise colour fills about quarter of the top right, before crashing. Tried clearing data & giving all permissions again. Will search here to see if this has happened before.

I found one example of exactly the same thing, but no solution in the thread.

I’m wondering about screen size because of how the turquoise shrinks to roughly quarter of screen. My box is set to 4K with 10 bit HDR. What display settings have you got?

The other possibility I can think of is that they’re trialing ANT+. I have 3 background Ant processes - from memory - Ant USB service, Ant radio and Ant plugin. There is also the Tacx training app, but I’ve tried killing that.

Did you guys see this post Nvidia shield ?

Reduced 4K to HD & HDR to “limited”. Still nothing different.

I found only 1 other person who had the same problem. They also have a USB memory stick installed permanently. Do you & it works anyway?

I just got this to work using the files provided. Lots of issues, but it all stemmed from ES File Explorer adding a bunch of junk characters to the main.32.com.zwift.zwiftgame.obb filename. Once I moved the file into the com.zwift.zwiftgame folder I renamed it to the proper name, launched, and the game and it worked!

I did get the blue screen but I already have a mouse and keyboard hooked up to my shield tv, and a click of the mouse + a couple swipes to the left got me to the login screen. Now to actually try out a few miles!

Great news Anthony! Please report your experience afterwards :slight_smile:

I rode a few miles with it last night before switching to my preferred method, which is streaming to the shield tv from my pc (in a different area of the house) using an Nvidia GPU via moonlight.

Here are my findings:

  1. Performance was exactly on par with a non-4K appletv.

  2. The Shield TV seemed to only support 2 Bluetooth devices (just like Apple TV), so I was only able to pair my smart trainer and HRM.

  3. When I tried to switch to using the companion app Bluetooth devices, I could see them, but they wouldn’t connect. Possibly this is an issue with backwards compatibility between the updated companion app and the older version 32 of Zwift.

  4. Otherwise it’s very rideable! I’m just spoiled by the graphics on my pc. Moonlight streaming to the Shield TV and then using the companion app for Bluetooth is a pretty awesome experience, so that’s why I didn’t continue testing.

The disparity in graphics quality between the Shield and PC is really disappointing. It would be really nice to have the option to increase the quality (on all platforms). I’m sure even the PC graphics could look much better with a few tweaks!

I have been able to get Zwift installed on my Shield using the linked APK above. It all seems to work fine, but it won’t see the Wahoo Blue SC or a discrete Wahoo BT/ant+ sensor on my bike on my non-smart wind trainer.

I loaded the companion app, and got a notice in the Shield app that I was using a companion app, but I don’t get the phone icon when I try to add sensors, and I don’t see the sensors on the companion app either. If I click the Bluetooth icon in the companion app, it tells me no sensors are paired and to pair them using the main app.

Suggestions? It feels like I’m so close… And yes, the companion app on my phone is on the same wireless network as the Shield. I can pair the sensors to the phone using Bluetooth, but the companion app doesn’t find them.

I seem to be stuck on the home screen. “Welcome to zwift… Join riders from all over the world…” Three “panning” dots at the bottom but I can’t seem to get past this point. Tried the remote, tried the controller, tried various remotes on my phone (Android TV and shiled remote) can’t seem to get to the login screen. Any thoughts?

Turns out I needed to use a mouse-like accessory. Got into the app but it keeps crashing around 3-4 miles in. Will file a report

1 Like

Has there been any update to the APK or anything as I cannot get it to work on my Shield even after following the instructions

Are there any updates on an official support for Nvidia Shield/Android TV? It sounds like the Android app has moved out of beta.

2 Likes

Can I get the apk file Please

1 Like