Workouts not registering as complete in training plan

Posted last night about problem with workouts not being credited to training plan. Same issue again tonight!! What the ■■■■ is going on @GoZwift ??? This is not good enough! :rage:

from one of the other numerous threads on this issue:

1 Like

Thanks Mike. It’s incredibly frustrating! Wonder will they let us know when it’s fixed!

1 Like

you don’t have to re-ride these - you can mark them as complete when viewing the training plan and it gives you credit as if you rode these outside (even if companion still shows it as a completed activity in your feed)

Wow I’m seeing the exact same problem. I’m a software developer and I don’t comprehend the “workaround”. I have most definitely saved every one of the workouts and they all show up in my Zwift activities feed as well as in the companion app and Strava. For now I’m marking them manually as complete. It’s annoying because I didn’t figure that out until a few had expired from my prep and first week of the Build me up plan. For what it’s worth I’m using the Apple TV iOS app. In case it is relevant every time I go to use Zwift I have to double click the button on the Apple remote and swipe off the app to restart it to hear any music on the start screen or sound effects in the game. So plenty of bugs abound. Is there a Jira we can log stuff we find because I know of several others like gates moving while in training sessions if you will be double backing like in London or Richmond.

1 Like

No, nothing like that. Just this forum and Zwift support.

Having similar issue here. do training ride, it doesn’t complete in plan, but uploads to strava and shows in activities. session then expires on plan, or like tonight’s just disappears from plan.

for info, using Apple Tv app and android companion app (pixel 4a)

Yeah same issues here. Had workouts credited from the week and then they seemed to disappear. Also noticed that I didn’t receive credit for the PRL London as well after completing the route. Workouts seem to be greyed out on companion and can’t be noted as being completed. Just started this week. Using Apple TV and never had a problem before.

I have had the same issue for the last few weeks - completing the workouts, saving them and exiting the app. They are showing on strava - but with an odd time stamp - and then no record of having done them in either main Zwift app or companion app.

I thought it was maybe triggered by me having done a few rides out of sequence but this week I’ve done what Zwift told me to do and neither ride recorded as completed.

It is simple enough to mark them as “I did it” on the training plan in the Zwift app but annoying.

I hope this gets fixed soon as clearly a widely experienced bug.

This is happening to me constantly these days.

I always save the route from Zwift (on the Apple TV) (as per the workaround post early in the thread).

I end up having to mark the workout as having been done outside, but I don’t yet know what I’m losing out on.

At the end of today’s workout, it said something along the lines of “Great ride! Now just a couple minutes of cool down, and you’ll have another session checked off!”

LIES!

:laughing:

1 Like

I have the sound issue sometimes as well on ATV - but I fix it by switching the tv to a different HDMI input and then back to the input for my ATV and sound restores.

Me too. This must be an issue in recent versions. My Build Me Up workouts are all in my list of activities so clearly I saved them. Bu I have to mark them all as done outside the next time log in. If I forget I lose credit for those workouts. Please fix this!

1 Like

Another observation today; I could have sworn I switched my jersey and helmet a couple days ago, and I’m sure I was wearing that jersey yesterday, but I noticed today that I’m back to my old garb. Strange things are happening in the Zwift dungeon!

I have the same issue, does not register the stars on the plan but does in the companion app. I had an email from Zwift saying they are aware of the problem and use the “i did it button”.

Same issue here. Also using iPad and iPhone. Only just noticed my session at the weekend didn’t register on the training plan and has now expired. :angry:

Just completed today’s session and it shows in Strava and on the companion app under activities but training plan still says it’s outstanding.

Same as the other users, saves in companion and Strava but does not update the training plan.
iPad mini 5
iPhone X
Thanks

Same here - iPad Air 4, latest App version. Last 2 workouts of Gran Fondo Plan Week 5 done & saved, don’t show as completed.
Other observation: those “motivation comments” displayed during the last Over/Under workout didn’t match the actual Interval, really weird.

I have had the same issue now for about 10 days. I ride the workout and it exports to Strava and is also in my completed workouts but the training plan does not get updated. In fact the training plan often changes throughout the week, sometimes 4 rides, then 5 rides. If I quit the app and restart it seems to go back to normal but doesn’t register. I am using companion on iPhone 11 Max and Zwift on iPad. I have deleted the corresponding apps from all devices but still no joy.

Additionally i found that there is also a meetup bug in iOS where you do not have the option to keep riders together. Had to have an ‘Android’ friend setup the meetup for a recent ride.

Same issue here. Doing Build Me Up on a IPad Pro with the latest IOS14.4.1

Rides show on companion and history but non in app. Been an issue for me since the beginning the program.