Workout on Elite Direto XR suddenly far too hard

  • Platform and OS: Mac with MacOS 10.15.7 (Catalina)
  • Zwift version: 1.19.0 (100118)
  • Not using Companin App
  • Based in Belgium
  • Trainer: Direto XR, with latest firmware updated

Dear All,

I’ve been happily using my Direto XR on Zwift for 1 year now.

Since a few days ago however, without any changes done in my setup, I experience much harder workouts (around 25% harder).

ERG is on (and always has in workout mode), my cadence is aligned and stable, however power is about 25% higher than on target, and Zwift continuously says “reduce power”.

If you look at the attached picture, you see that my warmup started OK, but then became harder than expected (bringing me to close from my red zone already, while it usually ends at the high end of my blue zone), and then first interval (220W) immediately gives me a power fluctuating around 300W! I’m of course OK with fluctuations, but the average is obviously far too high.

I have:

  • Re-initialised my power trainer, and updated it to its latest firmware.
  • Done another trainer calibration, via the Elite iOS app
  • Done another trainer calibration, via Zwift
  • Uninstalled and reinstalled Zwift (the ugly way though: Moving the app package to the trash, and re-downloading it)

Every time, I re-tried a workout and suffered from the same.

I then tried a workout using a trial on FulGaz, and it seems OK… However I’m not keen to leave Zwift, unless I really have to.

Are there any recommendations on how to work around this within Zwift?

Many thanks,
G

Has your FTP been automatically adjusted up due to your 20 minute power registering higher? I would have a look at that, and compare it certainly with what’s entered in FulGaz.

If so, might be worth re-testing your FTP.

Many thanks, but I can confirm FTP wasn’t changed in Zwift, and I’m actually in great shape, so nothing to explain a sudden issue like this.

Moreover, it gives me the expected and very achieveable targets, but puts too much power (while telling me to reduce it!).

Happended to me this week, too. Elite Direto XR, Zwift on Windows 11. Combined with the crashes with latest AMD drivers it is really annyoing. Zwift ran great for about a year und now there are multiple problems. For calibration and restart helped, but the behaviour was the same.

Thanks for sharing, and strange that several users experience such a sudden issue almost at the same time.

Anyone has ideas how to fix this?

Today, I’ll do my scheduled workout, but disabling ERG. Wish me luck :wink:

I have a different problem with my XR-T, though it might be a Zwift problem; every so often the cadence drops to half of what it should be. I need to stop pedalling briefly to get the cadence to be read correctly again.

Today ERG problems also appeared on Android (which I have to use because Zwift will randomly crash with Windows 11 on AMD Drivers). Well now I am out of options und can cancel my subscription because after one year of no problems I have now no devices capable of running Zwift without errors…

Hi all. I need to revive this topic.
After a few months without ERG (to do the 50000m ascent challenge), I want to use it again.

Please read 1st for full description.

Once more, I do a normal training session, and after about 5 mins in the middle of a long stable 235W interval, I suddenly get around 315W with a constant « REDUCE POWER »!
Well, reduce it yourself, I’m super stable at 85rpm!

I tried again and again , once it didn’t fail, and the next time it failed again.

It might be the Elite Direto XR, but looking for solutions or recommendations here.

Thank you!

I would raise a ticket with Elite support and go through troubleshooting with them.

I have the same problem with my Elite Direto XR. Firmware is up-to-date. It works fine on the Elite app. I find that by switching Erg mode on and off and/or playing with the resistance levels in the companion app I can usually get the resistance to normalise, but it is not a permanent fix, which is very frustrating and doesn’t make for a pleasant training experience. In my opinion this product is not compatible with Zwift.

Hi I am having the exact same issues with my Elite Direto XR. I have tried everything and still not able to sort it out. It’s very frustrating !!

Same here, also noticing intervals way over 300 W on my zone 2 rides which should be 200-220.

Elite Direto XR which worked fine last year, using Zwift on MacBook and/or iPad. Using Elite’s myE-training app I noticed no problems, and calibration has been fine and in line with my external power meter all the time. Going through the steps with Elite support hasn’t gotten me anywhere so far…

Interestingly I also noticed resistance issues in ERG mode a few times when using my bike computer/headunit as the controller using ANT+, so I figured it’s a trainer issue rather than a Zwift issue… seeing this thread I’m not so sure anymore.

edit: To all of you who experience the same issue, please ‘vote’ for the issue to get some recognition and attention! Also check out the responses in Current Issues with Elite Direto Trainers

Update: after a month-long and slightly frustrating process with the people at Elite they told me there was no detactable fault. However the problem is clearly there, and it occurs not only with Zwift but with different apps including their own, and using multiple devices as well.

So they conclude it must be the trainer at fault after all, and I’m getting a new one under warranty.

1 Like

Thanks for sharing the update! Good news for you, and hopefully for us. Would you be so kind to share your case number with Elite? This would allow them to connect the dots when I (we) contact them. I will tell them that I would like a swap too.

My experience with them was far from smooth, it took me a month to convince them of what seemed obvious to me from the beginning.

To get there as soon as possible, be ready to show them:

  • that the problem occurs on both zwift and their own myE-training app
  • that the problem occurs on multiple devices (tablet and laptop, or appletv for example)
  • that the calibration is okay and the power is verified by an external power meter

They will need fit/tcx files and the trainer diagnostics from those sessions, but they can explain how to get them.

They might send you a json configuration file that didn’t do anything for me, but after the above that was the only thing they could try.

Good luck all, I hope you’ll get there without the frustration I had