Workout not loading in Meetup or Event

Since the recent game update I have had problems with workouts in Meetups & Events. On 1/13/22, I signed up for VO2 40/20 at 7:00. When I joined the event,the workout was not on the left, and my avatar did not have the tablet in front of the handlebars. I was in the group, but didn’t get any resistance. I quit & tried to login & join again, but had the same problem.
Today, I joined a meetup, but had the same problem. I picked the workout, joined the event, and nothing. No workout, no tablet on my handlebars, no resistance. I then tried to leave/rejoin and I got the workout, bu wasn’t in the meetup with the rest of the participants.
Workouts from my custom folders or the list on Zwift work fine.
I use Apple TV4K.
I then tried again on my iPad & PC, and I had the same problem.

I did however find a way in which I picked the event from the Companion App after I started a ride, and that worked, but an attempt the same way earlier didn’t work.
I’ve been doing meetup workouts & event workouts for a few years & never had this problem.

Has anyone here experienced the same problem?

What do I need to do to fix this?