Workout mode - Ergo settings for Bkool trainer appear to be out


(Steve C) #1

Hi,

 

Just tried workout mode with a Bkool Classic (latest firmware with ANT+ FE-C).

When the system set the ergo resistance on the trainer, the output displayed was about 20% higher than that demanded  - even dropping gears or cadence, the resistance would maintain an output of around 15%-25% higher than needed.

It certainly felt like the output was what was being displayed - it hurt! If I stopped pedalling, the system would take it out of ergo mode for that segment - so I could complete it by trying to match the requirement through gears and cadence - but having to stop first for about 30 seconds killed off any change of sticking to workout intervals.

If it’s of any help, TrainerRoad are having a similar issue the the Bkool Classic and Pro running resistance higher than demanded - so it sounds like it could be an issue with the Bkool spec they are publishing.


(Stian Larsen) #2

I have the same issue with the Bkool Pro. 

I tried to start a FTP test in Zwift a couple of times, but find the following issues making it impossible:

* The watt values seems very low compared to the effort on my old tacx flow or using the Bkool with the Bkool simulator. 

* In ERG mode, increasing cadence does not reduce torque nearly as much as it should. It is nothing like riding outdoors or using ERG mode on the old Tacx Flow (Which is kind of opposite; having higher rpms on the rear wheel is somewhat easier). In Zwift I end up on the easiest gear, and grinding on low rpms what should be easily maintained 250W. This is during the acutal FTP interval which I guess is not ERG mode?

* I can maintain decent wattage in the climbs but get knackerd on straigs with 30 percent lower wattage. 

* Coasting down a 5% decent with only enough pedalling to turn the wheel gives a speed of 15 km/h and decending. Thats not how it works outside where gravity would get you up to at least 40 km/h. 

I guess Bkool must fix something in their FE-C ERG mode logics, or Zwift needs to remap the watt and speed readings and ERG watts sent to Bkool. 

In addition I would like to have some averaging on the watt values used to rate the various segments of a workout. Its very hard to stay within the limits for each segment.


(Mats Lindh) #3

Same issue with a bkool pro here as well - the resistance is all out of whack after a heavy section. Trying to get the wattage down again becomes impossible, as running in the easiest gear just becomes futile with 30 rpm and very uneven efforts. The watt graph looks like a complete mountain range instead of a decent, straight line.

Pausing the let the ERG mode disengage solves everything, and allows me to keep an even pace (and keep the Watts stable-ish) at a suitable set of RPMs.

Haven’t noticed any issues in regular Zwift rides (except for a small delay between landscape change and resistance change, but that’s understandable).

My last ride (24.11.2015) should have a data file that shows the issue. If needed I’ll be happy to provide any other debugging information or run the usb through debug or something similar.


(Jonathan Stone) #4

I am with you guys, the resistance is setting way too high in the Zwift workout modes on Bkool Pro, making it impossible to use really.  I did manage an FTP test in Zwift, but it was stupidly hard work and my result ended up being 195 and the same FTP test on Bkool simulator gets me at 270, which also ties in with my Strava and Training Peaks estimates from my Garmin, while out on the road.  I also think that the resistance is setting high in normal mode too, and while it very usable in that mode (unlike workout mode) I again think the resistance is probably in the order of 30% above where it should be.  I understand that TrainerRoad have tested the Bkool Pro and they are saying exactly this, that the Bkool Pro is setting the resistance 25 to 30% higher than it should.

I think Zwift is great and I would like to use the workout modes, but Zwift, if you are going to keep us Bkool’ers, then you need to do what TrainerRoad are doing, and work on sorting out these issues ASAP.


(Richard Sparkes) #5

I’ve got the same issue. Is there any way we can disable the ERG mode entirely in the Bkool trainer until a fix is available ?

I bypassed the problem by stopping every time ERG mode kicked in on an FTP test in Zwift but it is a pain.

Do we know if anyone in Zwift or Bkool are working on this ? I’m still not sure who’s issues it is.


(Steve C) #6

Yes - when you pick the workout, there’s a radio button to enable/disable ERG (it remembers the option between sessions too).


(Richard Sparkes) #7

Wonderful thanks so much, I missed that one.


(Julien G) #8

Thanks for the tip - I will try tomorrow. I guess you then control the power targets through gear shifting ?


(Richard Sparkes) #9

I did a test at the weekend and this tip worked wonderfully.

Yes, just used my gears to reach the desired power.


(Jonathan Stone) #10

Brilliant, thanks, will try this.  So, I am assuming that when it is not in ERG mode that it uses power curve data they have established for Bkool PRO trainers?  As such, I should do another FTP test and that I assume should be more accurate and closer to my FTP from Bkool using ERG mode on their software?

 

 


(Steve C) #11

I’m not sure how Zwift uses ERG mode in FTP tests, as it shouldn’t be setting a target power for the resistance unit - rather, it should set a fixed resistance and let you pick gears establish a maintainable cadence and power. Which, to be honest, sounds like running a workout with ERG switched off (i.e. resistance isn’t altered for hills etc).


(Richard Sparkes) #12

Good question, sorry I don’t know enough to confirm that. I guess someone at Zwift might ???

I’ve dropped the Bkool software in favour of Zwift, I got fed up battling with their interface.


(Jonathan Stone) #13

Hmmm, I am wondering if when you first go into Zwift if, as opposed to setting the Bkool Pro as a ‘Power Source’ and then ‘Controllable Trainer’ that it will let you set it up as a ‘Speed Sensor & Classic Trainer’ instead?


(Steve C) #14

Probably doesn’t do anything different, but have you tried just setting up as a ‘controllable trainer’ and not ‘power source’ first? I do that with my Bkool and the FTP test was fine.


(Hugues Compere) #15

Hi,

I’m using Bkool Classic and it’s work fine with ERG mode in Zwift and also TrainerRoad.

The only thing I do is to unpair cadence found with bkool. I pair my Garmin speed cadence. Perhaps a clue.


(Steve C) #16

Thanks Hugues - I swap cadence for a garmin one too. But when ERG is enabled, I always end up outputting higher than the app requests. So when I’m supposed be pedalling at 220W, the resistance demands about 260W - changing gear and cadence has no effect.

 

Can I ask what version of the Bkool firmware you’re running? It should be in the bkool app somewhere.

 

 


(Hugues Compere) #17

Hi Steve,

My Bkool firmware seems to be v 2.04.


(Steve C) #18

This sounds promising - looks like Bkool may have found a firmware issue: 

 

http://support.trainerroad.com/hc/en-us/articles/201697324-Bkool-Electronic-Trainers?page=3#comment_202745996


(Phil Whiffin) #19

Yes I hope they sort it out soon - make sure everyone emails bkool through their support page as this issue has been known since October:

http://www.cyclechat.net/threads/problems-running-a-bkool-trainer-with-zwifts-new-workout-mode.190065/


(Dan Harris) #20

Same issue for me on a BKool Pro. Tried a Zwift workout last night and couldn’t cycle slow enough to get the wattage down to the target level. Will log a ticket with BKool support in hope of getting a fix for what appears to be a common problem.