Windows 10 - Zwift Won't Load - Error Code Z117

Is there any actual fix for this error message??

Zwift update failed during patching. Error code Z117 at line 602 in patcher.

Used Zwift back in 2016, booted up the PC app, and the update failed.

Uninstalled everything, programs folder & docs folder (just not registry) and re-installed off the Zwift website - re booted computer - Windows APP still won’t load.

Keeps giving me that above error message.

From what I gather, nobody will respond to this or the customer support ticket I created.

I haven’t even got on my bike yet and I’m already regretting paying for this monthly membership…

Any ideas that actually WORK??

Rob

Hello Rob,

I have Zwift installed on 2 Win 10 computers (both 1909) and it installed and runs fine so this is something more specific between Zwift and your computer. Zwift support def. seems over loaded right now, took them a week to reply to my first ticket.

Couple questions for you.

  • Is your windows 10 fully patched to 1909? (just an easy way to eliminate any other issues)
  • Are you using Antivirus and if so what? Possible it is blocking the process for updating with a false positive. (logs in AV should show that)
  • Uninstall the app again, then go to these folders and delete all of the contents, just incase. You will get a warning about not being able to delete some files as they are in use, just click skip all of them.
    C:\Windows\Temp
    C:\Users[Your Windows Account Name]\AppData\Local\Temp
  • List item

This other thread notes about a folder in your Download folder, if you have a Zwift folder there, delete that as well.

None of that works.
Windows is updated. Latest 1909.
Deleted temp folders, and the app data folders. All directories besides the registry were deleted.
I restarted the pc, then redone loaded the windows installed, same error.
No firewall, virus scan is avast, basic free, and was disabled prior to the install process starting.
My Mac it installed fine, but I don’t have a lightning to HDMI so I’m really wanting to use the laptop.
Pretty frustrated.

i think my specs tho are old should still work no?

That screen doesn’t show what your graphics processor is. But as far as CPU and RAM it meets specs to run Zwift

Old,
Inter ® HD Graphics 3000

IIRC HD 4000 was listed as the minimum internal graphics. You can try to see if Zwift will load on that machine but the integrated graphics might be too old.

If it does you would be limited to the basic (lowest) resolution.

1 Like

Thanks dan,
Would the GFX prevent the app from completing the upgrade tho ? The app loads let’s me log in then crashes and won’t load or complete the update.

Im not super tech savvy but my understanding is nothing will prevent Zwift from installing on your machine except for lack of disk space. I would guess it’s crashing because your integrated graphics isn’t strong enough to handle the game.

If you have a smart phone you can run it on iOS or Android. Or if you want a big screen AppleTV is the cheapest option to get running (but it’s Bluetooth only)

Appreciate your help.

I just wish support would chime in to confirm.

I don’t have a smart trainer; so I need to use the ant+ and the laptop to watch on my Tv. Much easier then trying to prop up an iPhone somewhere to ride.

Really not idea but might unfortunately be the only option… frustrating

Thanks again Daniel

Is this a system you could throw in a GFX card, if support came back and confirmed? Even a cheaper low end card would give you at least 1080p (i am running HD4000 off my i7 and it runs perfect so far with 200+ people in a race)

Thanks Matt,
Not sure it’s an 6/7 year old laptop. Not sure how upgradable the insides are. Likely not worth it tbh. I’ll probably just have to use my smartphone and deal with it. I don’t suspect there’s a workaround they’ve obviously dialled up the specs needed since I last Zwifted…
sucks

In that case nope, not option then to update graphics and even if you could upgrade the CPU, mobile chips tend to be so outrageous a new laptop is often a better option.

I think you might be correct. Too bad they upped the requirements.

Had the Z117 error message when I update the program.
Somehow seems like my Wifi is not working due to the IPS issue in my company dormitory’s wifi network.
My solution was using the VPN to change my IP address to another country like Korea,
and IT WORKS!
Done updated the program, login and logout the program, close the VPN software and restart the program with my current IP. No issue for login.
Perhaps when the next update I might need to do the same trick.
Cheers!

Hi Rob;

I know this is 8 months later, but have you managed to get it working.
I have had same issues and investigated last night and posted a fix which works for me in the general discussion forum.
Thanks
Graham

@graham_swan
Sorry but I can’t recall what actually worked to let me get back on and riding.
However I eventually gave up and completed a factory reset on my computer. It’s just an empty shell now with zwift a different riding app. Nothing else is loaded on the machine and it appears to work. I’m not using zwift these days but the other application instead.
Sorry I couldn’t be more help!
Good luck,
Rob

I had the same issue, the trouble was in the Avast antivirus program.

What worked for me was going into Avast settings and creating a custom rule for Zwift app.
The problem is Avast blocks integral parts of the update and you can’t set up the rule for Zwift launcher prior to hitting install. So the 1st install is a dummy only to setup the custom rule. Then you need to uninstall and reinstall Zwift again and the update should be 100% fine.

Let me know if it works for you. Good luck.