Windows 10 recaptcha_en.js login error [November 2021] [SOLVED]

Getting the same here, I manage to get to the Blue Zwift Screen as far as ‘‘Ride On’’ then it just disappears and will not go any further, I’ll try blocking gstatic

You are right, I didn’t realize this only affects Internet Explorer. So the cross effect should really be very limited.

But it seems recaptcha can also be used also in “invisible mode”. And since the script is restarted after every keystroke, maybe it tries to interpret how you enter your credentials somehow.

I have just started getting this problem in the last two days. I regularly log out and log in to Zwift as family members have their own Zwift account but use the same PC/Kickr setup.

This is really annoying now. I have to click Yes in the Javascript error page multiple times when trying to enter my password. Eventually it might all get through and login, other times it is just in a loop of this script error.

This is on Windows 10.

I hope this is fixed soon.

I still can,t get past the script. The message comes up after EVERY character I type in. Logging into my account via the Zwift website shows I have no data. Not a mile. I have uninstalled and reinstalled three times with no result. And the login doesn’t recognise my password. Very, very frustrating.

@Sean_Bolton7373 @Martin_Cullen1 while it’s not ideal, you could try the workaround described by Jesper and Dave above:

That did the trick for me while we wait for Zwift to fix the underlying issue.

  • Start menu / Windows key
  • Type “Internet Options” and select the Control Panel item

  1. Press the Windows key + R to open the Run command box.
  2. Type inetcpl.cpl and press Enter.
  • In the dialog box, select the Security tab, then Restricted sites



  • Then Close


You should now be able to run the Zwift launcher and log in without the script error (might need to restart Zwift).


Thanks for the advice. I have tried blocking the gstatic website as described and it seems to have fixed the problem.

Same problem for me as well. Zwift, please fix this.

Hi @Steffen_Karstoft_DZR

welcome to the forum…

Did you see the temporary fix above?

1 Like

Yes. That one works of course. But even though work around exists, the issue should still be fixed. It seems like you’re working on it as I read the thread.

Thanks for the work around and detailed screenshots because initlaly I was trying in Internet explorer and it wasn’t working. This isn’t ideal and this sort of thing should be patched with an expedited approach. Not everyone is techy minded nor should have the patience to go looking for the answer whilst sat on a trainer, bibs in a cold garage wanting to train. Again community coming up on trumps :+1:


I had this for the first time this morning, I just hit yes a couple of times and it worked for me.

1 Like

Same here, I just hit one of the buttons (possibly Cancel) once and things went on normally from there.

1 Like

Perhaps they’ve changed something already, if not fully fixed it yet. When I first saw it, none of the options would stop it coming back up when I tried to type.

If they have changed something it broke it for me! Unlike Zwift I know!

first time I had seen this was this morning

I have this problem as well. I am only using my windows 10 pc for zwift so I have problems where to find the place to make the required settings. Can somebody guide me to the place where these settings can be made?

I am not able to follow these guidelines:

  • Start menu / Windows key
  • Type “Internet Options” and select the Control Panel item

@Eltjo_Biemold Press the Windows key + R to open the Run command box. Type inetcpl.cpl and press Enter.

Got the same error with Windows 11. Workaround is working.


Works, but I’m not sure how that’s easier. :rofl:

Thanks! Problems solved. I stopped using windows on daily basis long time. In windows 10 everything is at a different place than I was used to.

1 Like

Check out my orthopaedic shoes.


Probably helps if your computer has Windows in non-English and “Internet options” finds nothing…