Windows 10 recaptcha_en.js login error [November 2021] [SOLVED]

@shooj Getting this again at present, even on a clean build. Verified on another PC by logging out.


There is a workaround that works by blocking the website

See instruction in this thread:


I’m having the same problem. I have managed to work around it, but it’s a bit of a pain.

Although I could dismiss the error dialog, it seemed to make no difference whether I said Yes or No to allowing scripts to continue running. It also came back with every keystroke.

I worked around it by typing my password into Notepad, then copying it. After dismissing the error dialog, I right-clicked in the password field and selected Paste. Then I was able to click the Login button. IIRC I had to dismiss the dialog again, then could click Let’s Go.

Windows 10 Pro
Build 19041.1052

The version of IE on my Zwift computer is also 19041.1052, but I have the same problem on my main PC (Windows 10 Home 19043.1165).

The script ( causes an error in the MS Windows Based Script Host.


Whether it’s the same problem or in the same place, I’m not sure, but it looks like it’s this “return”:


case N[1]:return S.return(S.D);

@Daren @Dave_ZPCMR
Thanks both for flagging this up. I’ve relayed to the team to investigate.

1 Like

@Dave_ZPCMR @Daren

Are you both on Zwift launcher version 1.0.52?

Yup. Old one doesn’t work any more. :wink:

1 Like

Downstairs, I’m not 100% sure. The PC isn’t on at the moment to check.

Upstairs, at this PC, yes it’s 1.0.52.

However, I just launched Zwift here and had no problem with the JS this time.

It was a fresh installation, so it might be that the full update process left it in a different state compared to my Zwifting PC in the garage. (It took about 10 minutes to patch everything - I think my downloaded installer was more than a year old.)

In the OP I had it come up immediately on a new PC build as soon as I tried to log in - this was on a clean and updated install of Win10 and Zwift fully installed with the up to date zwiftsetup.exe/launcher. I went over to my laptop and hit ‘Change User’ to test, which brought it up instantly. So in both cases for me the game was fully up to date. My main rig is permanently logged in (as I suspect most people are) so I wouldn’t see it there.

Same problem happens here on the setup which worked yesterday.

I worked around the problem by adding to Restricted Sites in Internet Options and clearing the cache.


Nice suggestion!

@Daren and @Dave_ZPCMR
Would you kindly try the two steps Jesper mentioned and confirm / deny results?

1 Like

I’m very sure it will work, not ideal though. Why’s it even being polled by the launcher, if it’s so unnecessary that it can be blocked without issue?

We’re working on resolving it from this side so that Jesper’s workaround isn’t needed.

UPDATED: But in the meantime, have a few confirmations that the workaround is sound. Please use Jesper’s steps above. Dave’s illustrated guide to Windows Internet Properties (below) is useful.
Type “Internet Options” in the Win10 search bar to get there.

UPDATE v2: We’ve had users confirm they’ve clicked OK until they get past the error message. This might be a simpler workaround.

Yep, works fine. I didn’t need to clear the cache, just blocked the URL via Internet Options.


Yep, works as a workaround for me too.

I also realised that the reason the problem had “gone away” earlier was because I was logged in already. Once I logged out the issue came back.


Same here for me another day another problem

1 Like

Having the same problem here, the workaround above (adding gstatic to restricted sited in Internet Properties/Security) seems to have worked, but why is this necessary?!

I am having the same problem as well. Blocking gstatic worked for me also.

Regarding Update v2 (see above): I had different script error issues before and was always able to continue by clicking on “yes”. But this does not work in this case (recaptcha). The error reappears afrer every keystrokje in the input fields.

Blocking gstatic is not a long term solution in my eyes, since this site hosts static web content of google. So this might cause problems in other applications. Many other websites will use google “recaptcha”, which is the following:
“reCAPTCHA is a free service that protects your site from spam and abuse. It uses advanced risk analysis techniques to tell humans and bots apart.”

Please don’t always quote a solution that one of your paying users came up with (already in earlier occurences of script erreors), but solve the problem properly.


Same here…
I thought that it was a virus but it seems an issue seen by several persons here…
I tried to reinstall zwift but still having the same issue :frowning:

Same here. It always popped back up irrespective of which option was pressed.

I agree it’s not a long term solution, and I’m sure Zwift don’t think so either. Since there’s no CAPTCHA in the Zwift login screen it would seem completely redundant. I dare say they can probably just remove it, and it might only be there because someone used some other code as a basis.

Blocking in the Internet Options should only apply to IE. Few people will use that as their primary browser these days (I hope). Chrome, Firefox, Edge etc. shouldn’t be affected. I’ve tested it, and even with in the restricted sites list, I can still load the script in Edge (the one most likely to take any notice of Windows Internet security options, I’d guess).