When paired via bluetooth, Saris Trainers cannot complete spindown through Zwift/report resistance issues

Installed a new iMac 5k 2019 and set up BLE for convience instead of Ant+ (stupid me). No resistance with my Tacx Neo (firmware most current) on latest Zwift version. Had to repair my sensors with Ant+ and lost track of the group ride I was doing.

UPDATE #3 : We have noticed some Zwifters have been experiencing similar issues after the update below. Please try the following:

  • Go to the iTunes store and update your device
  • Restart your IOS device
  • Disconnect all Bluetooth devices from zwift, reinstall (trainer) and calibrate again

This should get your ERG mode back up and running.

Please let us know if the issues persist, or any other issues arise.

1 Like

Hey Simon -

The Wattbike Issue may be something different. If you haven’t done so already, could you please send in a support inquiry detailing the issue along with the firmware version you’ve got installed?


Just tried to do the stage 3 on Tour of Watopia and it still does not work. I’ve reset Apple TV multiple times, multiple spin downs and nothing works.

Hi there,

I connect to Zwift using a windows laptop and Nokia 3.1 phone. Since the update I am experiencing intermittment resistance issues to the point where it gets too hard to pedal so I have to abandon a workout. I have a broken shoulder at present so was desperately hoping to stay fit on my trainer! Any fixes please for my setup?

Hey Terry - I would suggest calibrating your trainer, and making sure you don’t have any other cycling apps open at the same time. If you’re still finding issues, send a message to support@zwift.com and we can look into this further. Thanks!

This one is on me for noticing this way too late but my ERG mode has not really worked at all. I tried my Wahoo Kickr Snap with a laptop few times and yes it worked like a charm.
But whether it’s the Zwift app on my ipad or my Companion app on my iphone, ERG mode has NEVER and I mean never worked for me.
Latest firmware and all the apps are updated. Kindly help please.

Hey there - have you made sure that you are in ERG mode when entering the workout? You can also toggle back and forth within the app. You may also want to do a spindown calibration before entering your workout, and try the troubleshooting steps listed HERE. If you’re still finding issues, send us a support request and our agents can investigate further.

Did a workout yesterday and ERG-mode worked just fine but today it didn’t activate. It said “ON” but nothing changed. Tried turning it on and off a couple of times but just finished the workout without it. Would prefer it working though =D

AppleTV 4k with Neo2.

I did a workout on ERG mode on Sunday with former Zwift version (PC), all was fine. Power was locked by Zwift/trainer. No matter what I did I needed to maintain target power.
Since update I wasn’t able to use ERG mode properly. I did two different workouts. ERG mode was set on in workout screen. While riding I could easily go above or below target power by changing cadence/gears, Zwift doesn’t change resistance of trainer. It just gave information like “more power” and “less power”.
Toggling ERG mode of/on doesn’t change anything. When I stopped pedaling it gives “ERG mode temporary disabled”. When I started pedaling again it gave a message like “pedal steady to enable ERG mode” and then ERG mode was enabled again. But nothing changed.
Nothing else has changed on my setup: no Windows updates, same trainer, same connection (ANT+), no other devices connected.
When I use Wahoo app or my Garmin Edge I can use ERG mode properly from within these.
So I suspect something wrong with Zwift.
Any known issues?

Did you pair the trainer as controllable FE-C?

Hi Gerrie, yes, sure. As said, nothing on setup changed compare to previous sessions.
Other members of ZRG (Zwift Riders Germany) group confirmed ERG issues.

There was a silent update to version 1.0.42125.
ERG mode is fine again for me.

[10:03:53 2019-11-02] Patcher: Local version is “1.0.41943”.
[10:03:53 2019-11-02] Patcher: Server version is “1.0.42125”.

1 Like

I had this same issue today, tried 3 different workouts and all fine until I needed to go above 250w and then ERG mode has a fit and won’t let me accelerate at all.

Did calibration and testing on my Tacx Vortex utility app, and all seems fine. But when in Zwift it’s making the Vortex smell funny trying to put the power down when ERG doesn’t work .

(was on Zwift on Monday and Tuesday and didn’t have any problems, done nothing different today…)

I had the same after a Zwift update this week. On Tuesday everything worked well. After updating the Zwift on Thursday, my display is prompting “more power” or “less power” even when I try to keep constant cadence and power. It makes the following of my ftp level resistance impossibe as the resistance keeps fluctuating ±30% or so.
I haven’t changed anything, only the update.
Setup: Wahoo Kickr Snap, Win 10, Android companion, Wahoo cadence sensor, Wahoo Tickr X, Garmin ant+ dongle.
All the device have the latest firmware.

Help would be appreciated. Thanks.

I have the same issue with my Tacx Vortex. Did the Zwift Update yesterday and tried to do a Workout after. Enabled ERG mode and then the resistance went crazy. When going from the warm up to the first part of the Workout the Trainer raised the resistance so high that I could not pedal anymore. Smell of burned tyre all over the room… and the resistance did not go back to normal. I had to stop the Workout. A week eralier I did another Workout and had no issues at all. Trainer Firmware is up to date. Technical Setup of my Trainer is as prescribed by Tacx.

Same issue here Wahoo kickr 2017 model.
No resistance in ERG MODE during FTP test.
Any suggestions?

@VZT_Petri_Kyto @Rusti @THE_KINGDOM - Have you tried calibrating the trainer before your sessions and seeing if the issues persist? If they do, please message us at support@zwift.com and we can look into this further.

Rob, are you referring to the 20min section of the test or the whole workout. If it was only the 20 min section then it is because that portion ERG is off and you have to use your gears or the ± keys or the incline buttons on the companion app to change resistance.

I’m referring to the short FTP test, I believe the issue also occurs with the regular FTP test as well.
Erg mode is enable by default, I use it on my races etc but for the FTP Test based on my reading it seems this is a widespread issue.
I’m not using manual resistance mode as the FTP test I believe should include ERG mode?
Right now the result is is that I end up spinning out over 105+ RPM as there’s simply not enough resistance on ERG mode even in my maximum gear.

Please advise