When paired via bluetooth, Saris Trainers cannot complete spindown through Zwift/report resistance issues

Has this issue been solved yet? I bought my husband a tacx Neo 2T for Xmas. The erg mode didn’t function in Zwift which is the only platform he uses for training. I exchanged the machine for a wahoo Kickr and had the same issue. It is not us. We were able to get erg mode functioning in sufferfest, the resistance changed well and followed an erg workout program. Tried in Zwift again and the power was all over the place and resistance didn’t change on the Kickr. We are very familiar with the wahoo, it works well on our first generation machine, the setup is the same, just a new machine. Wahoo customer support say it’s a known problem with Zwift. Here most people see it’s a problem, so why hasn’t it been fixed yet? ZWIFT PLEASE HELP!

We use ant+ on windows. We have the same problem. Is there a work around?

Is there a workaround for ant+, windows, kickr 18, or Neo 2T? Had the same problem on both machines

Hi Zwift Support,

I too am new to using Zwift and I’m also experiencing zero resistance with my Tacx Flux S. I’m running a Google Pixel 3 Android screen mirroring via Chromecast to my TV.

On the app I can be pedaling like a mad man and still only showing 3mph on what looks like a hill and not feeling resistance at all.

How do I find out if I am in ERG mode or whatever?

Same here; the Tacx Flux S is connecting with Tacx Utility and Tacx program, it is up to date and possible to calibrate.

Back to Zwift; no calibration possible, not possible to put ERG mode on (while training) and speed/wattage has constant fluctuations.

Firmware is new (bought it this november) en software all up to date.

I’be bought a ANT+ Dongle (good/expensive one, from Tacx itself) so i’m going to try this afternoon. Hope for the best…

Nb: I used Zwift already for 2 months without problems. From last monday these problems had occure out of nothing.

2 Likes

I am having the exact same issue. About a week ago out of the blue my Tax Flux S started having myriad of issues with Zwift. Sometimes when I open Zwift, it can take 10-15 minutes just for it to be found (Using Mojave on Mac). I have verified also that firmware is updated, everything is correct on the Tacx Utility App.

I have been trying to use Workouts in Zwift and it doesn’t even recognize that I’m doing a workout - constantly shows I’m on Step 2 and I did a 28 step Workout. The ERG mode does not work AT ALL. It’s incredibly frustrating. I do not want to have to use an ANT+ Dongle, that is ridiculous.

Zwift - what’s the fix here?

Another Tacx flux S user with same issues (on mac), Tacx firmware is up to date, I calibrate the trainer frequently and yet as of 11/1/19 whilst following training plans there has been fluctuations in resistance using ERG mode, sat at ~330w and there was large drops in resistance, displaying in the range of 200w-250w whilst my legs start spinning like billy whizz - a bit frustrating knowing it’s a subscription service, hoping for a fix fairly soon.

Exactly the same today on Wattbike Atom. Large wattage fluctuations up and down during workout in ERG mode. Has never happened before.

@Kyle_Rogerson @Adam_Benson_Moxie @Allard_Lourens @Cameron_Webb

Hello all, our team has not been able to reproduce this issue specific to the Tacx Flux Trainers, and we’ll need some more information on your setup. If you have not already done so, please contact us at support@zwift.com and let us know any details of when this started to happen, along with your Zwifting device, Trainer brand and model, firmware version, and how you are pairing with Zwift (ANT+, native bluetooth, or bluetooth via Zwift Companion).

I’m having the same problems on my tacx flux s , using blue tooth , firmware is upto date and so is the zwift app . I can do any thing upto 600 watts in Erg mode but then if I try to do a 1000 watt sprint the trainer doesn’t apply resistance

@Josie.L: Can we change the topic of this thread, it hasn’t been about Saris trainers for some time.

Hi Josie, this issue seems to have returned with the april 1st 2020 update. Can you investigate further?
Thank you

New to Zwift, but definitely seeing huge lag in workout mode after recent updates.

My setup: Kickr -> ZCA (iOS) -> Zwift on PC (lag like 2,3mins)
Even if try Kickr -> Zwift on iOs there is still 1 mins lag.

@Gerrie_Delport This issue originally related to Saris trainers, so it will reflect that. We were unable to find any confirmed issues with other trainers, so any new issues with lacking resistance should be flagged to support@zwift.com so we can test and confirm a bug within Zwift.

That said, (and @Christine_Mardle, if this may help) we have found the Saris trainers to have a new but very similar issue: if being paired via bluetooth, you are currently unable to calibrate through Zwift. This would cause issues with resistance. Current workaround is following:

  1. Calibrate Saris trainers on Rouvy app
  2. Close out of Rouvy app
  3. Log on to Zwift and pair.

While we do not have a timeline at this moment, we are working with Saris to support the spindown through Zwift again.

I will go ahead and edit this post.

2 Likes

Followed the Advanced Firmware Options recommendation from the April 24th update message. I selected the latest version and ran the update successfully, but it did not fix my calibration spindown issue.

Once up to speed on H3, Zwift displays “maintain current speed” forever, or as long as I care to continue pedaling, vice telling displaying a message to stop pedaling as I’ve seen in many videos. If I let it spindown, the only option is to cancel the calibration. I’ve calibrated the H3 using the Saris app only. I’ve tried the Zwift calibration on Apple TV and IOS apps.

Has zwift sorted this controllable problem out with the gradient on the saris H3 yet? It’s been like this for a couple of weeks now and I’m starting to get frustrated

Is this sorted? I’ve just switched from having a Tacx neo to a Saris S3,and no resistance.I’ve followed all the advice,and still no joy.No reply to two emails to support@zwift.com either. Help, someone!

Hi @SamJ_J

At this point in time I have not see a response to indicate that Zwift found and solved the Bluetooth Bug that effect controllable trainers, especially the H3

Many thanks Gerrie; I meant H3 not S3. So what are we meant to do? Wait for an update?

Sam that is all you can do. You can still pair it as a power source only (leave controllable blank) and use it as a fluid trainer.

The power numbers will still be accurate, it just wont simulate the terrain. Then you can keep your fitness up until the update come.

What device do you use? Ant+ work on windows 10.