When paired via bluetooth, Saris Trainers cannot complete spindown through Zwift/report resistance issues


The first 7 blocks of the FTP test will have ERG on, but Block 8 is free ride thus ERG is off.

To increase resistance you can use ± to increase resistance or the incline buttons on the companion app.

Also make sure you are on the latest version on Zwift.

Okay let me try to make it a bit more clear. There is no functioning ERG mode at all on ANY stage of the FTP tests with Wahoo Kickr 2017 over Bluetooth. Doesn’t matter if it’s stage 1 or 3 or warmup, I can’t even get to stage 7 because my trainer has no resistance on ERG mode. There’s simply not enough resistance to do the test with ERG mode turned on.
Sorry to be direct but I’m trying to eliminate unnecessary back and forth here.
Further, as far as my research shows this is a widespread issue especially over Bluetooth.

Are you aware of this issue?


Thanks Rob, that cleared up that question.

Does other workouts have the same issue or only the FTP test?
What do you use for Zwift? And did you check that you are on the latest version?

It seems to just be the ftp test, although I haven’t tested all training modes.
Issue exists on both Android and Windows platform.
I recently had to migrate to windows because Zwift hasn’t made the app compatible with Android TV OS yet which is very unfortunate. At least now I’m able to run a full graphics.
ERG mode runs without issue in regular rides and races.

I must be on the latest version at it was only reinstalled recently with the migration over to windows.

Do you mean sim mode. ERG is only available during a workout.

Never heard of “sim mode” during regular rides I thought it was still called ERG… as you can turn it on our off…

training/workout… FTP tests screenshot below

Yes sim mode is for regular rides and ERG for workouts.

More ERG info.

I figured out that after a Zwift Update calibrating the Trainer again via tacx app solves the issue. After the next update the issue is back again, then I do a calibration and it works fine again. Kind of annoying but it is helping so far. Is this the normal and intended behaviour of Zwift?

Hey Zwiftees,

by now I’m really fed up with this issue, since nothing has help yet. I looked for a solution on this forum but can’t find anything helpful.

Since this indoor season, my girlfriend and I are having massive problems when training in ERG mode. First of all, our setup:


WIN 10 Laptop
TACX Neo 2 (2018)
Garmin Cadence Sensor


Macbook Air 13"
TACX FLux 2 (2018)
Garmin Cadence Sensor

We usually train together at the same time, but also apart. Now for the problem: When training in ERG mode zwift will not behave accurate in adjusting the resistance to match the required power output. Instead sometimes it doesn’t react at all, but must of the time zwift tends to lower the resistance so that the power output drops 20-30 watts below what is needed during the current phase of the workout. I’ve read that this issue might be solved by adding external cadence sensors instead of using the internal ones of the smart trainers. So, I bought the external Garmin sensors, what seemed to have helped at first. For some reason without changing anything from session to session the problem occurs from time to time. After finding a configuration that seems to work, without changing anything the setup will start bugging around the next time. I’ve also read that this problem seems to occur since Zwift added cadence to the ERG modes reactions to not add resistance when cadence drops due to the rider not managing to keep up, in order to prevent forcing him or her to a full stop since he then can’t even maintain the slower cadence.

Is there anything I could do? We have both ANT+ and Bluetooth as an option to most of the devices. Which is the better choice? Could it help to split the setups an use only ANT+ on one and only Bluetooth on the other? The most frustrating thing about this is, that usually you first realize the problems during the first hard interval of a training, mostly after a 10min warmup or even more. Changing the connections and trying different options has worked sometimes but only after a full restart of the app. Switching while pausing the workout never helped.

Any ideas? Plz

Best regards!

Hi Josie,
Yes, I am always calibrating the trainer before a session. So, I haven’t changed anything in my procedure.

I have the same problem. Using a Tacx Neo 2T, ios iphone, and blue tooth - erg mode does not work in Zwift. Simulation mode works fine. Firmware version 0.0.32. Garmin support said they are aware of the issue.

Hi all -

If the issues persist - I would like to request that you send a message to support@zwift.com. Please let us know what platform you are using, trainer you are using, how your are calibrating (whether it is on the trainer app or within Zwift), and what workout you are finding issues on.

Thank you!

Hi Josie, I am using Zwift on AppleTV + KICKR, everything works fine. I wanted to switch to the iPad. Unfortunately, ERG mode is not working, no matter if it is ON or OFF, the same result (seems to be OFF all the time). After searching the internet, I found this thread, which I think is related to my problem. I have all the devices up to the date (Ipad, KICKR have the latest software). I tried restarting, disconnecting, reinstalling, no results. What should I do to run Zwift on iPad + ERG mode? Is it a Zwift bug?
Thank you!

Hi Piotr,

Could you force quit Zwift on your AppleTV, so it is not open in the background? Have you also tried calibrating your Kickr on Zwift on your iPad?

Hi Josie, I calibrated Kickr on Zwift on the Ipad today in the morning, it helped ERG mode ON seems to work fine. Thank you!
However, after 45mins of the workout (it was before calibration), my Ipad froze completely! After restarting, Zwift tried to continue the workout but saved only the last 15mins of it. That was very strange. I have never had Ipad frozen. Have you any suggestions for it?

Hi Piotr - is your iPad up to date on the latest OS version? Were there multiple apps being used in the background?

Hey @Josie.L,

After the latest update it happened again. Did the update and wanted to workout and the trainer turned the resistance up as high as possible. No chance to ride like this. Several calibrations and spin downs later it is working again…

Edit: or at least I thought it would. Using erg mode in workouts is not working…resistance rises and rises and rises…

It worked fine bevor the update

Edit 2: just discovered that Zwift is not able to find the control for my vortex. Cadence and power are found but not the controll function when I am trying to connect via Bluetooth. Had connection established by ant+ before.

Hey Sebastian - do you have the Tacx app open in the background. It sounds like its being controlled by another app.

Hey @Josie.L thank you for your answer. After calibration I switched off Bluetooth at my smartphone and only the ant+ connection was established. I also turned off Bluetooth at all other devices around so that there could not be an interferences with the ant+ signal.

Hi. New to all this. I have bought an Elite Aleno smart trainer. I have both bluetooth and Ant+ and going from what I’ve read, ant+ seems to be the way forward. I have it set up and can ride in Zwift and use zwift companion. However, i get going and i can be pedalling like a madman but just not going very fast and other times can get up to 40/50 miles an hour (but that’s giving ll my effort) other times, it’s not cler if i’m on a hill or not, don’t think i am though and people are bombing past me and I’m hardly moving, like 3 or 4 miles per hour yet I’m pedalling like crazy.

I am still in my free trial period but really want to make this work before committing to a monthly sub. Apologies if this is in the wrong place but it seemed as good a place as any as i read some Elite trainers have issues. Can anyone tell me what i can do to get the best experience or is it a Zwift or trainer issue? As i say, the trainer is set up and is recognised etc.

Thanks in advance. Ride on!