Watts Get Stuck During Group Rides

Hello everyone, I’ve been experiencing sticky power during group rides and it is driving me mad. Below is my set up and some of what I’ve tried. Please don’t tell me to switch to Apple TV, that is not helpful and I doubt it’ll solve my problem. I switched from iPad to a dedicated laptop due to prior dropout issues and a year later I’m having this sticky watts madness.

  • Running latest Zwift firmware on HP EliteBook i7 connected to power
  • Wahoo Kickr from 2020; verified on app it’s the latest firmware, spindown via Wahoo app and Zwift app every two weeks.
  • Ant+ Dongle - USB from laptop and Ant+ end under two feet away from Kickr
  • Kickr (FEC) connected as power source, controlable, and cadence. Tickr HR strap is the only extra. All via Ant+.
  • Computer 5 feet away from Wifi router
  • Shut down Bluetooth on the laptop and most devices around me. I left it on on my phone to connect my AirPods and I use my phone for Zwift Companion. I’ve tried riding with my phone off and still have sticky power issues.
  • Watts get stuck for 15 seconds up to over a minute, at which point I’m dropped and I give up. Happen randomly during rides, 2-3 times for every hour ride.
  • I unplug the Kickr after every ride but leave the power box connected to the wall. A fellow Zwifter advised I unplug it from the wall and I’m trying that now.

Any ideas? This is killing my group rides :frowning:

Thanks guys

This doesn’t sound like sticky watts, but a hardware or connection issue instead. Can you try recording your ride in the Wahoo app or on another device (bike computer)? This will help us determine whether it is related to Zwift or the trainer itself.

How else do I describe my watts getting stuck at a specific number for 10+ seconds to minutes at a time? Whether it’s 100W or 215W I’ve been getting stuck while my HR and cadence keep updating. I now realize there’s some “sticky watts” racing cheat/bug. This is not it.

Updated the title of this topic to avoid confusion.

Try running a log file through zwiftalizer.com maybe that will give us some clues. Post the results here.

Will do that, thank you! And I’ll look to record a ride on Wahoo too as suggested but the stuck watts happen so sporadically, I struggle to ride on the trainer for too long without Zwift groups

Can you also try pairing up a Garmin bike computer (or similar) if you have one so you can see what power it shows from your trainer while you are on Zwift?

I do this with my Kickr Bike so I can see average power for the ride (which is important to me). This might bring another set of data you can look at to see if it’s at trainer level or Zwift level.

Have you tried using Bluetooth? I suspect there’s something wrong with your ANT+ dongle where it’s getting “stuck”. Either that or the USB cable or port (have you tried a different USB port? What happens when you don’t use the cable?).

By the way, don’t calibrate your trainer in Zwift. Always use the manufacturer’s app - that’s what Zwift themselves will tell you too.

Hi Mike, thanks for taking a look. I did a group ride today and had my watts stick for ~20-30 seconds at around the 28 min mark of my ride (6:38pm-ish) and near the end around the 43 minute mark of a ~45 minute ride that started at 6:10pm. Here are the results from the log file from Zwiftalizer… interestingly no Ant+ failures! It looks like my trainer on channel 1 might be failing a bit too much, which could be caused by interference from my WiFi? I just noticed I was on a 2.4ghz and switched to the 5ghz one so will see what happens next time.

Please let me know what i’m missing when reading these results, I’m at a loss trying to fix this. Thanks!

Rx Fail over 20% :face_with_peeking_eye: please place your Ant Dongle near your trainer with a shielded USB Cable or try Bluetooth.

It is already 20 inches from the trainer and am using a shielded cable. I changed to 5Ghz Wifi, will see if that works. I had more problems with Bluetooth (dropouts).

Hmmm, strange. Any 2.4Ghz devices near the trainer? How long is the usb cable? If its too long it can generate issues in transmission as well. Did you disable energy saving settings in Windows device manager for your usb ports? That applys to the Bluetooth device as well. Have you updated Bluetooth drivers to the newest possible?

normally if a kickr has transmission issues, power drops to 0 instead of maintaining the same value

Ah ha! I had not disabled energy savings for the USB ports. Just did, thank you, hope that helps. Bluetooth does have the latest driver installed, and I couldn’t find energy savings settings for that one. My computer is always plugged in and has best performance settings on.

My modem/router that transmits both 2.4Ghz and 5Ghz wifi is 8 feet or so away from the trainer/laptop, without any physical barriers. What’s perplexing is I hadn’t had issues until now.

Cable is 3 feet long. I read about length but it’s pretty inconclusive, might buy a new one to see what happens since this one is going on 3 years old. Good to know about transmission & a trainer issue being unlikely, I’m contemplating a new one but I got this one in 2020 and it worked flawlessly up until recently.