Wahoo KICKR Reverts to Resistance Mode When ANT+ Connection Interrupted


(Kerry Webb) #1

I had something odd happen during today’s tour of the Island. First, my trainer setup consists of a Wahoo KICKR trainer, a Wahoo Blue SC Speed & Cadence sensor, and Wahoo TICKR+ heart rate sensor. At ~25 minutes into the ride, the Zwift software lost control of the KICKR. The first thing I noticed was the Zwift Power output display briefly went to zero. The Power output returned within seconds, but the KICKR resistance no longer changed based on the grade. My guess is the KICKR mode was somehow changed/reverted to resistance mode. My understanding is the KICKR should be in Sim mode during the Zwift session. Unfortunately, the only way I could get the KICKR back into Sim mode was to exit the Zwift session and restart it. I don’t recall now, but I don’t think simply unpairing the KICKR, and then re-pairing it while still in the Zwift session worked.

This happed to me once before (~1-2 weeks ago), but I didn’t report it. At that time, I did a little browing through the Zwift Support topics and it occurred to me that the problem may be related to a temporary loss / interruption of the ANT+ connection. I repositioned my ANT+ dongle to be closer to the KICKR (closer and with no obstructions). My setup has remained in that position since that time and I have had no further problems until today (and I have used Zwift daily).

Since loss / interruption of the ANT+ connection with the KICKR is probably going to happen from time to time, would it be possible for the Zwift software to recognize when this happens and place the KICKR back into Sim mode?


(Vincent Beggs) #2

Kerry, I have noticed a similar problem with my KICKR. I have never had it drop out while I am riding but during the last three times that I have gotten off my bike for 10-15 minute break, coffee/lunch/etc. the KICKR is no longer in SIM mode. This is painful since typically if I have to get off the bike for 10-15 minutes, it’s in the middle of a long ride and I am forced to have to restart the app and my long ride turns into several short rides.

It would be great if you could somehow reconnect to the KICKR to reestablish SIM control.


(Tim Corso) #3

I noticed this last weekend, as did a few other people at other times. However, thinking back I think this might be a Kickr problem, as I noticed this happen in an IOS app called Virtual Trainer, when climbing Alpe d’Huez


(Siève Stand-Art) #4

This happened to me as well. Just chiming in that it’s a bit of an issue. I moved my ant+ stick, via usb extension. much closer to my bike; however I’ve never had an issue in Trainer Road like that in over 18 months where it moves from ERG to Standard on a dropout (which is rare.)


(jamie Andrews) #5

Had the same issue tonight…has never happened before and the set up(dongle distance) etc is exactly the same…but it has happened to me the last 2-3 rides…I’ve read where the laptop should be plugged in too, will try that tomorrow…hopefully just start up beta bugs and working them out with all our input


(Todd S) #6

I found the following thread to be relevant: https://support.zwift.com/hc/communities/public/questions/201339859-kickr-workaround


(Dmitriy Zelikson) #7

I had a similar problem which I fixed. My Wahoo disconnected and showed 0 power every 2-3min during the ride. Resistance also stayed the same regardless of the grade during the island ride. I got a $5 extension for my ant+ sensor on Amazon and places it underneath the Kickr. That solved the connection issue. The slope issue was solved by running the wahoo fitness app during the ride in sim mode. Just start it as if you were doing a workout and pause right away in sim mode on one of the options. Everything works really well now. 


(chris noland) #8

This happened to me today…wow did it suck :slight_smile:

what is the best firmware to run on the kicker?  I just updated to a released version from a beta…the ant stick is 3 feet from the kickr.  I was hoping the new version of firmware would crank down more on the hills as there is no way a 9% grade should be easy :slight_smile:

 

thanks

Chris


(Cody Corona) #9

Has there been any updates regarding this issue? It’s been happening to me all week, after running smoothly without issue for 2 months. Having my ANT dongle closer to my Kickr (where it wasn’t really close before) doesn’t seem to have fixed the issue.


(Nat Jakpaisan) #10

I have the same problem with my Kickr, I have set Trainer Difficulty to 100%. For some reason I still can’t feel the change in terrain in Richmond climb. I wonder what’s going and how can I fix it??


(Tim Corso) #11

Nat J.

Most likely the Kickr is in another mode other than SIM(ulation). If you have the Wahoo app you can connect to the Kickr while you are in Zwift and then scroll through the pages until you find the SIM mode. Turn it on and you will be good.

I agree this happens a lot to me. I hope someone fixes it really soon


(Nat Jakpaisan) #12

Thank you Tim, I’ll give it a go tonight.