View own profile/activities bug in Companion App

Hi Zwifters,

If you have set your privacy settings for activities to Follower right from the beginning of your Zwift career AND the standard for new activities is set to Follower as well, you can’t see your own activities during the profile view of the Companion App.

You click on your profile and then on Activities, you get the “This Zwifter does not have any activities” error message.

For this error to come up, every activity has to be set to Follower, no activity is set to public. As soon as you set one of your activities to public, this message disappears and you can view just this single activity, but none of your other own activities.

It’s like I’m viewing my own profile from a public perspective during the app, despite being logged in as myself and viewing my own profile.

This can’t be right and does not work as intented.

Hi @Mike_Medwed

I think I understand the first part about setting the “Activity Privacy Default” setting to “Followers”, but I’m sorry to say that I’m confused about that second setting you mentioned (e.g. “the standard for new activities is set to Follower”).

Can you remind me where I can find this, and I’ll try to get more information about this for you?

Perhaps you can share some screenshots as an example of what buggy type behavior you’ve encountered? Screenshots are often super helpful for understanding the issue.


Hi Steven,

You can change the privacy setting for each individual activity. And you can set a default, which then gets applied to every new activity.

I had this set to Follower right from the beginning. If I open up my profile and click on activities:

I then see this:

This Zwifter does not have any activities.

As soon as I change any of my recent activity to public, I can then see it though the procedure above, but only this single one:

It’s like I’m viewing my own profile from a public perspective and therefore cannot see any activities I’ve done.

@Steven_D Just want to catch up with you on this topic. Have you been able to replicate this?

This has popped up before but I couldnt find the thread.

For memory, you can see your activities when you view all your activities through the Activities tab on the Home screen though?

Yes, when I click on activities in the homescreen, then on “only me” in the upper right corner, I can see my activities just fine.

Hi @Mike_Medwed

Somehow this one fell through the cracks and I apologize for that. Thanks for the detailed reply with screenshots.

I don’t have a means to reproduce the issue but I’ve raised your concern to the team and I’m awaiting a response. It does seem buggy (as far as I can tell), but I’ll let you know when I have more information.