Very poor graphics despite Ultra capable system

Please share your computer specification (CPU, RAM etc.) as this problem is the most likely not connected with graphics card. You can post screenshot from dxdiag or logfile (type ‘dxdiag’ in search/run field next to menu start.)
image

My system information:

1 Like

My theory on this is that Zwift only recognises standard quantities of memory divisible by 8 - so 4096, 8192, 16384, 32768 etc - and anything outside that it doesn’t know what to do with. The systems with issues are NOT reporting 16384MB of RAM, as shown in the screenshots above and on the FB thread. Something else is taking up hardware RAM allocation before Windows and throwing Zwift off, which runs without logging any RAM at all.

1 Like

From the manual of one of these user’s motherboards (MSI A320M PRO):

So it’s taking some resource before getting into Windows. I wonder if this is causing the issue, if it means Zwift does not correctly identify the amount of RAM available.

1 Like

Great find Dave. Apparently there is bug where Windows reports installed memory incorrectly by subtracting reserved memory from it’s value (it should only do that with “available memory” but it does it with both). There is no known fix for that, at least I didn’t find one.

It is very much posiible that it throws Zwift hardware detection off and causes described issue with poor graphics. The only hope is Zwift fixing/improving their memory detection algorithm.

image

More reports of this problem here. Seems like it’s more likely to be when RAM isn’t divisible by 4 rather than 8 based on some of the documentation about OpenGL textures. As though when the system RAM isn’t recognised by Zwift, it is not used to pack/unpack the full-sized or correct quality textures. But I’m getting way out of my depth now, haha.

2 Likes

There will be even more such reports because Ryzen systems popularity is exploding. I really hope someone at Zwift know about this… This really has to be fixed. It is obviously Zwift specific issue.

By the way I wish we could just set graphics settings manually so problems like this, or one with wrong graphics profile assigned to newer GPUs, could be avoided.

1 Like

There is plenty of info on sites about AMD GPUs not being as good as NVIDIA for Zwift. It has to due with AMD not being as good at handling OpenGL which Zwift runs on. You can get more info at www.zwiftalizer.com and:

“ * Note: AMD graphics cards don’t perform as well in Zwift, so they should generally be avoided.”

This problem is nothing to do with that. The OP has an Nvidia graphics card, as have almost all the others. The issue is on the AMD Ryzen CPU platform, but doesn’t affect them all.

@Dave_ZPCMR correct, my bad…brain must be fried today saw Ryzen listed (processor) and brain went to GPU.

1 Like

No worries, it’s certainly an odd one. As mentioned I know of others on Ryzen/Nvidia that don’t have this issue at all (I’m one of them). The weird system RAM thing is the only common denominator I can find. Everyone with this low quality textures problem appears to have an uneven multiple of megabytes and Zwiftalizer analysis shows a blank where it should be listed.

This is true to some extent. Even with unpotimized OpenGL drivers old and lower tier AMD GPUs are still good enough to run Zwift at High or Ultra. This is different issue though. Some high end systems get lowest possible texture (and probably model) quality assigned by Zwift engine. It looks worse than on integrated Intel graphics… And that should say something.

1 Like

MY DxDiag.txt

System Information

  Time of this report: 4/15/2020, 18:10:04
         Machine name: DESKTOP-5ADKTJV
           Machine Id: {51C2C03C-CD59-4F05-B920-F5B8682B46B0}
     Operating System: Windows 10 Professionnel 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)
             Language: French (Regional Setting: French)
  System Manufacturer: Gigabyte Technology Co., Ltd.
         System Model: B450 AORUS ELITE
                 BIOS: F42c (type: UEFI)
            Processor: AMD Ryzen 5 2600 Six-Core Processor             (12 CPUs), ~3.4GHz
               Memory: 16336MB RAM
  Available OS Memory: 16336MB RAM
            Page File: 2183MB used, 16583MB available
          Windows Dir: C:\Windows
      DirectX Version: DirectX 12
  DX Setup Parameters: Not found
     User DPI Setting: 96 DPI (100 percent)
   System DPI Setting: 144 DPI (150 percent)
      DWM DPI Scaling: UnKnown
             Miracast: Available, with HDCP

Microsoft Graphics Hybrid: Not Supported
DirectX Database Version: Unknown
DxDiag Version: 10.00.18362.0387 64bit Unicode

1 Like

Yes, seems to be ram related bug… either way there’s nothing you do about it! Its zwift coding team that have to resolve this one.

Thanks, again an unusual RAM capacity (would normally be 16384MB). Can you just confirm a couple of other things please? One is a screenshot from analysis of a log file at zwiftalizer.com, and the other a screenshot of the memory page in Resource Monitor in Windows (type it in your start menu).

1 Like

Thanks! So Resource Monitor shows the right about of installed RAM this time but again Zwiftalizer confirms that Zwift is not recognising it at all. Surely it’s got to be to do with that.

This is from my Pentium Gold laptop with Basic profile on integrated graphics at 1080p, and the textures are noticeably clearer.


So lets check if I understand the problem correctly… If i remove one ob my 8GB ram my graphics will be much better? 16GB is not working while 8GB should?

good news this morning. I do not know if it was zwift which made a correction but my textures are now magnificent.

I updated the bios of my motherboard for the F51 version (Gigabyte B450 Aorus Elite) maybe the problem came from there?

Now from zwiftalyzer my memory appear.

2 Likes

Great news! I wonder if they fixed it in the latest update? BIOS update could make sense too though, if it means Zwift can now see the RAM correctly.

Edit: same game version on your two Zwiftalizer screenshots, so unless it’s a change at Zwift’s end it can’t be the update.