Updates and minimum requirements


(Harold Tamminen biciTO) #1

When we get those updates like the one last week, do they affect the minimum requirements to run the program? If yes, can one skip the update and still run the program. I have always just accepted the updates and never tried to skip them. I just had a issue of a computer working before the update and crashing after and being told that this computer’s graphics card does not meet the minimum requirements.


(Vincent W.) #2

Zwift does not change the minimum requirements of the application unless specifically specified after an update. This would be made very clear to the Zwifter community so I wouldn’t worry about that. In your case, it may be best to update your graphics card drivers. Did you see the “does not meet the minimum requirements”  message when you tried to install Zwift previously?  Zwift may work with graphics cards below the minimum requirements but there is no guarantee. 

Feel free to update us when you can!