UPDATE (4/26/2019): Some Trainers Are Lacking Resistance In ERG Mode

resistance
trainer
(Josie) #1

UPDATE #3: We have noticed some Zwifters have been experiencing similar issues after the update below. Please try the following:

  • Go to the iTunes store and update your device

  • Restart your IOS device

  • Disconnect all Bluetooth devices from zwift, reinstall (trainer) and calibrate again

This should get your ERG mode back up and running.

Please let us know if the issues persist, or any other issues arise.

UPDATE #2: We have released a fix on iOS and Apple TV. Please let us know if the issues persist, or any other issues arise.

UPDATE #1: We have released a fix on Mac platform. Please let us know if the issues persist, or any other issues arise.

Hey Zwifters,

We have identified an issue with the lack of resistance in ERG mode on some trainers via Bluetooth. Thank you for your patience while we investigate this issue. I will update this post as we receive new pertinent information.

[ZG - 5961]

15 Likes
Resistance issues after update
Hammer connectivity issues
ERG Mod stopped working
Resistance issues after update
Kickr feedback gone
Resistance - Elite
(Dan) #2

is this just for ERG mode? i just did a regular “free ride” and the resistance was really weird over grade changes. it was like there was a 20 second delay on all the grade changes.

i’m on a kickr snap 2017, latest firmware.

1 Like
(Josie) #3

Thanks for that info, Dan.

We’ve heard more reports of this in ERG mode, but this could be related. If you haven’t already, could you open a support inquiry and send us any logs? Thanks!

(J) #4

+1. No control in ERG mode in workouts since the new update.
Apple TV, kickr1. Can’t complete a spindown. All latest software.
Works fine in wahoo’s native spindown app. Works fine in Fulgaz.

Also tried in iOS app and Macbook. No joy there either. Macbook keeps saying “no signal” when searching for the kickr.
iOS app exibits the same ERG mode issues as Apple TV4K.

9 Likes
ANDROID: Wahoo KICKR owners - Sim and Erg working properly - no more Lag/Errors, on Android Beta
(Acacio Filho) #5

Same Here. Kickr 1 latest firmware version. Everything working fine at Wahoo Fitness app.
No Resistance on grade changes. ERG mode not working.
Already got in touch with support team. Waiting for a solution as it is a known issue.

2 Likes
(J) #6

Same problem - Hammer 1 - Apple TV. Everything updated, works fine in native app

(Dan) #7

opened a support ticket with logs! hope it helps!

(Emanuele) #8

Same problem with Élite Drivo. Ticket opened
Thanks

1 Like
(i) #9

Same issue. Hammer 1 / MacBook w ANT+ & BLT. Tried iPhone as well

emailed Zwift support and they said to update firmware.

Firmware is, and has been, up-to-date.

UPDATE: appears to be limited to Bluetooth - forced an ANT+ connection by turning off Bluetooth and it worked fine again

(Robert K.Oswald [DIRT]) #10

Same happened to me today! 2018 Kickr Core. MacOS.

(VIC) #11

Hi, problems with the resistance aswell, even in free ride.
My trainer is Elite Qubo Digital B+ paired with iPad 2017.
Hope it gets solved asap. Rainy and windy out there for the next days :frowning:

1 Like
(Jay) #12

I’m having the same issue in both ERG mode and during free rides. In free rides essentially every course becomes flat - no resistance during climbs. Only the BLE connection seems to fail. Using ANT+ there’s no problem, just have to give up cadence or HR data in that case. Using iMac desktop and Cycleops Magnus.

Ticket opened yesterday with Zwift support.

1 Like
(Ralph) #13

Greetings,

I am having the same issue with BLE/IOS with my CycleOps Magnus M2 since the update. Opened a ticket. Hoping for a quick fix. Thanks!

Regards,

3 Likes
(Nathan) #14

I have been having same issues since the desert flats update. I just done another hour ride. Same issues as everyone else. I tried have found using the bluetooth from the companion app gives better results. Was failing before the 40 minute mark but at 40 minutes the spindown worked.

Long as I followed the numbers on the companion dashboard things were working as normal for last 25 minutes. laptop screen was so far behind.

I have opened support ticket and sent logs. sending logs again from this ride to show the difference.

1 Like
(Byron) #15

Same issue here

Apple TV
kickr gen 1

No spindown
No resistance change

2 Likes
(Nathan) #16

I have an ant+ dongle I might give that a go.

(Hope) #17

Count me in on this bug as well; I wasn’t in ERG mode but rather was doing a free ride on the Greatest London Flat this morning when I realized my trainer’s resistance wasn’t changing at all to reflect the posted elevation. I’m on a CycleOps Hammer, latest firmware; tried to recalibrate and it failed in Zwift but succeeded in Rouvy.

I also filed a ticket, but figured I’d add my voice to the chorus here too. :wink:

3 Likes
(Pak) #18

Same problem: ERG mode doesn’t work in workout mode and no up-slope/down-hill resistance in free ride; spin down could not complete and stuck at 2 mph every trial. Using app on iPad and Cycleops Hammer with everything up-to-date. Everything was working fine before updating the Zwift app on Friday.

2 Likes
(Alan) #19

Mine too ! Latest update on Apple TV renders the app unusable.

Calibration is way off.

And won’t complete a calibration.

Yet when the same setup is connected to an iPad without the update. It works and calibrates fine.

I’m just stuck on a tiny screen rather than my two dedicated 40" screens :man_facepalming:t3:

Sort of out Zwift !:rage:

(Andy) #20

Also with cyclops hammer no resistance in free ride.