UPDATE (1/28/2019) Run avatars stopping and starting during their run

error

(Josie) #1

Hey Zwifters,

Update #1: We’ve released an update on all platforms that should improve your running experience. If you’re still experiencing dropouts, please let us know!

There have been several reports of running avatars stopping and starting during a run, as well as having trouble finishing run calibration. This appears as a dropout on Zwift, where the speed goes to 0 then jumps back up quickly to actual speed.

Please make sure that you’ve checked for any bluetooth interference issues, and that your battery on your device is full.

If you are experiencing this issue, please open a support inquiry stating the problem, what devices and platform you are using, a .fit file of the run activity, and any details that may help us reproduce the problem in our labs.

This post will be updated as new information is received. Thank you for your patience!

[ZG-5050]


Zwift pod works when running fast, but avatar constantly stopping when jogging/walking
(Andy) #2

Same problem here. Just Bought two of the run pods from Zwift and the avatar is constantly stopping. Not making for a very enjoyable run. Also my first 11km run was not recorded. Frustrated!


(Josie) #3

Hi Andy -

We just released an update across all platforms in the past week. We’ve improved the experience, so you might want to see how it goes now. If you’re still finding issues, please let us know!


(Peggy) #4

I updated and retried the run calibration on AppleTV 4K yesterday, but it doesn’t work at all for me. The Zwift run pod pairs okay, but when I try to adjust the calibration speed the AppleTV home screen appears, so I guess the app is crashing. When I go directly to run a course, the runner doesn’t ever start and the speed reads 0mph. I’ve tried changing the run pod battery, even though the Milestone app says the battery is fine, but no difference. If I switch to Zwift on a Mac laptop (Mojave), no problems running using the Zwift foot pod. And the Milestone app syncs with the Zwift run pod without problem.


(Andy) #5

Tried it today and yesterday and it was perfect


(Ted) #6

I am having the same issue with calibration. I can calibrate if I use the default speed but the app crashes when I try to change the speed. Otherwise it is working fine.


(Peggy) #7

Ran in Watopia using the laptop yesterday and it worked. Tried today with two different 4k AppleTVs AND the Mac laptop and ALL of them behaved the same: footpad and HRM pair but Zwift only reads 0mph. Everything up to date, tried rebooting etc. Wasted an hour trying to get it to work (it worked on the laptop yesterday!). Finally just ran without Zwift and downloaded the run to the Milestone app.


(Peggy) #8

Also, I just tried Zwift Run using my Garmin foot pod and ANT+ stick using the laptop and the avatar started running. I didn’t run very far, just wanted to see if it would work. No way to use the ANT+ stick with AppleTV though. And when I was using the Garmin foot pod in December, I noticed the cadence would randomly get doubled, doubling my pace as well, which is why I started using the Zwift/Milestone foot pod. I saw the cadence bug reported here on the forums.


(Keith) #9

I had this problem today. The avatar stopped after about 10 minutes. I’ve tried using the pod on 4 occasions, of those, it worked without problems on 1 occasion .


(Josie) #10

Thanks for your report @PeggyH. We will be releasing a patch addressing the crashes that are related to what you are experiencing. @Ted_Heaverin - were you also on Apple TV?


(Josie) #11

Hi @Keith_Leng - what platform and device were you using to run on Zwift?


(Keith) #12

Hi @Josie.L I was using a Galaxy Tab S2. I’ve also had similar issues with a Galaxy S8. The pod was a Zwift Pod.


(Michael) #13

I’ve been having this problem for over a month. Zwift on my Asus Android tablet with Milestone pod was working great until the start of December, then it went south. Firmware on the pod is current, battery is full, pairs with the tablet though it takes a long time, then the spm count goes to 0 and then nothing at all. My only run in weeks with all the pieces working was yesterday for 2.18 miles, then it stopped and I gave up troubleshoot. Am thinking about Stryd now, since I see no real progress here.


(Josie) #14

@Keith_Leng - thank you for your report. We will be looking into this.

@Michael_Aguilar - is your avatar stopping at all, or is it the spm/cadence that shows no value - but still moving?


(Michael) #15

Yes, my Avatar stops moving if by chance I get the app to start or it stands still stretching and shaking at the start of a workout

Mike Aguilar


(Josie) #16

@Michael_Aguilar @Keith_Leng - there was an update pushed yesterday for Zwift on Android. Try updating and see if the issues persist. Thanks so much for your help.


(KolzManz) #17

Hi @Josie.L,

Updated to the latest iOS Zwift version - was working fine after that for a few runs (will NO dropouts and calibration works fine). Tried running today (with a new training plan) and Avatar just doesn’t respond or move. Just stretching, etc. and spm/cadence shoes no value - this is on the New York map.

Nothing has changed in my environment for the past few days and definitely no Zwift updates on iOS.

Thanks - Daryl


(KolzManz) #18

No response for the past few days from Zwift.

Extremely frustrating - thought of having a run with Zwift. Again, avatar not moving at all. Tried both iPhone and iPad with the latest app version.

Also tried uninstalling on both devices, changed footpod battery - nothing worked.

What’s going on?


(KolzManz) #19

UPDATE: I took out the battery from the Milestone Pod and put it back in again and avatar started responding. Go figure.


(Josie) #20

Hi there, I’m sorry for the delay in response on my part. Please let us know if that issue arises again for you. If this is something that occurs constantly for you, please open a support inquiry and we can investigate further.