Unexpected Resistance Issues with Trainer [January 2024]

For those on the Tacx Flux S - the following steps should be performed using the Tacx Training™ App that is available from Garmin on Apple App Store and Google Play Store

  • Follow the in-app instructions to perform a trainer calibration.
  • Once your trainer is calibrated, start a Power based workout.
  • Set a watt target of 150 watts or as close to it as you are comfortable reaching.
  • Pedal to reach the target watts and observe if you are seeing stable watt output at the 150 watt target.

Then:

  • Lower the watt target to 90 watts.

  • Continue pedaling and observe if you are seeing watts lower and stabilize at the 90 watt target.

After you completed this test, please let us know what you were able to observe with regards to reaching the higher and lower watt targets.

Did the proposed test today

  • calibration with Tacx Training App
  • start a training with power target 150 watt: worked nice and steady holding the 150 watt
  • kept my pedalling frequence constant at 80-90 rpm and reduced the power target to 90 watt
  • watt reduced, but did not reach the 90 watts. Therefore I shifted into the lightest gear, keeping the 80-90 rpm. In this gear the 90 watts were reached an controlled nice and steady.

After this test I disconnected my Tacx Flux from the Tacx App and started a structured Zwift Training: the ERG mode didn’t work at all. It caused fluctuations of the watts between 70 and 200 watts within a seconds. Even within one pedal stroke the resistance changed significantly.

What worked with my setup is, to do the calibration with the Tacx App, and then directly start the Zwift structured workout.

Hope this helps to find a solution.

Regards
Georg

Tacx Flux
PC with Zwift version 1.57.3
Bluetooth

1 Like

@Georg_Wheelie Thank you very much for sharing your results! Just to confirm, after you did the calibration with the Tacx app, then went to the Zwift structured workout, did the workout work as expected?

Right. The structured workout worked as expected with the ERG mode keeping smooth and steady the targeted watts after calibration with the Taxc App and then going directly into the Zwift structured workout.

Ok this issue started yesterday before I updated and continued after I updated.
Choppy resistance in freeride on my own, with a group and pace partner.
Wahoo Kickr V5 checked all ok
Apple TV rebooted and updated
Any possible interference moved

Issue continued this morning
Created new test account and resistance was fine
Switching between accounts original was randomly choppy and new one 100% fine. All account settings the same so issue can’t be at my end.

I’m hoping this may be a server issue and not related to an email from Ethan regarding use of Innuendo I also received yesterday.

Dear Georg, Dear Zwift Support,

im here because i got the same problem with my zwift and tucx flux s set up. the fluctuations of the the watts within a workout are annoying. you can even see the constantly changing watts after in the workout log on zwift companion app (see my screenshot below). I constatly have to shift my gears because the resistance changes even if the pedal stroke AND the pitch (for exampe 9% up) did not change at all.

I will try the Tacx App calibration, then straight into zwift app and start a tour.

setup:
Tacx Flux S
Android Smartphone and Tablet - Zwift App version same on both devices, 1.57.3 (125438)
Bluetooth

Same thing here with my Zwift Hub. I have reported it to customer service. It started acting up last week. The resistance would go up on downhill and reduce on uphill. Today it cut out during my ride in the New York world. It’s very hot to touch, hotter than usual.

Having issues also. Started ride January 24. Watts/w/kg/mph all off. Eventually my avatar comes to a stop while I’m still pedaling, 0watts. I did all the trouble shooting in Zwift, they told me it was my Snap trainer. I contacted Wahoo. They sent me a new(?) hub for my Snap. After installing and doing a Wahoo spindown, still same issues with Zwift. I enter a pacer ride and can’t keep up even with lowest pacer, eventually my avatar just stops. It’s been 15 days since this issue started for me. Both Zwift and Wahoo have replied to request for problem solving with negative results. Wahoo did send the new hub but still same results.

Video might be useful to help work out what’s happening …

I followed Georg’s method with tacx calibration, closing tacx app, open zwift and start the ride. it felt “better”, i could not notice the extrem resistance/watt fluctuations (10-30w) within seconds.
Even tho the watt tracking does not look very “smooth”, but i guess better than the last screenshot 2 days ago:

Hi @Jeri_Mc_OWL_67 , welcome to the forums! Could you confirm whether your Snap is stably reporting wattage in the Wahoo app for a similar amount of time? Wattage dropping to 0 like this (without disconnecting) is usually a hardware issue. If this is only occurring in Zwift, we’d be happy to troubleshoot this via Support, but if it’s occurring in both Wahoo and Zwift, there would be no way to address the issue just from the Zwift side.

Hi! Thanks for responding.We did narrow it down to hardware issue, just today! We took the trainer to local shop for testing. Results were I needed a cadence sensor. Wahoo had sent me a new assembly for my Snap already and when things were the same we were trying to figure out if it was hardware or software. Turns out hardware was the culprit. The new cadence sensor did the trick and I’m back in Zwift world!

I want to say that Zwift has been very communicative through out my issue which lasted about 2 weeks!

I’ll post on Forum so it closes my question/comment.
Thanks again!

Jeri McDonogh

And.what does the cadence sensor got to do with your problem?

I’m not sure. I just know that after I took my Snap to the bike shop they told me to try a cadence sensor. I installed it and starting riding and everything worked.

That’s pretty weird because cadence does not affect power in Zwift. You don’t even need cadence to ride.

I use a 3G Cardio recumbent exercise bike. Since starting Zwift several months back the watt limit was 562. I noticed in the last few rides that the limit is now as low as 500. Were there any changes or updates in the program that might have affected max wattage within Zwift?

As I stated before the problem ended up not being with Zwift but with my Snap trainer. The sensor resolved the issue and that’s what is important to me.

A cadence Sensor can not fix a defective trainer.

2 Likes

UPDATE February 13

Hey everyone - thanks for flagging your issues on this thread and working with us to help address some of the unexpected issues in game version 1.57.0. We are releasing game version 1.58.0 this week which should address this issue.

The 1.58 phased rollout will be available to to all OS platforms by Thursday / Friday depending on your local time zone.

For those using Tacs FLUX series trainers in particular - please read Evan’s post on the 1.58 release notes thread.

Since January (TOZ) I’ve experienced a few resistance issues with my Tacx Neo trainer.

Firstly the resistance shifts from the course profile, seems like there’s a lag of say 30 seconds from the course profile I’m riding (so the resistance doesn’t match the road profile), then after a few minutes of this happening the resistance goes light before the BT disconnect all together. When I go to Pair in the Menu it appears everything it connected, then I go back to the ride screen and it’s still disconnected. I can do this a few times, sometimes it works (the resistance is still out) but the majority of the time it doesn’t.

Initial I thought it was an issue when I hit a power up icon, but this wasn’t the case as it would just disconnect at random times, 10 mins, 20 mins or even 50 mins into a ride!

I’m now forced to connect my Neo BT via my iPhone and not my usual Macbook, which isn’t a real issue as I’ve had no connection issue so far, just annoying that there’s an issue that I can’t work out.

Hopefully it’s not an issue with my Tacx Neo (1st Gen) which runs as smooth as butter and just a technical issue with the BT connection with Zwift and the MacOS platform, which I’m native to.