Unable to download a ride - and it didn't auto-upload [July 2021]

Same issue again tonight for me - did a warm up then selected join race using pop up button but the only data transferred to strava is my warm up & not the race info. In the past 2 separate rides would be recorded - please get this resolved & maybe you ought to offer a free months membership for all users as these issues aren’t good enough

1 Like

Same issue for me…bunch ride with Coco wouldn’t upload to Strava. It’s on Companion App but nor Strava or Garmin Connect. Using Apple 4K TV

Warm up loaded- 2 races failed! Another load of stats gone forever! ATV user.

Zwift is suggesting the workaround of force-closing the app every time and I think this may be what saved me–I also use Fulgaz so I force-close each app from Apple TV after every session to avoid any Bluetooth fights when I start up again. I seem to be one of the few that had an event successfully save (Roval Alpe climb as above, after the screen froze, and after killing the app–but keeping Companion running–logging back in, and finally saving from my stop point).

1 Like

Same problem with me. First event post update. Big PB up Alpe du Zwift gone. Not on Strava, didn’t happen :frowning: Weirdly the power, time and distance data (as well as alpe du Zwift segment time) all show up on Zwift power so I know I didn’t dream this magical ride up the Alpe but it doesn’t seem like they have a Fit file available for download that works. Tried to repair the fit file I could download from Zwift power but didn’t work.

Has anyone got any more help from Zwift other than: sorry you’re out of luck but here is a “fix” (shut down app) for next time? I don’t see anything more helpful but might have missed it.

Sorry- Apple TV too.

1 Like

So here is the bit I don’t get: there is known problem - acknowledged by Zwift… there is a workaround - described on this forum by Zwift… but people only arrive at this forum once they have lost a ride and are looking for a way to recover it (which there doesn’t seem to be at the moment). WHY then are Zwift not displaying the workaround solution to everyone as a note in the companion app BEFORE people lose a ride (in many cases an important one because of the nature of the events that are on at the moment such as climbing races) and need look on the forums for the problem retrospectively? Be upfront and save us the heartache of lost PBs and kms

12 Likes

It’s an known issue with Zwift. Third arty apps and with Zwift not showing the correct maps

Hi @shooj,

What about for PC? You have a workaround for Apple TV etc, but what do PC users do?

So far it seems limited to events only…or it is just a random glitch. Have lost group rides but not individual rides (so far).

hi.

USING IPAD PRO

since the latest update i have 2 issues.

  1. i used to be able to have my pedals (assioma) as the power source and the trainer (kicker gen 1) as the controlable. now i can’t locate the trainer when i when i have set the pedals as the power source.

  2. none of my races are uploading to either companion app or strava. they are recorded on ZP. i have checked the connection and i am not logged in under any other device.

things were working fine prior to the update

Very frustrating. Today my warmup ride saved to strava. The next two group rides did not. They all show on my Zwift Dashboard but do not appear on Zwift Power at all. Plus when I check the rides on the dashboard the data is completely inaccurate - shows in miles/feet not metric, power & HR recorded only for a few seconds…

1 Like

Confirming this issue has happened to me since the last update. My work outs cannot be accessed via Zwift .com, show funny on the companion app, and won’t sync to Strava.

Happened after the update on an Apple TV.

Hi I am using Galaxy Tab S6 which is Android device and facing similar issues commented in many other riders. I would like to fix this issue as soon as possible. This is very frustrating

Totally agree.

There is no solution of repairing lost rides.

But there is a WORKING SOLUTION for all future rides (please read post 85 here from zwift).

BTH. There should be Zwift public announcement. We should give it a catchy phrase…

“Swipe up and close the app, or it will never happen on Strava”

:wink:

I hope when this is fixed things integrate that haven’t :smirk:

Same issue. I did the Yumezi Badge Hunt ride yesterday. Companion shows the ride in the activity feed with the usual header info (km, ride time, elevation, calories), but once I go into the activity there’s no map or any of the other ride data screens (cadence, heart rate, power). I can’t see who I rode with or who gave ride-ons. The ride did not transfer to Strava.

Using Apple 4K TV.

I can also see the ride in my Zwiftcom feed, but if I click on it I get a blank screen, so cannot get to the .fit file.

1 Like

Geoff, is there something I can do with the. Fit file. I have exactly the same scenario

I had the same problem this morning.
This is on an Android tablet (Samsung Tab S6 Lite) with the latest update

I had a planned meet-up for a workout ride.
Did a short warm-up & when the ‘meet-up’ button appeared I chose ‘not yet’ as I was still warming up.
I then didn’t get the ‘join meet-up’ button again - it kept flickering & disappearing, but would not stay on the screen long enough to actually select it.

I had to ‘end ride’ back to the initial Zwift screen with my username across the centre & then go back into Zwift from there. This immediately gave me the meet-up button when I started riding.

When I completed the meet-up, I exited as normal.

The warm-up ride has uploaded correctly, but the workout has not.
The stats on the screen in the Zwift activity match the screenshot I took at the end of the ride from the ‘timeline’ screen’ (i.e., distance, time & calories) but the power/hr graphs etc. are just 3 short straight lines and the upload to Strava shows a 3s ride. The fit file on Zwift is <1kb, so hasn’t recorded the data correctly.

Reading through this thread, it sounds like it would have worked if I had killed the app between the warm-up & the workout. I hope a fix comes soon.

I have occasionally had an upload not happen before, but downloading the fit file from Zwift and then uploading manually to Strava has sorted it. This time, Strava (as it is designed to do) rejected the upload because the ID of the upload was the same as the ID of the immediately preceding warmup ride I had done from which I had transferred to the group ride. The group ride numeric details and description were right on Zwift website, but it’s map didn’t present and wasn’t right on Companion either. I will try putting the fit file through gotoes website which I sometimes use to merge rides (but it works for one or multiple rides) and it randomises the ID (which it has to do for multiple merges, otherwise it would use one of the ride IDs and that ID might already be on Strava for the individual ride)