Unable to download a ride - and it didn't auto-upload [July 2021] [SOLVED]

Ugh. I figured as much. No worries, this will just have to be my motivation for riding up Ventop again :slight_smile:

Thanks again for getting the patch out!

@shooj They were uploaded to the Zwift servers, and, at least for me, even showed up on Zwift Power complete with power and HR breakdowns. They show in the activity lists both in the companion app and the my.zwift.com activity feed, showing distance, ride time, elevation, and calories burned in the feed. But when you go into the activity itself in the companion app, you get “Activity details could not be loaded” showing all that basic info, but no photos, route info, or power/hr graphs. On the website, you get basically a blank page (header and footer only). Fit files downloaded from the website are broken, tho, as far as Strava is concerned.

So something is getting uploaded, it’s just broken. I guess the question is whether whatever is broken in them is fixable.


My race ride managed to upload correctly to zwift power, however it used the warm up details on the companion app. I’ve checked zwift power again a few mins ago and it’s now changed the statistics to the warm up ride ie wrong power /hr details etc. Very very disappointing, appreciate tech things go wrong but losing rides is really frustrating especially if you’ve done an effort

1 Like

My ride uploaded ok. Had to manually update ATV to new version beforehand. Did not warm up but went straight to event

Just need to fix the historical rides.

This happened to me last night. Fine to now update the version, but how do I u[pload last night’s ride when the FIT file seems to be empty (1kb), yet the Zwift ride history definitely shows I did the ride and the time - so the information must be stored somewhere, how do I access it and get it into Strava?


I have the same exact situation. I did a really hard race and I see the activity and details, but when I click on the activity to obtain the FIT file, that page is blank. It’s exactly like Trey is saying. Does Zwift have a fix? All of the ride information is there!

I’m not too sure what procedure you did not making it work @Kevin_Bishop

I have just done a double race back to back Aussie Crit Crusher 1 and 2. Everything uploaded

And thats what I did.

Warm up with Brevet and 10 min before crit 1 start. Save the warm up and press save after taking the data from the captured photo :joy:. Go on log on screen. Force quit (double click screen button on ATV remote) and flip the app up.

I also wait for 10 second and check something on the other app.

Then I join Zwift. Select any world. Join the event straight away. RACE … got :1st_place_medal::sweat_smile:. Then soft pedal for a 30 seconds. Quit and save photos. Got on log on screen. For quit.

I was checking the Olympic TT result for a minute.

Then I log on for race 2. This time I try to pedal 20 seconds before joining the Crit race 2 in NYC. RACE … got :1st_place_medal::grin: again. Pedal for 30 seconds to cool down. Save.

Everything on Zwift screen and on Strava :+1:t3:

Edit just saw the update from @shooj

Now I update the app.

1 Like

Just in case anyone misses the update in the original post at the top - Zwift claim that this is fixed as of this morning’s release. Not tested it yet myself but fingers crossed…

1 Like

Updates appeared for both apps today for me. Seems to be working now however issue of yesterday’s fit file still in progress and using data from the previous ride doesn’t look like it’s going to be fixable.

1 Like

The update worked for me

1 Like

This release did not fix the problem for me. My ATV shows 1.15.1, but my ride yesterday showed the problem. Rode with pace partner, ended the ride but did not force quit, joined the AHDR ride. The pace partner data showed up, but the AHDR ride data did not.

Hi @Johnny_Drama
I checked your ride yesterday on Innsbruck, and you were still on version 1.15.0 (1.0.75178).

For you and others on iOS / AppleTV devices - visit the App Store from that iPad / ATV and look for the “Update” button. If your device is set to not auto-update, you’ll have to manually update in this way.


Thanks for checking into this for me @shooj

When I checked this morning (before posting initially) the version was at 1.15.1. It’s possible that it auto updated after my ride but before I looked this morning.

So unfortunately I got another ride in that has not uploaded properly, afterwards I noticed my Zwift app on ATV did update.

I guess the million dollar question is can the broken files be fixed so I can upload to Strava?

Hi @shooj
I’ve updated to Version 1.15.1 on my Apple TV, exited and restarted my Zwift app tonight, did a Miracle ride. It shows up on my Zwift companion (as it always has) but did not upload to Strava.

The update works for me

but the million dollar question that no answer has been provided for (as far as I can see) is, are our rides that did not uploaded to strava lost? or is zwift working on a solution? Yes the update resolved the main issue, but is a solution coming for the problem it created prior to this?

If you go back and read previous posts this has been answered already. There is no way to recover previous rides.

I have not read all 398 posts, sorry! Hence “as fas as I can see” :). However, is the answer you cite provided by a zwift user or a zwift insider? which are two completely different things. Are zwift officially saying “we are sorry for the error, it is now updated (fixed/resolved) but rides completed during the error are lost and no solution will be provided for this”?

though they must be able to provide some data as otherwise zwiftpower (I see power and HR there), as well as the zwift website (where I see, speed, distance and climbing) would not show anything either. In the least they can provide distance, speed and climbing (which cannot be added manually)?