Unable to download a ride - and it didn't auto-upload [July 2021] [SOLVED]

Same issue for me too. Is there a way to go straight to the start pen as a temporary workaround? Whenever I do a race it now records the 3 seconds in the world prior to hitting join race…

Dan, Exactly the same happened to my last group ride. My nether regions told me that it was a lot longer than 3 seconds. Second time this has happened. If we are posting to the forum, how many thousands have lost the will to live with this issue. It is absolutely shocking. Rant over!

1 Like

My VenTop Specialized Roval Climbing Challenge was unable to load today too

Raced a Crit race 1 of 2 last week and file was malformed. All saved in Zwift, zwiftpower etc but not today’s plan or strata. I did more events Friday and a free ride Sunday without issues. Then I just put in my best performance in a long time as a B in TFC mad Monday race and again it is malformed and didn’t upload to third party apps. Pretty infuriating at this stage.

Just happened to me for the first time. Everything downloaded EXCEPT the map and route tracing. It also didn’t upload to Strava as a result. What’s the latest on this issue??

1 Like

@shooj fitfiletools not working for either file. Thanks for giving this attention but it is annoying. Your help is appreciated.

More info on this bug is on the Zwift Insider site.

1 Like

WHY IS EVERYONE JUST ACCEPTING THIS TECHNICAL ISUE AND THE DISRUPTION IT IS CAUSING LIKE SHEEP TO THE SLAUGHTER?!!! We are paying for a service that is not working!! Contact Accounts and ask for a refund!!! This is not acceptable! :confounded:


So my perspective is that if you join an event from the world you start in, it works fine. If you join an event from a different world, doesn’t work. There is no work around as the fit file is empty and cannot be uncorrupted. Extremely annoying Zwift, please get fix out ASAP!


Same here as well. Started in one world and then joined event in another world after 5 mins. Agree with Matt_Young2.

Same issue. Apple TV 4K. No events saved upon completion since the “upgrade”. Not happy.

1 Like

Thanks for the suggestion, but force closing my ios device (ipad pro) did not terminate the previous session. It still shows an inProgressActivity.fit file. Since the last update, Zwift data has not recorded properly. I get basic stats like time, distance elevation, but everything else is blown.

Can anyone else confirm Matt Young’s suggestion? Would be a good temporary fix

Yep. Races affected. Solo rides aren’t. It’s an iOS issue too, not just Apple TV

1 Like

no, this did not work for me. I did a group workout though… started in Watopia (did my warmup), then it took me to London for the workout itself and dang, same issue as everyone else… inprogress.fit, corrupted file content, etc etc…I’m on appletv

Not tried but I’ll give it a go. Hoping this strava sync bug is not like the weight sync bug that is still outstanding after 14 months which was simailrly caused by a zwift update.

Come on zwift gives us an update not 4 days of silence is pretty bad PR. Eta for fix or rollback the update would be best given how much this is impacting zwifters.

@Sandy_Thomson Sorry to hear it’s still not working for you. Due to this ongoing issues still not fixed, the temporary work around for me is no free ride but I join an event when prompted “Join Event” or “Let’s Go” on my screen. Only then I start spinning of which I’m in the start pen by then.

I understand this is frustratingly troublesome too for racers when they need to do their warm-ups but now have to save their warm up ride first, save, close properly and then re-log in again :disappointed:

I hope they fix these issues soon and other ones too since the game patch update they released last week.


Just want to add my experience successfully using the workaround. Running Zwift on iPad, event was the Specialized C ride (shortened Mountain 8 route). Pertinent details:

  • Made sure that the Zwift app was completely off/quit (it already was)
  • To be safe, also swiped up to quit the Companion app on my phone
  • Launched a free ride in Watopia (just to be safe, I selected Mountain 8)
  • Didn’t pedal at all before clicking the “join event” button after the free ride started - I made sure that the timer still read 0:00
  • Only once I was in the starting pen did I launch the Companion app on my phone
  • Completed the event + about 10 minutes of cooldown within that same session
  • Session uploaded to Strava successfully

To be clear, I did not do any sort of free ride warm-up before the event (I just warmed up in the starting pen - joined about 10 minutes before the event start).

It’s insane that this major bug has sat unresolved for a week!!


I wonder if was Zwift’s payment system that was broken it would take them this long to fix it?


Same problem here with the 2nd gen Apple TV. I thought the cause was the beta tvO/S until I found this thread.
Ride uploaded after 20 mins of trying, not sure what made the difference :no_mouth: