Training plan "freeride" segment -- stuck in ERG mode


(Dan Dube) #1

did two different training plan workouts the past two nights that had “freeride” segments.

in the middle of the ride: ERG worked fine - segment 1 at 200w. segment 2 freeride kicked in, the trainer was still stuck at 200w. segment 3 was ERG at 210w, and then segment 4 was freeride again, but with variable resistance/power.

it seemed random which freeride segments were “stuck” and which were variable. it was particularly painful to do a 300w segment followed by a freeride that got stuck – that was supposed to be a less intense segment!

i tried to change ERG mode manually in the menu in-game, and it made no difference (turned it off, then on, then off, etc).

my kickr snap firmware is up to date (as far as i can tell), and so is zwift. i’m on a mac.

training rides without any freeride work fine.


(David K) #2

I think we’re going to need to research through your log files a bit to see how your Kickr is communicating with Zwift during your rides. I’m wondering if it’s somehow just missing the cues for new segments, but without logs, I couldn’t tell for certain.

I should have an email out to you within the next 10 minutes. Please check your inbox for us!


(A Oosthuizen (C)) #3

Dan, I’ve been stuck in ERG mode for months now since I completed a workout in ERG mode. Now no matter what ride/race/plan I do, it is ERG. I’ve made my peace with it.


(Vincent W.) #4

 Wow, sorry ERG isn’t working properly for you! You’re in ERG mode even out of workouts? If you haven’t already done so try sending in a support ticket so they can check out your logs and get to the bottom of this.