Training Peaks Workouts not showing in Zwift


(Jeroen Titanicman KISS (B)) #1

Hi team,

Since this week, Training Peaks workouts do not show up under My Workouts any longer. Automatic upload of completed workouts to TPeaks works well as before

 

Thanks, Titanicman


(Tom Hodgson) #2

I also noticed tonight that they weren’t showing either.


(Michael Infantolino TOMBC) #3

any update on this? It just stopped showing on my apple tv 4k

 


(Danielle ODell) #4

Exact same prob for me today. Workouts suddenly not there. Nor is training peaks available as drop down menu under workouts. However, Upload post ride to training peaks was fine. A most frustrating problem. I see several threads on this forum on this issue but no resolutions posted…?


(Michael Infantolino TOMBC) #5

I ended up finding a Zwift works most closely resembling what I had on my Training Peaks calendar for today but still annoying. I’d like to continue with the Training Peaks as I have been all along. I just did a ride yesterday from TP with no issue on ATV, No matter what I tried today I could not get it to work. But the ride uploaded without issue to TP.

 

going out on a limb here, any chance this has anything to do with Day Light Savings time adjustments?? Or just a coincidence??


(Jeroen Titanicman KISS (B)) #6

Hi All,
As per another thread, I redid the set up of my TP account in Zwift, ever since it works again.


(Danielle ODell) #7

^^tried that, multiple times, no dice.


(Michael Infantolino TOMBC) #8

Danielle, I had the issue yesterday as noted. Today I have a workout on my TP calendar. It is actually under workouts today with Zwift. Did you try again today?


(Danielle ODell) #9

Ugh. yes, today seems to be back to normal, thanks! Just wish I knew why that happened and what I could have done to get around it - yesterday was a long, complicated, critical workout - day just got a little derailed because of this issue. First world problems, I know…

I did try exporting the workout from TP and saving to Zwift workout folder in documents - I could get it to appear in zwift on my computer but unfortunately, my computer does not communicate with my kickr, and the workout was not showing up on my phone or ipad…so, I had to make do without yesterday. Oh well! 
Thanks so much for the help!


(Michael Infantolino TOMBC) #10

Glad it worked for
You as well. It seems to be a isolated glitch. Hopefully. I too had a big workout planned which was a bit derailed. Only after the fact I figured out a workaround. I too have a kickr. You can add a workout to the wahoo app if it’s connected to TP. Then use the app to run the workout.


(Gabi Zaffir) #11

its looks like there is  trainingpeaks workout “stuck” in my zwift account, always the same workout although in my trainingpeaks its change, what should i do ?

 

gabi zaffir


(Stuart King) #12

I am having issues from above - no training peaks workouts showing? so annoying please help! my accounts are synced and iv tried disconnecting and connecting again 


(Stuart King) #13

can you actually speak to someone from Zwift…submitted a ticket no end of times and takes forever.

 

taking the piss now 


(Jeroen Titanicman KISS (B)) #14

Hi Stuart, it may be you need patience till overnight if remembering well. Agree that recreating a TP workout in Zwift is fairly suboptimal…

GL, Titanicman


(Stuart King) #15

thanks Jeroen,

 

Its been a problem for over a week now?


(Mischa Irsch 140.6) #16

bump
SAME problem for me y’all. Worked for me last weekend - no dice today. Tried re-linking, restarting, everything…


(Danielle ODell) #17

It seems to be a random glitch - not sure if it’s on Zwift end or TP end. I did finally hear back from Zwift and they more or less shrugged their shoulders. There was no fix, just cross your fingers that it eventually returns to normal. I haven’t had a problem since my initial post above… it just randomly started working again one day… but there’s clearly an issue somewhere!


(Rosa Cilliers) #18

I have encountered this and with the help of my coach found a potential cause. It seems that if I have a TP workout without a title it doesn’t show up in Zwift. But the moment he adds a title it is there at my next log in. So check whether your workout has a title next time this glitch pops up. 


(Alan Berezin) #19

Mine was missing title and unavailable on zwift.  I named in in TP and restarted zwift OS X and still nothing.  Maybe some cache has to expire.  Ill report again if it works later.