Training peaks not showing up in workout selection

Training peaks work out have been loading perfectly in Zwift until today. Now TP does not even show up as a catergory in workouts. Checked the connection between TP and Zwift and deleted and loaded again Zwift app. Anyone else with same problem ?

I am experiencing the same issues here. Tried reconnecting, deleted the workout, put it back on my schedule, closed and opened the companion app… No idea as to why this is not working anymore.

It really annoys me.

1 Like

Is it a workout based on power? Then it should be selectable in your Zwift plans (if linked of course)
Is it a workout based on heartrate or ERP? Then you won’t see your workout in the plans as Zwift only can setup a workout based on power.

Cheers

1 Like

No, it is a workout based on power/watts. Used to work just fine.

Cheers

I am having the same issue. Power based workouts on my calendar in Training Peaks not showing (multiple days) or showing up days later than planned. Help???

2 Likes

Are you naming you activities? That sometimes causes issues.

Make sure the workouts are duration based versus distance.

Yes and yes…:worried:

Try disconnecting and connecting TrainingPeaks?

This just happened to me today for the first time ever. I’ve been using Zwift and TrainingPeaks for a while now with no issues and then all of the sudden my daily workout is not showing up in Zwift.
I tried re-connecting the TrainingPeaks connection to Zwift and that did not work.
The workout today in TrainingPeaks is just like all my other workouts in the past that have worked…there’s only one per day, they are time based, have a name, and have intervals.
I had to download the .zwo workout file from TrainingPeaks and then put it into the Zwift Workouts folder on my computer. Even then there was an issue where even that would not show up under my Custom Workouts in Zwift. So I deleted the Workouts folder, restarted Zwift, and then copied the file back. That time, Zwift created a new sub-folder under the Workouts folder and all my old workout files re-appeared but at least the new one for today that I copied into it finally appeared in Zwift.
Hope this works tomorrow or else I’m going to open a support ticket.

2 Likes

I started having this problem in November 2019. Now none of my coaches training peaks workout show up. I have build each one in zwift before I can do them. zwift support has bee ZERO help in this matter. Pretty poor customer service.

Have you been able to find a solution? I’m having the same issue, they connected a couple days ago, but now none…

I’ve just started a new training plan TP and am having this issue too. I did a TP from the same coach early 2019 and it worked perfectly. About to try disconnecting and reconnecting.

1 Like

Just started using TP and getting workouts from a coach… followed all directions on how to sync but the workouts aren’t showing up. Anyone still having this problem ?

havin the same issue. I have not been able to get it to work once yet. The automatic payment every month just works perfect though…

1 Like

You have to name your workout!

I was having the same issue since last week, so frustrating, so I had to do my trainingpeaks workout on FulGaz app. Then, when I finished, my workout loaded from FulGaz to TP and the activity was named by FulGaz based on the route I selected.
So when I came back to zwift I realized there was again the TP Costom Workouts Folder and the workout made on TP that I previously did on FulGaz app (It even appared with the name given by FulGaz) so I started to give all my TP workouts a name by the date and now they are showing up on zwift.

Well, at least this worked for me.

1 Like

Yes, same problem happened to me. It wasn’t until I gave my workout a specific name on TP did it show up on my Zwift workout page.

1 Like

what specific name ? :slight_smile:

@STEKAM_Sky it doesn’t matter what you name it, it just has to have a name in TrainingPeaks in order to sync to Zwift. You can label it by type (“Tempo”, “Interval”, etc.) or week/day (“W1D1”, etc). But without a name the import of TrainingPeaks workouts into Zwift won’t work.

Yep. What I meant is to title the workout*

@DKE_Watson not working in all case…