Trainer Resistance | Trainer Difficulty too low, Simulation and ERG mode do not work [January 2023]

I also have the Kickr V2 and just the same for me but on a Windows 10 PC with Ant+ dongle…no fun! :thinking: :smile:

1 Like

7 posts were split to a new topic: Resistance mode in races

Same problem here. I even read this forum post before updating Zwift and as expected the ERG mode no more worked. After exiting the workout, the gradient feel also didn’t work: rode up hilly KOM without any change in resistance.

  • MacOS, Ant+ dongle, Tacx Neo.

Opened up TrainerRoad app and did my workout over there: ERG mode worked flawlessly.

1 Like

I have the same issue with ERG not working with ANT+ FE-C after the update. Sim mode also did not work after the workout with ANT+. I have not tried Bluetooth with ERG mode, but SIM mode did seem to be working correctly with BT. Windows 10, Stages SB20.

1 Like

Reposting this as it might have been lost in my earlier reply from late last night. I did have success with ERG when I drove the connections through the Bluetooth on my phone via Companion App. Everything else failed. Something folks could try while this all gets sorted.

Erg mode broken
Drops counter broken

1 Like

Broken for me also after update…Kickr V2 Windows 10 with ANT+ dongle…No resistance change on rides through the Kickr???..fine before update!!!

1 Like

There’s a theme developing: things are broken if using ANT+ but seem to work over BLE. (EDIT - for some users - seems others have issues over both)

If you have the option, try switching to a BLE connection. (tangentially: an external, USB BLE dongle is often more reliable than internal BLE)

EDIT also to suggest the usual “nuke and pave” steps: completely uninstall Zwift from your system and delete any folders left behind. Unpair your trainers/sensors from any device you plan to run Zwift on, as well as any OTHER devices that might remember them. If AppleTV: do a factory reset of the ATV. It’ll grab your apps from iCloud once you set it up again.

You can see on Tempus Fugit that virtually no one is doing a workout… Surely it’s rollback time…


I dont think that is the case - i was using bluetooth and erg mode didn’t work. some people have said swapping from one to the other seems to get things working - i didn’t try this so not sure if it works for bluetooth to ant+

i disagree on the internal/dongle point - it can sometimes cause more confusion as you might need to disable the internal bluetooth to get it to work properly.

I’ve never had issues with either internal BT on laptops or dongle on PCs - never had to move it nearer the trainer either - across multiple devices, trainers and even houses!

1 Like

● [ERG] does not work.
●Slope is not reflected.
●Calibration fails.

Please fix it soon.


I just upgraded to v1.33 on PC running Win11. My trainer is a Wahoo Kickr gen 1. Up until now, everything has been running as advertised.

I do a workout ride nearly every day.

After the latest update, ERG mode isn’t working.


I also had this issue on a workout this morning. I havent changed anything in months and it has been flawless. Updated this morning and the ERG would not engage in a workout. I switched to a freeride in Watopia and it was adjusting resistance normally. It was only in workout mode that it wouldnt automatically adjust.

Checked trainer firmware and it is up to date. ERG works through Tacx app.

On a Tacx Neo with Win 10 (ant)

1 Like

Même problème de mon côté, on dirait que Zwift n’arrive plus à controller la résistance de mon hometrainer.
Problème survenu depuis la mise à jour effectuée aujourd’hui

1 Like

Downloaded the update on my PC yesterday and both my wife and I don’t have functional Workouts. The ERG mode doesn’t control the Wahoo core or Kickr trainers. Also noticed the drops in free ride seems to pause and doesn’t increase despite constant pedalling. Hope this is solved soon.

1 Like

Same issue, I had 90 minutes to get my workout in this morning but have lost my window after troubleshooting this issue with no success. Kickr Core, tried Ant+ and BLE, Windows. Never had any issues before now. ERG mode simply not working and power is all over the place.

The Zwift calibration fails every time, and feels very different - I need to push an extreme amount of watts to get to 23mph. I tried calibrating on my Wahoo Utility App, and it worked just fine and felt normal. But that did not fix my issues when going back to Zwift.


Updated this morning on Windows 10. Using a Neo 2 with ANT+FEC.

Sim mode and erg mode worked as expected for two subsequent rides.

It probably depends (partially) on ANT+. Change to BT.

@ZWIFT I expect that this problem will be fixed within a few days. Otherwise you should consider a refund program for your paying customers.

And stop deploying this buggy version ASAP.

How is it possible that such a broken software ever leaves the lab?