Trainer Resistance | Trainer Difficulty too low, Simulation and ERG mode do not work [January 2023]

It probably depends (partially) on ANT+. Change to BT.

@ZWIFT I expect that this problem will be fixed within a few days. Otherwise you should consider a refund program for your paying customers.

And stop deploying this buggy version ASAP.

How is it possible that such a broken software ever leaves the lab?


I work in software development and how this update managed to pass testing with a core functionality failing is mindboggling. This should have been one of the things to clear UAT…


Yeah well, UCI Pro is in what, two weeks?

How’s that going to work when half the pro’s trainer difficulty no longer works because Zwift broke their own platform.

1 Like

Shucks, that’s my setup too, so I’m not hopeful that mine is going to be working…

I’m on there. It looks like I’m doing a workout. No erg, though, so it’s a lie

My speed and wattage during a workout was all over the place. When I jumped into a normal Watopia solo ride, the trainer (ERG mode) simply didn’t care if I was going up hill or down hill - the speed and wattage just stayed the same. Usually when I’m climbing at 10+% on Zwift my cadence goes WAY down, that’s just my normal way of riding. Last night, my cadence was super high, about 90, and my avatar would adjust it’s speed up the hill as if ERG mode was not one. I’ve been on Zwift for 6-7 years now so I know what not having ERG mode feels / looks like in Zwift. Essentially, when I did my 16 mile ride with 1000 ft of climbing “test” last night - the resistance on my Kickr never changed 1 time, it was like riding on my Kurt Kinetic Liquid trainer from 10 years ago but on Zwift. This update has made my smart trainer a dumb trainer, and I’ve used both on Zwift, I hope they find the cause quick and can fix it. I know these things happen but the QA/QC for something like this is the main reason we have a smart trainer and Zwift, ITS A CORE REASON WE PAY FOR THE ZWIFT EXPERIENCE!


Testing has been outsourced to us, the paying customers.

A deployed show stopper like this raises questions concerning CI/CD processes at Zwift.

In three weeks there’ll be the UCI CYCLING ESPORTS WORLD CHAMPIONSHIPS… or…


Understood, but was your speed (mph or km/h) about correct going up the 10% gradients, or was it same speed as if you were riding on flat ground?

My speed was falling back but you just don’t feel the slopes! Like your trainer difficulty is put to 0%

1 Like

Im currently riding and ERG didn’t work, but mid ride I got a weird power dip and now ERG is working again, like they have done a server side change.

Same. Tried to do a Workout after doing the Update but ERG Mode failed to work. Also getting a frozen Drop Counter, it flashed for a while but drops did not increase and later on the Drop Counter stopped flashing at all.

Same here, ERG mode issues after the update.

Win 11 Pro, Tacx Neo 1, Anself ANT+ Dongle.
After some restarts (Zwift, Trainer, PC) I unpaired all devices in Zwift and reconnected them via BT and surprise, surprise … ERG is working again without issues.

Anyway, please fix this asap. How is it possible to break something that was working flawlessly for years?

Hello all,

Thank you for the very detailed comments in this thread. We are working on this right now. In the thread, I see a few reports that may fix the issue:

  • Disconnect and reconnect your trainer as Controllable in the Pairing Screen
  • If possible, switch from ANT+ to Bluetooth as a pairing method
  • Run a spindown calibration in Zwift (not available on all trainers)

I will update as I get more information.


For what it’s worth, I received a reply to my support request this morning. they say they’re working on a fix, but no ETA on when that will be delivered. Just “very soon” but who knows what that means.

1 Like

have the same problems

  • Windows11 with ANT+ FE-C
  • Elite Direto
  • Data reading works fine
  • no control over the power possible (ERG/manual)
1 Like

Same for me
Garmin Neo 2T
Windows 11
ANT connection

Since update today (1.33) ERG mode is not
Longer available

Just to add my findings on this topic:

MacBook Pro 2014
Big Sur 11.7.3
Latest Zwift update
Ant+ Dir XR - Contollable, Power, Cadence - No ERG control

Bluetooth Dir XR- Contollable, Power , Cadence - ERG successful, workout - Twenty Torch

iPad Pro 5th Generation 2022
OS 16.2
Zwift Version 3.43.0
ERG successful, workout - Twenty Torch.

Hope this feedback helps.

same here, but with

  • Win11
  • Elite Direto
  • Ant+ FE-C
  • repairing, restart, calibrating etc. did not help

With RGT oder Garmin EDGE it works fine

My setup is similar… have you tried bluetooth yet with the direto?