Trainer Resistance | Trainer Difficulty too low, Simulation and ERG mode do not work [January 2023]

After update * PC: v 1.33.0 (1.0.107174) January 25 2023 Tacx Neo connected to ANT+ does not work on trainer simulation mode neither ERG mode. It seems to work on on dumb mode at 0% grade. It was working flawlessly for years prior this update. Any guidance to troubleshoot?

9 Likes

Same, Saris H3

2 Likes

ERG not working after update. on a Kickr with Assioma pedals. Has worked flawlessly until today - only change was the update. Toggling the ERG on and off did not fix the issue.

4 Likes

All sorts of people on ride I did earlier tonight said they’re having simulation / resistance issues… Kickr, Saris, Tacx… not trainer specific.

4 Likes

Lots of people reporting this in the update thread for 1.33 over in the What’s New forum.

Sim mode is okay for me but erg is not.

Windows 10 via Bluetooth

Super excited and grateful for the updates!

That said, since the update, ERG doesn’t seem to work—anyone else? I know people hate ERG, but I love the accountability. Had to keep myself honest today :rofl:

1 Like

Anyone else have ERG mode just not work at all on any type of workout? I have a Kickr v5 and workout basically everyday (rest day yesterday). Last worked just fine last weekend and i can’t get it to work at all after the update. Game and Companion says it is enabled, but it definitely is not…

3 Likes

I’ve tried using the buttons on the game and in the companion app and it just does nothing.

2 Likes

Trainer difficulty would have no bearing on the “structured workouts” area of Zwift UNLESS you are NOT using ERG mode during them OR if you are using the term “workout” as a means of referring to any standard sim mode ride?

Apparently there is a Reddit thread where more people are reporting the same thing…

ERG mode is 100% broken in this update. I’m (at this moment) in the middle of a Z2 workout, riding at a steady cadence, and can’t keep a stable wattage.

It’s especially bad during rest intervals. Impossible to stay within boundaries without hyperbolic soft-pedaling.

As a data point, this is with a Tacx Neo 2T

7 Likes

@Richard_Barnhill and @Bret_Giuliani_RtR when the workout is selected, there is an option at the bottom of the screen that says “User ERG mode”. At the risk of sounding like a troll, is that option enabled? It may have been checked off by accident, and it’s easy to miss.

1 Like

@Mike.Winfield It was checked in my workout and still did not work.

2 Likes

Haha, no worries, I am in software development, so I know the drill of adking the obvious questions first!

Yup, made sure that was checked. In the workout, the game screen menu and Companion app both said ERG on.

I thought it was maybe because it was a custom workout, so I tried a Zwift one, same issue.

I restarted my PC, same issue.

Made sure Companion app also got the update, it was up to date.

I tried pairing and repairing my equipment, all good.

I probably have the most vanilla setup out there.

HP Laptop, Windows 10
Kickr v5 paired via ANT+ dongle
Google Pixel 3a running companion app

Not sure what other specs are worth sharing?

3 Likes

Same issue I’ve reached out to support regarding Erg mode. I have a Wahoo kicker core. I have uninstalled and reinstalled Zwift. I have run a spin down on Wahoo… no updated needed and the spin down worked fine. Shut down the Wahoo app restarted Zwift and everything connects but clearly there is a higher set of resistance on the trainer as I try to do the spin down on Zwift and it is ridiculously hard. So I’m not too sure if it’s Erg mode or just the connectivity to the trainer. Clearly something is not right.

3 Likes

Same issue for me, ERG mode broken after 1.33 update. Windows PC and Tacx Neo

1 Like

@Richard_Barnhill I’m finding ERG mode to be working when I connect to the trainer via ANT+.
Let’s compare our environments. You’ve shown me your environment, here’s mine:

Zwift game app running latest release (1.33.0) on generic PC, Windows 10
KICKR v5 paired via ANT+ dongle
Google Pixel 3XL running Zwift Companion app

Those all seem to match, but there could be nuances. As you may know, on ANT+ these trainers can show up as two separate devices: “Power Meter” and/or “FE-C trainer”. I chose the FE-C trainer device for Power, Cadence, and Controllable Trainer.

Also, to simplify the testing, I turned off the Bluetooth support on the PC.

@Darren_Beams Please refer to my discussion with @Richard_Barnhill for any related information.

It would be helpful to know if you are connecting through ANT+ dongle or through native Bluetooth or through Zwift Companion BLE Bridge. Also, when using Zwift outside of a workout, do you feel increased resistance riding uphill in the game world? These answers can help us to isolate the issue.

I too tried swapping between FE-C and Power options, but didn’t see any difference… Humm…