Trainer Resistance Issues (Mainly on iOS Devices)

trainer
resistance

(Devin Knickerbocker2522) #122

I used to have an issue where, after i calibrated my elite direto, it suddenly stopped registering resistance from hills. Resistance would change slightly but not nearly enough (e.g., 10% would feel like 2% etc.)

And, it seemed that the watts displayed were low relative to my Stages (on my CX bike) and my power2max (on my MTB).

the resistance problem was solved by getting an ANT+ dongle and connecting directly to the PC rather than using BLE through the iPhone. No problems now and zwift works as intended.

However, the Elite trainer still registers low in comparison to my other PMs, to the tune of a good 15 to 25 watts or so. This may not actually be a bug, it could just represent resistance in the system, heat loss, other efficiency loss, etc., due to the fact that the Elite measures at the rear “wheel” whereas the other PMs measure at the crank.

However, in order to maintain consistency, I have paired the trainer as the “controllable” speed sensor, but separately paired a PM as the power source. Easy peasy lemon squeezy.

  • Your exact trainer (including the year if applicable) Elite Direto (2017 model)
  • The device you’re using to run Zwift iPhone 6 previously (through companion app); now directly on PC using ANT+ dongle
  • BLE or ANT+ connection? ANT+
  • Zwift Game version most recent
  • Trainer Firmware the latest provided by Elite
  • Sim or ERG mode Sim

(Peter Castrop) #123

Tried a workout today. Seemed to start okay, but after 14 minutes the resistance became so high I could not turn the pedals anymore.

On free rides I still get resistance issues, like gradient of 2% feels like 10%.

I would like my money back. This issue started in September. I don’t want your socks or sunglasses. I just want it to work.


(Natalia Nadkańska) #124

Hi Guys!

Maybe someone here could help me.

The problem is I feel almost no resistance while climbing :thinking: Even though I set the slider to MAX (when it comes to “Trainer Difficulty” option in settings). But when it comes to downhills, I slow down a bit.

I tried to pair and unpair everything a couple of times… :disappointed_relieved:

  • Your exact trainer (including the year if applicable): Elite EVO (2018)
  • The device you’re using to run Zwift: PC using ANT+ dongle; I use also companion app
  • BLE or ANT+ connection?: ANT+
  • Zwift Game version: most recent
  • Trainer Firmware: the latest provided by Elite
  • Sim or ERG mode ERG

Any ideas? (Thanks in advance!)


(Godmother Fox) #125

Natalia, as far as I know (correct me if I’m wrong), there is NO climbing/downhill simulation while you are in ERG mode.

In ERG mode your trainer keeps wattage according to workout setting … no matter what gradient of the road is. If your workout says, for example, 80Watts, then trainer sets 80watts and it doesn’t matter you are currently on flat road or steep climb. Conclusion - there is no relationship between watts and the gradient of the road in ERG mode.

You should be in SIM mode to get simulation of the road - then trainer changes resistance according to gradient …


(Natalia Nadkańska) #126

Thank you! (I’m still a newbie…) :flushed:

So, to sum it up:

  1. ERG mode =
  • makes me hold particular wattage during my training;
  • has nothing to do with resistance (example: even if I ride uphill I don’t feel any resistance, because it’s all about keeping particular wattage)
  1. SIM mode:
  • trainer changes resistance according to gradient (so I should feel there’s uphill);
  • good to use it when free riding than doing particular workout/training

And one more question (it may be stupid :sweat:): Does SIM mode have a… hmmm… special icon to turn it on? OR Am I in SIM mode just when I uncheck ERG mode (and that’s it)?

Thank you in advance for the reply!


(Godmother Fox) #127

Yes, You got it. Note, I’m quite a newbie, too, so take my advice with “some salt” :wink: but I honestly believe I’m right (if I’m not, then I hope somebody more educated will correct me) :slight_smile:

ERG mode = you (or your workout) say what wattage/resistance you want … if you set ERG and wattage to, let’s say, 60Watts, trainer keeps resistance at 60 watts no matter what’s going on … you can change gear, you can change cadence … and trainer still keeps resistance at 60 watts …

… and, of course, in ERG mode there is no relationship with track/gradient/surrounding at all … trainer is set to 60 watts resistance and it keeps it. It doesn’t matter if you are currently on flat road or climbing to Alpe de Zwift or even going downhill. What is variable is your speed, but resistance of trainer is still the same. It may sound weird, but in ERG mode (which is mostly workout mode) the surrounding is just for our entertainment/fun.

Some useful info can be found here: https://zwiftinsider.com/erg-mode-in-zwift/

SIM mode is actually Free Ride - your trainer behaves as a normal bike on the normal road. Hard to climb, easy on flats, even easier on downhill … resistance changes depending on the gradient. Your speed changes depending on gradient and your effort (how many watts you currently produce).


And one small addition to ERG mode - in Zwift Companion App you have an option to change “classic” ERG mode to INCLINE mode. Actually, it’s the same … the resistance is fixed (doesn’t respond to road gradient). Instead of Watts you just set Degrees of slope (which is just another name for some # watts) …

you can find more information here https://www.smartbiketrainers.com/five-things-know-new-zwift-companion-app-4626 .


(Natalia Nadkańska) #128

Thank you, Godmother_Fox!

I read both articles couple of days ago, but I thought that I still do something wrong.
Maybe I should just “play” more with the settings… :thinking:

I just had/have that feeling that I had no problems with the settings when having trial version of Zwift; but when I paid for a membership… hmmm, I felt like something went wrong and my settings just got dysregulated :sweat_smile: (But maybe it was just me who messed up somehow with the settings… :grimacing:)

I guess, I will try different settings combination and check what feels right for me!

Godmother_Fox, once again, thank you for your help and patience!


(Godmother Fox) #129

You are welcome! Don’t be focused on all those settings and options too much :wink:

  1. do you want to enjoy the simulation of “real road”? Then jump on your bike, choose Free Ride and go … you choose the track, you choose your gear/cadence/tempo, you choose if you ride hard (put more watts) or easier (fewer watts) … everything is up to you. Actually, I like those free Rides the most - my favorite feature of Zwift.

  2. do you need some more serious/exact training? Then choose some Workout and start it … and you are in ERG mode … all you need to take care of is pedaling …

that’s all … The most important thing is … Have a fun! :wink:

GdF


(Jamie Bishop Crescent CC) #130

Hi @Jon , since the latest build that came out on Saturday (1.0.32268) I’m now suffering from the original problem again. I rode in Sim mode on NY on Friday and everything was as expected. Lined up for the Fondo on Sunday morning and no resistance or road feel on my Neo. Once I’d finished the Fondo I quit Zwift on the tv and relaunched and did a small sim ride and resistance was back. I’m hoping that in the latest build the bluetooth patch hasn’t been missed off.

It was pretty disappointing to have to ride the whole Fondo with no simulated gradients, I tried unpairing and repairing the trainer during the ride but it dint help. Starting again wasn’t really an option with it being an event.

Kind Regards Jamie


(Lin Alan) #131

Did you force quit Zwift after your ride on Friday night? I found out a long time ago that force quitting Zwift after each ride was way to go. This eliminated some odd issues.

Did you do a ride on Sunday morning prior to the Fondo? For example, you rode around for 20min. Saved the ride and returned to the rider selection splash screen. Then, went right back into Zwift for the Fondo. If so, I found this on occasion causes oddities. As a result, I would recommend: 20min ride, save, force quit Zwift. Relaunch Zwift, join Fondo.


(Jamie Bishop Crescent CC) #132

Yeah always force quit it as I too have found if you don’t it can hang onto the BLE connection and cause issues. Sunday was a bit chaotic, I had signed up in the companion app but once it Zwift it wasn’t joined so had to quit and rejoin with about 3 mins to go. Maybe this stuffed it up. Still a bit annoying, I’ll keep an eye on it and see what happens with events.


(Willem Kool) #133

I used to use a Tacx Bushido. Since I use a Tacx Neo the average power has dropped from 185 W to 145 W consequently.

Tacx Neo 2018
Ipad Air (iOS 12.1)
BLE
Zwift 1.0.32268
Tacx latest version
Sim


(Jamie Bishop Crescent CC) #134

Hi, that’s not got anything to do with this BLE issue and resistance drop outs with Zwift and iOS. That’s because the Neo is very accurate and your bushido wasn’t. My Neo is identical to my P1 power pedals, my previous 1st gen kickr read 20-30w too high in comparison.

Cheers Jamie


(Willem Kool) #135

Thanks Jamie for your information. I am very disappointed that I am not as good as I thought I was (ha ha).

Cheers Willem


(Jamie Bishop Crescent CC) #136

I know I went from a race winning B to a mid pack C but at least it’s real


(Lin Alan) #137

I think I read somewhere that if you start Zwift with less than 5min to go, the auto join dialog for the event will not pop-up. If so, I am not sure of the logic behind that design choice. :man_shrugging: