Trainer Resistance Issues (Mainly on iOS Devices)

trainer
resistance

(( C)raig) #102

Hello @Jon, I have updated, but still had ERG issues after about 30mins in a group workout today. So I linked as you suggested, KICKR directly to AppleTV (no HRM or cadence). However, I am now unable to use the Companion App at all, when it starts it thinks I’m in a ride, and when I click ‘save’ or ‘discard’ it crashes the App on the AppleTV, see the video:

I have deleted the Companion App and reinstalled from App Store, but I get same issue 100% of the time.

Please can someone look at the ticket.


(Jamie Bishop Crescent CC) #103

@Jon I installed the latest version on my TV yesterday and did a Sim ride and then a race (THE CHOP) on my Neo with TV and it worked as expected which was a nice change, hopefully the latest update has fixed the bug for me.

One thing that I do always do though is force quit the Zwift app on TV when finished otherwise it hangs onto the bluetooth connection which I think causes issues. Even with the TV put to sleep it seems that it keeps hold of the Neo (BLE) because if I open the Tacx app on my iPhone it cannot connect to the Neo (BLE) until I actually force quit Zwift on the TV or power off the TV fully and which point it connects and can control it.


(Lin Alan) #104

@C_raig Are you force quitting Zwift between sessions? If not, I highly recommend it. Secondly, if you’re not pairing anything via the companion app, try waiting until after you see your avatar before starting the Companion app.


(( C)raig) #105

Yes, I force quit, and restarted Apple TV, restarted iPhone, no devices connected to Companion App, just KICKR connected to ATV. It seems companion thinks I’m riding,but ATV doesn’t? Zwift App on ATV crashes every second time I press save ride/discard on companion App,


(Lin Alan) #106

Bizarre! As a hail mary, try deleting the companion app from your iPhone and the Zwift app from the AppleTV, power cycling them both, then reinstalling the apps. ???


(D rew CINCH BOOM) #107

Zwift support has not responded to my recent emails with updated log files documenting the wild resistance changes on all these computers and trainers. I can jump on Trainer Road and get a normal workout no problem. At a minimum it would be nice to know that Zwift acknowledges it identified a problem and working to fix it. My brother in NY on a Wahoo Kickr is experiencing the same issue. No resistance changes on hills and random increase / decrease of resistance regardless of terrain.

Does Zwift identify this as a problem and are they working to fix it?


(David Gibbs (Red Rider)) #108

I spoke too soon.

It worked yesterday for a very short workout … but when I tried to do a workout today it started OK, but lost connection to the sensors about 10 minutes in. When I got the sensors reconnected, Zwift refused use ERG mode. It was calling for 85 watts but I was riding at about 120 watts.


(Lin Alan) #109

Zwift definitely acknowledges that a problem exists. This whole thread/topic is proof of that. Furthermore, Jon Mayfield himself commented above:

I like yourself and many others have zero issues w/TrainerRoad or other software. The latest update seems to have fixed things for some users. However, it looks like many are still having problems. I expect that another update will be available before too long. In the meantime, patience and keep sending log files?!

If you go with the Kickr with no cadence and no HRM, can you get through a ride? Also, I assume you’re on Bluetooth. ANT+ is a great workaround if it’s an option. I have no issues if I switch to ANT+.


(( C)raig) #110

I’m wondering if Zwift as a company actually uses the iOS/tvOS/BLE setup in their marketing/demo rigs on the road? If I search online for Zwift, I see the Apple TV and tablets appearing in 50% of their promotional images and videos, but do they actually use it themselves outside of photo shoots? My guess is they use PC/Ant+ in all their rigs?

Maybe I have made a wrong decision in my hardware choice. Zwift was working for me last year, I lost a couple of rides due to Zwift server issues, but it was new device for Zwift back then, no big deal.

I was, however, expecting this years Zwift experience would be better on AppleTV, taking into account the 62% subscription price increase vs last year, and assumed further development and testing on iOS/tvOS would have created a better product/service.

Support are unable to help as I can’t send them log files (even though they have asked for them, and they know I am running on AppleTV!!).

I wanted a ‘plug & play’ setup, at moment I have a ‘plug & pray’.

The Zwift experience is really good when it works, but its just not working for me at moment, both ‘in game’ and ‘customer support’


(Lin Alan) #111

I too am on AppleTV 4K. However, I have only lost resistance during free ride (simulation) mode a few times. Most of the complaints here in the forum appear to be with ERG mode or sensor connectivity. I have never used Zwift ERG mode and my sensors all connect up w/out issue. (knock on wood!)

I am sure they have AppleTV in their lab and for QA testing. I doubt that is the problem. The problem is that they broke something in an update this summer that affects some people more than others. In my case, 99% of the time I have zero issues. However, I have seen others w/the same setup (AppleTV and Neo) who cannot seem to get thru a ride. I work in software and feel for Zwift but at the same time as a customer, this is *#$#. Hopefully, they get this sorted sooner than later!


(( C)raig) #112

Zwift support still not helping me, taking 24-48 hours to reply to my emails, and then they are just template answers, saying I need to check my WiFi, even though I told them that is OK.

I think I have solved my Zwift issues with tvOS/iOS/BLE. Checking the forum, it seems there have been issues since June this year, still not resolved. I don’t have time or patience to wait for a fix, I have no confidence when @Jon says its a ‘hack’ to get the BLE working with Zwift Companion App.

My solution? I purchased a reconditioned Dell Alienware Alpha from eBay, install windows 10 on SSD, plug in Garmin Ant+ dongle, and am able to complete a workout successfully and ride simulated gradients. Graphics not as pretty/smooth as AppleTV, but that’s not important, its the core reliability - connectivity / ERG / uploading that’s a must for me.


(David Gibbs (Red Rider)) #113

Yeah, I’m experiencing the same thing.

Told them up front I was using using Apple TV and their first question was: What platform are you using?

Sadly, It’s a standard refrain with consumer tech support.


(Terry Cheng) #114

Tried this yesterday and left it idle for about half an hour and it appeared to keep the connection. I’ll continue to test it and see how it goes. This was done using the Wahoo speed / cadence sensor which was previously giving me the drop outs too.


(Laura Tanner) #115

Hiya, I am still having problems with my 2017 Wahoo Kickr and Zwift. I seem to have sorted the random power dropouts for now, but I am not getting any resistance changes. I have deleted all wahoo apps for now and all sensors are running through Ant+ I have checked it isn’t in ERG mode. Also I uninstalled then reinstalled zwift on my laptop. No change. Any suggestions?


(Adam Shepard) #116

I have a Kickr Core that I’ve been using successfully on Mac OS for some time. I just recently switched to using an Apple TV 4k, and am now having resistance issues. Today I was pedaling up the radio tower road in the big front chainring just spinning away with little resistance, but then it became challenging to pedal on the descent. After reading through this thread, it seems that a fix was supposedly in place… Does that mean this issue is still being investigated or not?


(Godmother Fox) #117

Just out of curiosity, how did it happen You rode Watopia (radio tower) today? You mentioned You are on Apple TV now, and as far as I know, there is no way how to use world tag hack there …


(Adam Shepard) #118

It was a group ride, and sometimes group rides take place in other places.


(Brangerud Sportsklubb) #119

I have the Elite Direto with Ant+ to Pc. Have had the trainer for some weeks but now the resistance wont work. Have tried different troubleshooting but have not managed to solve it, Please help`!


(Andreas Grønneng Hjelme) #120

2018 Kickr Snap. Installed an run trough my MacBook. Not getting resistance changes. Not able to spindown in Zwift.

Nothing paired to Wahoo app, Game re-installed.
Worked fine untill one week ago.

Everything works fine if i play on my iPhone.
Help :confused:


(Henk de Beer) #121

2018 Cycleops H2, and using an Android tablet (Teclast T8, would love to use my new Mi Pad 4 but is just shows a black or red screen).

The trainer pairs fine with Zwift, reports power and cadence, but no resistance changes.
On the same tablet, my old Vortex Smart worked fine on Tuesday.
And with Rouvy on the same tablet, the H2 works perfectly (I tried this after my ride on Zwift, so no chance of it still being connected to Rouvy).

I need another 2km or something for the last week of Ride for a reason, then I’ll stick to Rouvy until there is a new Zwift update.