Trainer Resistance Issues (Mainly on iOS Devices)

trainer
resistance

(Jamie Bishop Crescent CC) #41

@Kevin this is latest I had this morning from a Tier 3 engineer.

"Using your Mac with ANT+ is definitely not the solution, but is a suggested workaround for the time being.

Unfortunately, we do not have a timeline for a fix since we’ve been unable to find where the issue lies. I know this is not the best news to pass along, but I assure you that this is something we are definitely looking into. I do appreciate any information you can pass along, as it will help us investigate further."


(Kevin Lewis) #42

Thanks Jamie. Given my ability to reproduce this, and my 30+ years experience in low level software, if you ever need someone to test a debug build via TestFlight on ATV4K, I’d be more than happy to run it and pass back results. Comfortable with Xcode debugging via Wifi, so grabbing Console logs is trivial. Just trying to help!


(Clive King [KRT]) #43

My feedback:

Your exact trainer (including the year if applicable)

TACX T2800 NEO August 2016 (approaching 400+hours) AC Powered

The device you’re using to run Zwift

AppletTV 4K

BLE or ANT+ connection?

BLE with Tacx Neo and Wahoo Tickr HR or Tickr Fit HR

Zwift Game version

Latest Version: NYC Update

Trainer Firmware

0.2.1/0.74/0.8.4

Sim or ERG mode

Sim and ERG mode. Have some issues with ERG not working when going from SIM (Warm up) into group Workout (ERG) without quitting Zwift and restarting. Otherwise no known resistance issues in game for SIM group rides and races.

Setup also includes:

using BLE from Android Phone (also running companion app) with BLE BOSE Headphones
Using Fans with 2,4Ghz wireless remote
5GHz Wifi Connection with 3rd party TPLINK VR900 Router running 5GHZ and 2.4GHZ WiFi networks (very reliable) - 70MB/20MB EE Fibre Connection (Very reliable)

Periodically hard turn off AppleTV otherwise left in sleep mode. No 2.4Ghz Wireless phone in house. Other BLE devices are present but not paired to AppleTV.

Note* after TVOS 12 update, I had AppleTV hang issues; Blackout on screen until hard off/on.


(Vincent W.) #44

Pretty much what @Jamie_Bishop_Crescen said but I hope to get a significant update soon.


(R O G H A I R) #45

Updated for the new york course and feel no resistance now on hills
-magnus 2018
-iphone 8
-ble
-newest version of zwift
-trainer up to date
-sim mode


(Alex Obelink) #46

Same issue.
Wahoo kickr/ipad combo. Power drops

Not having issues with other softwares…defenitly. Zwift issue


(Chicken Little) #47

I noticed the issue in late July. For me the issue has been mostly related to joining group rides. I sign in to Zwift and free ride and everything seems fine. I usually ride for 10 min then do a spin down and ride for a few more minutes to make sure everything is working. Then I join a group ride, and when the ride starts, no resistance change on the hills. I have noticed recently that if I join the group ride within a minute of the start, it seems to work, but if I join with a few minutes to spare and ride the virtual trainer, I usually get not resistance on the hills once the group ride starts. Just my observation.

My details:

  • Your exact trainer (including the year if applicable): Wahoo Kickr 2017
  • The device you’re using to run Zwift: MacBook Pro macOS Mojave 10.14
  • BLE or ANT+ connection: BLE
  • Zwift Game version: most recent version (1.0.31087?)
  • Trainer Firmware: most recent
  • Sim or ERG mode: Sim

(Matthew Papapetrou) #48

Your exact trainer (including the year if applicable) - Wahoo Kickr 18’

The device you’re using to run Zwift - Ipad Pro

BLE or ANT+ connection? - BLE

Zwift Game version - 1.0.30934

Trainer Firmware - KICKR '18 Firmware v3.4.68

Sim or ERG mode - Sim


(Luke Foley WBR B) #49

Trainer: Wahoo kickr core
Device: Apple TV (4th gen)
Connection: BLE
Zwift game version: 1.3.30327
Firmware: latest from Wahoo
Mode: sim

I recently did a ftp test workout and when it actually came to the 20min test my wattage was fluctuating between 220 330 so It was hard to gauge what wattage I was actually riding at.
Also my connection through the zwift companion app would loose connection after about 15 mins. I didn’t have any other apps open on the I phone or the Apple TV. I don’t have any other platform to run zwift on except Apple TV and I phone(don’t want to run on I phone as tiny screen). I followed the support page instructions about loosing signal still no joy. Looking for help thanks
Luke


(Richard Harman) #50

Looks like we’ve been discussing this for quite a while - I hope this get fixed soon. I have wahoo kickr 2018, & connect thru apple tv. Zwift version updated yesterday. Trainer firmware also updated 10/30/18. everything has been working great until Tour of NY stage 4 day. No resistance changes on gradients. It’s set on “just ride” or SIM mode. When I did my short Halloween ride in watopia to check out my ultra cool bones bike, the gradient resistance was working again. Now this morning on NY stage 5, the issue had returned. I’ll experiment with some workarounds, but when i purchased everything, I was under the impression this was a solid combination of technology and equipment. works ok in wahoo fit app.


(Chenli Tan) #51
  • Your exact trainer (including the year if applicable)
    Wahoo KICKR 2015

  • The device you’re using to run Zwift
    Mac + TV

  • BLE or ANT+ connection?
    BLE connection

  • Zwift Game version
    1.0.31423

  • Trainer Firmware
    1.5.68

  • Sim or ERG mode
    Sim and ERG mode

Can’t calibrate either, it won’t spin down till zero and then timeout and calibration failed.


(Peter Castrop) #52
  • Your exact trainer (including the year if applicable)
    Elite Direto December 2017
  • The device you’re using to run Zwift
    Ipad or Mac
  • BLE or ANT+ connection?
    BLE connection (have tried ANT+ but didn’t solve the problem)
  • Zwift Game version
    Ipad version 1.0.31304
  • Trainer Firmware
    The latest (there have not been any firmware updates. All Direto trainers have the same firmware)
  • Sim or ERG mode
    Sim mode

Zwift Power sticks and stops tracking hills
(Vincent W.) #53

New Update: Quality Assurance has reproduced the resistance issues for a few trainers and we would like everyone to try unpairing cadence sensors and see if that makes a difference. For Kickr users try unpairing everything but the Kickr.


(Terry Cheng) #54

So unpair the cadence so it is not measured? For my Kickr Snap,using a Wahoo Blue SC speed / cadence sensor looses the resistance after approx. two minutes.

Using a cadence only sensor (like the Garmin one) ensures that the resistance doesn’t drop out


(Andre Beley 8544) #55

The problem appears to be common with BLE. I have 2017 iPad, Wahoo Kickr 2, wahoo HR and Wahoo cadence sensor. All have the latest software versions loaded through Apple updates and Wahoo app.
After about 15 minutes on a ride through NY, the power on the Kickr locks on a specific power - could be any place “uphill or downhill”. The only way I’ve found to fix it is to close the Zwift app completely on iPad and start it again. Zwift then takes me back to race start and places in a rear position in the ride, (which is rather concerning). In my testing, all BLE devices work again.
I’m not sure if this is only the NY route, but have only experiencing this on NY route. I’ll test when routes change - I assume soon.


(Kevin Lewis) #56

Hey Vincent, thanks for the update.
What does this mean for us Neo owners? The cadence sensor is integral to the Neo. Do you mean that we just unselect Cadence in the Zwift pairing screen?

Is there a theory you could share with us that the Zwift dev team are working on to explain this loss of resistance behaviour? Does it explain the apparent start date of this problem in June?


(Clayton Bigsby) #57

Add me to the list…1st. ride this season in NYC world …My manifestations were spontaneous resistance changes… 1% to 3% felt like 1% to 12% or more…Then other times climbing steep grades in tall gears with little resistance.
Just unpredictable and all over the place …no total drop outs though…even took a couple short breaks with no drops.
Elite Direto December 2017 only firmware available Calibrated before ride (after warm up)
iMac running 10.13.6 hard wired internet connection 100+Mb/sec connection
HDMI to 55"TV running game at either 1440 or @4K quality
Zwift Companion on 2017 iPad Pro
BLE
Game ver.1.03.1423
Sim Mode
Wahoo BLE HR monitor
Bontrager Duotrap S BLE & ANT+ speed and cadence sensor


Gradient of 1% suddenly feels like 5% on Direto
(John Cordner) #58

I have been having this issue also. I am new to Zwift having recently got the Kickr 2018 model. It seemed fine when I first used it on the Innsbruck and Watopia course but I think I first noticed it with the New York course. I have been using a MacBook Air 2015 over BLE with the supplied wahoo cadence sensor. After the first time it happened I realised there was a firmware update for the kickr so I updated it then restarted the Macbook and Kickr and it seemed to work fine. Yesterday however before riding I checked there were no updates and started a ride but noticed the issue was there. I stopped the ride restarted the MacBook and kickr again and this time it was fine.
However I have also been having an issue with the selection buttons which don’t always respond to a single click when I think they did before. I’m running the latest Zwift software on the MacBook which is running macOS High Sierra 10.13.6 and haven’t upgraded to Mojave yet.


(Marcus Fahy) #59

Similar experience here:

13" MacBook Pro with Mojave (10.14.1) with all updates applied
BLE connection to: Tac X Neo & Wahoo TICKR HRM, latest firmware on both
Zwift game version 1.0.31423
Companion App on Samsung Galaxy S8+

Doing workouts, resistance works initially with ERG mode on then drops off, similar when just riding, hill resistance stops working after a while. The wattage comes through consistently, it’s only the controlling of the resistance that ceases to function.

For instance on the McCarthy Special, the resistance works as expected during the warm up and the first three intervals, however fails to decrease the resistance following the third interval. Attempting to disable and re-enable ERG mode while still in the workout doesn’t resolve the issue.

I was going to purchase an Apple tv 4k, however given these issues, I think I’ll hold off for now.

EDIT:
I done another spin yesterday evening (The McCarthy Special) and when using Ant+ to connect the Neo and TICKR to Zwift on the MacBook Pro, everything worked as expected.


(Kevin Lewis) #60

I tried the suggested approach of not pairing cadence on my Neo and Apple TV, but it did not resolve the issue, I still had no resistance changes and no road feel.

Here’s what I did in more detail.

  1. Started Zwift.
  2. It automatically picked up my Neo and Tickr, and paired all of them, included Cadence.
  3. I unpaired Cadence.
  4. Started Zwift, and selected Join for my 16:45 ZBR ride (the time being 16:20)
  5. Went upstairs to change, wearing my Tickr. This is well outside Bluetooth range.
  6. Came back downstairs to ride. The Tickr is still paired.
  7. Rode, but without resistance change and road feel from the beginning.

The pattern of me going outside bluetooth range with my Tickr is common and I wonder if this may be contributing to the problem. Merely unpairing the cadence sensor was not sufficient to resolve the issue for me.

As ever, I’m always happy to run a debug build on my ATV to help diagnose this.