Tour de Zwift won't launch into game


I have been trying to get into stage 8 of this series for 2 days. When any category is selected and you click on start ride nothing happens. Other rides I am able to get into but not this one. I have tried relaunching the app and computer to no avail. Any insight would be much appreciated. Thank you!

Hi @Lucas_Chandler, welcome to the forums.

Sounds like you are using a PC, is it windows? Did you get the new launcher installed with the recent update?


I am having the same issue. I have Zwift app installed on Apple TV. It worked flawlessly until this past Wednesday, when screen blacked out after a ride started. I restarted the Apple TV, ran an update and restarted. Now I am unable to start Tour de Zwift Stage 8, even after selecting route and scheduling ride. When I click on start, nothing happens.

That’s exactly what I am experiencing except I am using a Mac.

I’ve seen references to this happening where a reinstall of the Zwift software resolved the issue.