There is Still a Bug That is Corrupting .fit Files on Long Rides


(Greg Gibson-Haymarket) #1

Another rider emailed me a corrupted .fit file today from a 92 mile ride that was unfortunately afflicted by the same bug that seemed to bother all of the metric century rides. I’ve been able to fix most of these files but for some reason the .fit repair tool seems to be choking on this file with an overflow error. I think it may be because of the file size but not sure…still trying but at least this rider has his Garmin data for backup.

Anyway, that bug is still in the system…

…and yes, someone rode 92 miles on Zwift today…

greg


(Jon Mayfield) #2

Yes, we’ve not fixed that bug yet. Soon. Pretty cool to see somebody go that distance!


(K I.C.K.R_Kevin) #3

Greg, did your KICKR stay happy for all 92miles?
I did a tempo 40k yesterday and on the descent at the end of lap 7 Zwift dropped the KICKR for a few seconds then when it came back i’d lost resistance control felt like it was stuck in level mode? Final lap done like that!!!
Little disappointed :frowning:


(Greg Gibson-Haymarket) #4

I was actually able to get the file repaired and it’s been posted to Strava.

I didn’t do the ride…it was a friend of mine named Scottie Weiss. he did 30 freakin’ laps!

greg


(Greg Gibson-Haymarket) #5

BTW, Kevin - I haven’t experienced that bug yet. I DO have occasional ANT+ dropouts, usually about 1 per ride that causes my rider to pause…but after a few seconds it comes back and I haven’t lost resistance. Usually when the dropout occurs if I stop pedaling for a couple of seconds it will come back on shortly after.


(En Latmask) #6

I experienced this bug today. Just finished a 100K ride and the timestamp goes bananas after 3 hours. I’ve tried to fix it but it’s too many fields to do manually.

Could someone please help me fix this?


(D W - ltb LMDGD) #7

I’ve also had the corrupt fit file problem with a couple of 3 hour rides and would love to get those file repaired. I tried an automated tool posted by Greg but it didn’t seem to work as the fixed file was tiny.


(Greg Gibson-Haymarket) #8

Walter - email me your corrupted files and I can probably fix them for you.

greg at greg gibson dot com


(Greg Gibson-Haymarket) #9

Anders - email me your file also. I can fix it.

See post above for email address.

greg


(Jeff Abbott) #10

I think I got this same bug too. I rode 56miles on Saturday. I stopped at 90mins to refill my bottles. When I uploaded it to Stava, the file cut off at the 90mins (27miles) and missed my other 30miles.


(Frederic Ranger) #11

Hi Greg,

Hit that corruption bug today on a metric century ride. Greg if you don’t mind l’ll email it to you to see if you can work your magic on it.

 

thanks,
Frederic


(Jon Mayfield) #12

Frederic, if you can open a support ticket and attach the fit file that’d be very useful to us. Thanks!