terrible framerate after 1.0.5450 update


(Mike Blaszczak) #1

After upgrading to 1.0.5450, I’m finding that the frame rate is terrible. Before the update, the game was very much playable on my laptop. Now, I’m getting less than 10 fps – probably around 8.

There’s no documentation, so I can’t find a settings dialog. I was hoping to turn down detail or distance rendering, or something. How can I troubleshoot this issue? Is there a settings dialog where I can reduce the rendering settings? Is there a debug display overlay that will show the exact framerate?


(Scott) #2

Hi Mike - we introduced the new Settings menu in the release notes for the big update last week. You can also find instructions here. Try turning down the Game Resolution. We’d love to know the details of the laptop you’re running.

Please log a support ticket if the issue persists. Thanks!


(Jon Mayfield) #3

In our logs I see you had a ride on 1.0.5395 at 6fps on Monday and a ride on Tuesday on 1.0.5450 at 6fps as well.   Most often, however, you run ~20fps. It seems like the PC itself is having strange performance characteristics that aren’t actually tied to yesterdays update.

A few questions to consider:

- If your PC is a laptop, was it plugged in?  Often graphics performance can double or triple when plugged in.

Have you rebooted in the past 2-3 weeks?  If not, sometimes that can help, specifically with NVIDIA drivers (which you do not have).

Were there any other graphics anomalies that could have caused the issue, such as gigantic plants all over the road?


(Mike Blaszczak) #4

Hi, Scott.  Thanks for your post.

The release notes say the setting dialog is reachable from the “pause screen”. But I can’t find any documentation that tells me what the pause screen is, or how to reach it. Can you help with that, please?


(Mike Blaszczak) #5

Thanks for your response, Jon.

Indeed, the problems might have started with 5395; I don’t always notice when Zwift installs updates since I have so much to fuss with before my workouts. (I used to get some water and then ride. Now, I’ve got to make sure my ANT+ gear has good batteries, my Garmin is charged, I have electrode goop for my heart rate monitor. Then, I make sure the internet connection to my house is up, and I update Windows, check my drivers, charge my laptop, login to Zwift, let that update too. I might have to do a firmware update for my PowerTap Hub, or download an update for my Garmin. And so on.)

My laptop is a Lenovo Carbon X1 ThinkPad. There have been several generations of this model over the years; if you’re looking at Lenovo documentation, I have a “Type 20A7” model. The machine runs Windows 8.1, has 8 gigs of memory, and an Intel i7-4600 CPU, and has the optional high-resolution 2560x1440 display, though I run it at 1920x1080 because so many apps have logical pixels-per-inch bugs.

The machine has an Intel Graphics 4400 display adapter. The Intel HD graphics control panel says the “3D General Settings” are in “Performance” mode.

I’ve dug around in the power management settings for my laptop, but I can’t find anything that excuses this behaviour. About a week ago, I started running on power instead of the battery because running Zwift eats my battery: a 40-minute ride takes the battery from a 100% charge to a 40% charge.

In Task Manager, I believe that Zwift is CPU bound: it’s pegging a single core. I didn’t look at Task Manager previously, so I have no baseline. (I’ve been trying to focus on my workouts instead of screwing around with all this technology.)  But I’m wondering if something in the updates didn’t cause Zwift to go single-threaded and scale down CPU usage, causing the perf problems I’ve noticed. For now, it seems I’m CPU-bound rather than GPU-bound.

How can I view the log that you’ve got? It would be much easier for me to troubleshoot my settings if I could see the Zwift framerate myself, preferably interactively.

I hope I can get this fixed; it’s been inspiring to use Zwift, but the terrible framerate and the resulting distraction is the opposite of motivating.


(Scott) #6

Hi Mike - the Pause Screen will automatically pop up if you ride for a few meters and stop (there is no hot key for it). You can also get to it from Fan View. Instead of pairing your devices on log in, click “…just watch” on the lower right of the Pair Devices screen, then click the orange button on the lower left of the screen 2x. 


(Mike Blaszczak) #7

Hi Scott!

Thanks for your answer. Thing is, why would anyone ride, then unclip to play with settings? That doesn’t seem like a very good user experience. Is the “pause” screen the “DONE” screen? That is, the button that shows me my totals, my peaks, the histograms of my heart rate and power, and then I quit?

I’d rather adjust my settings on demand, or at least when I start, rather than when I’m ready to dismount.

Thanks for the pointer, though – after my next ride, I’ll have a look. Then, I can make a change, and see how it turns out for the next day’s ride.


(Scott) #8

Yep - totally agree. There will be a way to pop the Pause screen without having to ride very soon. It will be similar to the orange button that appears if you click another rider in the rider’s list to “fan view”. 


(Al Clewley) #9

Scott,

Having not been able to ride on the Island for a couple of weeks I finally got round to entering the F8 competition yesterday. There was a noticeable difference in the frame rate on my MacBook Pro (2015) from what I’ve been used to.


(Mike Blaszczak) #10

I finally figured it out!

Embarrassingly, it ended up being a problem with my laptop.

Turns out I had a weak wired network connection, which made a background backup job take forever because it ended up running over WiFi. The network connection doesn’t matter much; but the overnight scheduled backup job wasn’t done by the time I started my workout in the morning. The backup job does a lot of compression, which sucks CPU, which hobbled Zwift.

Sorry for the rodeo, but I’m finally back to stable (and ride-able!) fame rates.


(Eric C. (Zwift HQ)) #11

Glad to hear it, Mike!